开发者社区> 问答> 正文

在父工程pom.xml添加了一段定义springcloud版本的配置,导致其他子?报错

依下是添加的代码

<dependencyManagement>
    <dependencies>
        <dependency>
            <groupId>org.springframework.cloud</groupId>
            <artifactId>spring-cloud-dependencies</artifactId>
            <version>Finchley.M9</version>
            <type>pom</type>
            <scope>import</scope>
        </dependency>
    </dependencies>
</dependencyManagement>

以下是报错详情。说另一个子模块common依赖出问题了。
图片说明
但每次只是一个或几个(不一定是哪几个)报错,其他依赖common的子模块都没报错

展开
收起
爱吃鱼的程序员 2020-06-23 14:10:47 739 0
1 条回答
写回答
取消 提交回答
  • https://developer.aliyun.com/profile/5yerqm5bn5yqg?spm=a2c6h.12873639.0.0.6eae304abcjaIB

    楼主,我也是在做十次方这个项目,到这块也是遇到了这个问题,我把springcloud版本换成了Finchley.SR1之后就可以了,
    上边那位yanJunit的说法是对的,中央仓库没有.M9这个包。
    https://mvnrepository.com/artifact/org.springframework.cloud/spring-cloud-dependencies
    换成别的就好了,我用的是Finchley.SR1

    你这个东西呢,明显是没取到dependency,或者你dependency写错了,或者是没有install到仓库里面把,你检查一下tensquare-search这个项目的pom.xml
    看看这个依赖(Dependency)

    <groupId>com.tensquare</groupId><artifactId>common</artifactId>

    报错的原因是你这个依赖在你本地仓库找不到或者是不是你改文件的时候小手一抖写错了?
    解决办法:
    --如果是你没有这个包辣么:
    找到你的common这个项目,执行mvninstall命令(在common这个项目pom.xml层运行)把这个包安装到本地仓库中,因该就没问题了。
    --如果是你小手一抖弄错了
    辣么你就自己改改吧。

    -----------------------新增-----------------------------
    哈哈恕我直言你这个spring-cloud-dependenciesFinchley.M9版本我根本没有在中央仓库找到...不晓得你是不是用了其他仓库。如果不是的话建议你也检查一下。

    <dependencyManagement><dependencies><dependency><groupId>org.springframework.cloud</groupId><artifactId>spring-cloud-dependencies</artifactId><version>Finchley.M9</version><type>pom</type><scope>import</scope></dependency></dependencies></dependencyManagement>

    我自己试了下用这个版本是可以的

    <dependency><groupId>org.springframework.cloud</groupId><artifactId>spring-cloud-dependencies</artifactId><version>Finchley.RELEASE</version><type>pom</type><scope>import</scope></dependency>

    -----------------------新增-----------------------------

    <type>pom</type>

    删除或者改成

    <type>jar</type>

    你依赖的是一个jar包

    笔者可以试试这样:
    1、选中项目,然后点击菜单:project->clean...

    2、右键选择项目,在出来的菜单中选择Maven->UpdateProject,

    3、出来的对话框注意勾选:ForceUpdateOfSnapshots/Releases

    4、点击OK

    这个应该是依赖冲突,看下你的spring-cloud依赖的和你之前项目里已有的依赖是否有冲突,如果有需要更换依赖版本号,图片下方为你这个版本所需要的依赖版本

    也可以在idea中打开pom文件使用ctrl+alt+shift+u查看版本冲突,红线的就是版本冲突,

    估计是jar包冲突吧?或者看看父pom类型有没有写错

    2020-06-24 10:25:06
    赞同 展开评论 打赏
问答排行榜
最热
最新

相关电子书

更多
搭建基于SpringCloud的微服务应用 立即下载
低代码开发师(初级)实战教程 立即下载
阿里巴巴DevOps 最佳实践手册 立即下载