开发者社区> 问答> 正文

Kubectl从服务器返回错误(NotAcceptable):unknown(获取节点)

k8s小能手 2018-12-14 15:04:29 892

根据这个:https://github.com/kubernetes/kops#compatibility-matrix 版本应该没问题。当我运行kubectl get node时,我得到以下输出:

Error from server (NotAcceptable): unknown (get nodes)
kubectl版本:

Client Version: version.Info{Major:"1", Minor:"13", GitVersion:"v1.13.0", GitCommit:"ddf47ac13c1a9483ea035a79cd7c10005ff21a6d", GitTreeState:"clean", BuildDate:"2018-12-03T21:04:45Z", GoVersion:"go1.11.2", Compiler:"gc", Platform:"linux/amd64"}
Server Version: version.Info{Major:"1", Minor:"7", GitVersion:"v1.7.16", GitCommit:"e8846c1d7e7e632d4bd5ed46160eff3dc4c993c5", GitTreeState:"clean", BuildDate:"2018-04-04T08:47:13Z", GoVersion:"go1.8.3", Compiler:"gc", Platform:"linux/amd64"}
kops版本:

Version 1.9.2 (git-cb54c6a52)
这是关于运行时获得的节点的信息kops update:

NAME STATUS NEEDUPDATE READY MIN MAX NODES
master-eu-central-1a Ready 0 1 1 1 1
nodes Ready 0 2 2 2 2

Kubernetes Java Linux 容器
分享到
取消 提交回答
全部回答(2)
  • davidaks
    2019-07-17 23:20:59

    服务器端和客户端的版本不匹配,建议升级服务器端。更快的方法也可以重装kubectl的client端,降到1.7.x
    https://kubernetes.io/docs/tasks/tools/install-kubectl/

    0 0
  • k8s小能手
    2019-07-17 23:20:59

    客户端:1.13.0,服务器:1.7.16。服务器必须是客户端版本(支持+/- 1,请参阅此处了解更多信息)。所以我编辑了服务器版本kops edit cluster并使用它进行了更新kops update cluster。

    0 0
添加回答
+ 订阅

云原生时代,是开发者最好的时代

推荐文章
相似问题