开发者社区> 问答> 正文

如何为 Linux 服务器安装 GRUB

行者武松 2017-12-06 17:24:17 1376

如何为 Linux 服务器安装 GRUB

Linux
分享到
取消 提交回答
全部回答(1)
  • 大财主
    2019-07-17 21:47:48

    当您无法通过 阿里云迁云工具 迁移内核版本较低,自带系统引导程序 GRUB 版本为 0.97 及其以下的 Linux 服务器,例如,CentOS 5 和 Debian 7。而且日志文件提示 Do Grub Failed 时,可能是因为没有安装 1.9 以上版本的系统引导程序 GRUB(GRand Unified Bootloader)。本文档介绍了如何为您的源服务器安装系统引导程序 GRUB 1.99 版本。

    安装 GRUB 1.99 版本

    登录源服务器。

    运行以下命令查看原 grub、grub-install 以及 grub-mkconfig 的路径:

    which grub
    which grub-install
    which grub-mkconfig
    使用 mv 命令为 grub、grub-install 以及 grub-mkconfig 改名以备份文件。您可以在使用阿里云迁云工具迁移服务器后,恢复原名以使用原配置。

    运行 yum install -y bison gcc make 安装 GRUB 依赖的 bison、gcc 以及 make 工具。

    运行以下命令安装 flex。

    test -d /root/tools || mkdir -p /root/tools
    cd /root/tools
    wget https://github.com/westes/flex/releases/download/v2.6.4/flex-2.6.4.tar.gz
    tar xzf flex-2.6.4.tar.gz
    cd flex-2.6.4
    mkdir -p build
    cd build
    ../configure
    make && make install
    运行以下命令安装 GRUB 1.99 依赖。

    test -d /root/tools || mkdir -p /root/tools
    cd /root/tools
    wget https://alpha.gnu.org/gnu/grub/grub-1.99~rc1.tar.gz
    tar xzf grub-1.99~rc1.tar.gz
    cd grub-1.99~rc1
    mkdir -p build
    cd build
    ../configure
    make && make install
    注意:
    若编译过程中出现了 -Werror 报错,您可以定位到编译对象的编译文件 makefile 中,去掉 -Werror 选项重新编译。
    后续操作

    安装系统引导程序 GRUB 1.99 版本后,您可以继续使用 阿里云迁云工具 迁移服务器至阿里云。

    0 0

集结各类场景实战经验,助你开发运维畅行无忧

推荐文章
相似问题
推荐课程