寻找大富翁
分数 25
作者 陈越
单位 浙江大学
胡润研究院的调查显示,截至2017年底,中国个人资产超过1亿元的高净值人群达15万人。假设给出N个人的个人资产值,请快速找出资产排前M位的大富翁。
输入格式:
输入首先给出两个正整数N(≤10
6
)和M(≤10),其中N为总人数,M为需要找出的大富翁数;接下来一行给出N个人的个人资产值,以百万元为单位,为不超过长整型范围的整数。数字间以空格分隔。
输出格式:
在一行内按非递增顺序输出资产排前M位的大富翁的个人资产值。数字间以空格分隔,但结尾不得有多余空格。
输入样例:
8 3
8 12 7 3 20 9 5 18
输出样例:
20 18 12
#include<algorithm>
#include<cstdio>
#include<string>
#include<cmath>
#include<cstring>
#include <iomanip>
#include<vector>
#include<stack>
#include<queue>
#include<set>
#include<map>
using namespace std;
typedef long long ll;
const int mod = 1e9 + 7;
const int INF = 0x3f3f3f3f;
const int N = 1000010;
const int NN = 10010;
int main()
{
int n,b;
cin>>n>>b;
int a[N];
int i;
for( i=0;i<n;i++)
{
cin>>a[i];
}
sort(a,a+n);
int t=0;
if(n<b)
{
for(int j=i-1;t<n;j--)
{
cout<<a[j];
if(t<n-1)
cout<<' ';
t++;
}
}
else
for(int j=i-1;j>i-1-b;j--)
{
cout<<a[j];
if(j>i-b)
cout<<' ';
}
}