POJ-1458,Common Subsequence(经典DP)

简介: POJ-1458,Common Subsequence(经典DP)

Description:


A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.


Input:


The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.


Output:


For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.  


Sample Input:


abcfbc abfcab


programming contest


abcd mnp


Sample Output:


4


2


0


解题思路:


题目的意思就是给你两个字符串,让你求最长公共子序列,就是一个标准的DP,直接套用公式就可以了!!!


程序代码:


#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define N 1100
char a[N],b[N];
int dp[N][N];
int main()
{
  while(cin>>a>>b)
  {
    int len1=strlen(a);
    int len2=strlen(b);
    for(int i=1;i<=len1;i++)
    {
      for(int j=1;j<=len2;j++)
      {
        if(a[i-1]==b[j-1])
          dp[i][j]=dp[i-1][j-1]+1;
        else
          dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
      }
    }
    cout<<dp[len1][len2]<<endl;
  }
  return 0;
}
相关文章
|
8月前
poj-1458-Common Subsequence
poj-1458-Common Subsequence
39 0
|
8月前
|
人工智能
HDU-1159-Common Subsequence
HDU-1159-Common Subsequence
47 0
|
8月前
|
Java
hdu-2112-HDU Today(dijkstra + map)
hdu-2112-HDU Today(dijkstra + map)
28 0
|
8月前
|
C++ 容器
POJ3096—Surprising Strings
POJ3096—Surprising Strings
|
8月前
|
算法
LCA(Least Common Ancestors)
LCA(Least Common Ancestors)
48 0
hdoj 1028/poj 2704 Pascal's Travels(记忆化搜索||dp)
有个小球,只能向右边或下边滚动,而且它下一步滚动的步数是它在当前点上的数字,如果是0表示进入一个死胡同。求它从左上角到右下角到路径数目。 注意, 题目给了提示了,要用64位的整数。
45 0
|
算法
POJ3061 Subsequence
POJ3061 Subsequence
HDU 4632 Palindrome subsequence(动态规划)
HDU 4632 Palindrome subsequence(动态规划)
82 0
HDU 4632 Palindrome subsequence(动态规划)