poj-1458-Common Subsequence

简介: poj-1458-Common Subsequence


Common Subsequence

Time Limit: 1000MS
Memory Limit: 10000K
Total Submissions: 43207
Accepted: 17522

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab

programming    contest

abcd           mnp

Sample Output

4

2

0

Source

Southeastern Europe 2003



题目分析:

此题意思就是求最长子序列的长度,不管是否连续,这就是  lcs  


<span style="font-size:18px;">#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
  char str1[1010],str2[1010];
  int dp[1010][1010];
  while(~scanf("%s%s",str1,str2))
  {
    memset(dp,0,sizeof(dp));
    int len1=strlen(str1);
    int len2=strlen(str2);
    for(int i=1;i<=len1;i++)
    {
      for(int j=1;j<=len2;j++)
      {
        if(str1[i-1]==str2[j-1])
        {
          dp[i][j]=dp[i-1][j-1]+1;
        }
        else  dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
      }
    }
    printf("%d\n",dp[len1][len2]);
  }
  return 0;
}</span>





目录
相关文章
|
8月前
|
人工智能
HDU-1159-Common Subsequence
HDU-1159-Common Subsequence
46 0
|
8月前
|
Java
hdu-2112-HDU Today(dijkstra + map)
hdu-2112-HDU Today(dijkstra + map)
27 0
|
8月前
|
机器学习/深度学习 安全 Java
hdu-1596-find the safest road(dijkstra)
hdu-1596-find the safest road(dijkstra)
51 0
|
8月前
|
C++ 容器
POJ3096—Surprising Strings
POJ3096—Surprising Strings
|
8月前
Strange fuction(HDU--2899)
Strange fuction(HDU--2899)
|
8月前
|
算法
LCA(Least Common Ancestors)
LCA(Least Common Ancestors)
45 0
|
算法
POJ3061 Subsequence
POJ3061 Subsequence
POJ-1458,Common Subsequence(经典DP)
POJ-1458,Common Subsequence(经典DP)
HDOJ(HDU) 1898 Sempr == The Best Problem Solver?(水题、、、)
HDOJ(HDU) 1898 Sempr == The Best Problem Solver?(水题、、、)
131 0