HDOJ 2071 Max Num

简介: HDOJ 2071 Max Num

Problem Description

There are some students in a class, Can you help teacher find the highest student .


Input

There are some cases. The first line contains an integer t, indicate the cases; Each case have an integer n ( 1 ≤ n ≤ 100 ) , followed n students’ height.


Output

For each case output the highest height, the height to two decimal plases;


Sample Input

2

3 170.00 165.00 180.00

4 165.00 182.00 172.00 160.00


Sample Output

180.00

182.00


image.png

image.png


同一个代码!这个运行时间正好是在超时的边界!~

import java.util.Scanner;
public class Main {
    static Scanner sc=new Scanner(System.in);
    public static void main(String[] args) {
        int n=sc.nextInt();
        while(n-->0){
                int m=sc.nextInt();
                double[] a=new double[m];
                double max=a[0]=sc.nextDouble();
                for(int i=1;i<a.length;i++){
                    a[i]=sc.nextDouble();
                    if(max<a[i]){
                        max=a[i];
                    }    
                }
                System.out.printf("%.2f",max);
                System.out.println();
            }
    }
}


目录
相关文章
|
6月前
|
人工智能 BI
LeetCode 209. Minimum Size Subarray Sum
给定一个含有 n 个正整数的数组和一个正整数 s ,找出该数组中满足其和 ≥ s 的长度最小的连续子数组。如果不存在符合条件的连续子数组,返回 0。
114 0
LeetCode 209. Minimum Size Subarray Sum
LeetCode 149. Max Points on a Line
给定一个二维平面,平面上有 n 个点,求最多有多少个点在同一条直线上。
100 0
LeetCode 149. Max Points on a Line
|
算法
LeetCode 363. Max Sum of Rect No Larger Than K
给定一个非空二维矩阵 matrix 和一个整数 k,找到这个矩阵内部不大于 k 的最大矩形和。
94 0
LeetCode 363. Max Sum of Rect No Larger Than K
HDOJ 1391 Number Steps(打表DP)
HDOJ 1391 Number Steps(打表DP)
127 0
HDOJ 1391 Number Steps(打表DP)
HDOJ 1003 Max Sum
HDOJ 1003 Max Sum
99 0
HDOJ1003Max Sum
HDOJ1003Max Sum
80 0
成功解决ValueError: min_samples_split must be an integer greater than 1 or a float in (0.0, 1.0]; got th
成功解决ValueError: min_samples_split must be an integer greater than 1 or a float in (0.0, 1.0]; got th