HDOJ 2071 Max Num

简介: HDOJ 2071 Max Num

Problem Description

There are some students in a class, Can you help teacher find the highest student .


Input

There are some cases. The first line contains an integer t, indicate the cases; Each case have an integer n ( 1 ≤ n ≤ 100 ) , followed n students’ height.


Output

For each case output the highest height, the height to two decimal plases;


Sample Input

2

3 170.00 165.00 180.00

4 165.00 182.00 172.00 160.00


Sample Output

180.00

182.00


image.png

image.png


同一个代码!这个运行时间正好是在超时的边界!~

import java.util.Scanner;
public class Main {
    static Scanner sc=new Scanner(System.in);
    public static void main(String[] args) {
        int n=sc.nextInt();
        while(n-->0){
                int m=sc.nextInt();
                double[] a=new double[m];
                double max=a[0]=sc.nextDouble();
                for(int i=1;i<a.length;i++){
                    a[i]=sc.nextDouble();
                    if(max<a[i]){
                        max=a[i];
                    }    
                }
                System.out.printf("%.2f",max);
                System.out.println();
            }
    }
}


目录
相关文章
|
9月前
|
SQL 数据库
MAX() 函数
MAX() 函数
69 6
|
移动开发 安全 JavaScript
MAX4/11/03/016/08/1/1/00 MAX-4/11/01/008/08/1/1/00
MAX4/11/03/016/08/1/1/00 MAX-4/11/01/008/08/1/1/00
67 0
|
10月前
|
人工智能 BI
|
10月前
|
编译器 C++
C++ max函数与min函数
C++ max函数与min函数
385 0
C400/A8/1/1/1/00 MAX-4/11/03/128/99/1/0/00
C400/A8/1/1/1/00 MAX-4/11/03/128/99/1/0/00
51 0
|
算法 C++
10min快速回顾C++语法(一)
本系列文章旨在短时间内回顾C/C++语法中的重点与易错点,巩固算法竞赛与写题过程中常用的语法知识,精准地解决学过但有遗忘的情况,为算法刷题打下坚实的基础。
136 0
HDOJ 1003 Max Sum
HDOJ 1003 Max Sum
110 0
HDOJ1003Max Sum
HDOJ1003Max Sum
94 0
成功解决ValueError: min_samples_split must be an integer greater than 1 or a float in (0.0, 1.0]; got th
成功解决ValueError: min_samples_split must be an integer greater than 1 or a float in (0.0, 1.0]; got th