升级vcsa6.7时报错设备根密码过期-阿里云开发者社区

开发者社区> 开发与运维> 正文
登录阅读全文

升级vcsa6.7时报错设备根密码过期

简介: 升级vcsa6.7时报错设备根密码过期

最近在升级vcsa6.7版本时,提示报错,其实报错内容就是设备根密码过期了,导致无法升级

Appliance (OS) root password expired.
Please change appliance (OS) root password before attempting an update

解决办法:

打开VCSA控制台,选择Troubleshooting Mode Options,开启ssh、shell

注意此处两项都回车选择一下,看到Disable就表示当前已是开启状态,无需保存,即时生效

然后通过xshell等相关工具连接VCSA,默认端口22

登录后会看到修改密码的提示,先输入老的密码,再输入新的密码,注意新的密码不能和老的密码相似度太高,也不能太简单,否则修改不了,最后执行chage命令,将root密码设置永不过期。

You are required to change your password immediately (root enforced)
Changing password for root.
(current) UNIX password:
New password:
Retype new password:
Password:
Connected to service

* List APIs: "help api list"
* List Plugins: "help pi list"
* Launch BASH: "shell"

Command> shell
root@photon-machine [ ~ ]# chage -I -1 -m 0 -M 99999 -E -1 root

设置完成后,请记得关闭Shell、SSH

此时再执行升级操作就不会报错了。

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

分享:
开发与运维
使用钉钉扫一扫加入圈子
+ 订阅

集结各类场景实战经验,助你开发运维畅行无忧

其他文章
最新文章
相关文章