poj-2551-ones

简介: Description Given any integer 0

Description

Given any integer 0 <= n <= 10000 not divisible by 2 or 5, some multiple of n is a number which in decimal notation is a sequence of 1's. How many digits are in the smallest such a multiple of n?

Input

Each line contains a number n.

Output

Output the number of digits.

Sample Input

3 
7 
9901

Sample Output

3
6
12

题目大意:
输入n,求出不能整除3和5,却能整除d并且这个数各位都是1;
111111111111%9901==0;
#include <iostream>
#include <cstdio>

using namespace std;


int main()
{
    int n;

    while(~scanf("%d",&n))//EOF
    {
        int cnt=1;
        int num=1;

        while(num%n)
        {
            num=(num*10+1)%n;//直接找由1构成的数,判断是不是n的倍数
            cnt++;
        }
        printf("%d\n",cnt);
    }

    return 0;
}

  

相关文章
|
3月前
|
算法 数据建模
Poj 3169(差分约束系统)
Poj 3169(差分约束系统)
20 0
|
算法框架/工具
POJ 2262 Goldbach's Conjecture
POJ 2262 Goldbach's Conjecture
114 0
POJ 2027 No Brainer
POJ 2027 No Brainer
82 0
POJ 2487 Stamps
POJ 2487 Stamps
84 0
|
人工智能
POJ 1936 All in All
Description You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way.
756 0
|
人工智能 vr&ar
|
测试技术
|
存储
大数加法-poj-1503
poj-1503-Integer Inquiry Description One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking vari
1099 0