1027. Colors in Mars (20)

简介: People in Mars represent the colors in their computers in a similar way as the Earth people.

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.

Sample Input
15 43 71
Sample Output
#123456

简析:一次ac,不解释,看代码。

#include <iostream>
using namespace std;

int main(int argc, const char * argv[]) {
    int a, b, c, i, d[6] = {0};
    scanf("%d%d%d", &a, &b, &c);
    i = 1;
    while (a) {
        d[i--] = a % 13;
        a /= 13;
    }
    i = 3;
    while (b) {
        d[i--] = b % 13;
        b /= 13;
    }
    i = 5;
    while (c) {
        d[i--] = c % 13;
        c /= 13;
    }
    
    char s[13] = {'0', '1', '2', '3', '4', '5', '6', '7', '8', '9', 'A', 'B', 'C'};
    
    printf("#");
    for (int i = 0; i < 6; i++) {
        printf("%c", s[d[i]]);
    }
    printf("\n");
    
    return 0;
}


目录
相关文章
|
2月前
|
数据可视化 jenkins 持续交付
Jenkins Blue Ocean
Jenkins Blue Ocean
15 0
|
4月前
【gloomyfish】Box zoom on Category Plot in JFreeChart
【gloomyfish】Box zoom on Category Plot in JFreeChart
23 0
|
5月前
|
编解码 人工智能 数据格式
PIE-ENGINE:Modis-Aqua产品包含了L3 Mapped数据集
PIE-ENGINE:Modis-Aqua产品包含了L3 Mapped数据集
297 0
|
12月前
190Echarts - 自定义系列(Girths of Black Cherry Trees)
190Echarts - 自定义系列(Girths of Black Cherry Trees)
20 0
|
12月前
88Echarts - 散点图(Distribution of Height and Weight)
88Echarts - 散点图(Distribution of Height and Weight)
28 0
|
12月前
114Echarts - 盒须图(Boxplot Light Velocity2)
114Echarts - 盒须图(Boxplot Light Velocity2)
96 0
|
12月前
113Echarts - 盒须图(Boxplot Light Velocity)
113Echarts - 盒须图(Boxplot Light Velocity)
141 0
|
C++
【PAT甲级 - C++题解】1027 Colors in Mars
【PAT甲级 - C++题解】1027 Colors in Mars
63 0
[CF Gym101196-I] Waif Until Dark 网络最大流
[CF Gym101196-I] Waif Until Dark 网络最大流
86 0
Figma|Generate color palette
Figma|Generate color palette
108 0