1027. Colors in Mars (20)

简介: People in Mars represent the colors in their computers in a similar way as the Earth people.

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.

Sample Input
15 43 71
Sample Output
#123456

简析:一次ac,不解释,看代码。

#include <iostream>
using namespace std;

int main(int argc, const char * argv[]) {
    int a, b, c, i, d[6] = {0};
    scanf("%d%d%d", &a, &b, &c);
    i = 1;
    while (a) {
        d[i--] = a % 13;
        a /= 13;
    }
    i = 3;
    while (b) {
        d[i--] = b % 13;
        b /= 13;
    }
    i = 5;
    while (c) {
        d[i--] = c % 13;
        c /= 13;
    }
    
    char s[13] = {'0', '1', '2', '3', '4', '5', '6', '7', '8', '9', 'A', 'B', 'C'};
    
    printf("#");
    for (int i = 0; i < 6; i++) {
        printf("%c", s[d[i]]);
    }
    printf("\n");
    
    return 0;
}


目录
相关文章
|
3月前
|
数据可视化 jenkins 持续交付
Jenkins Blue Ocean
Jenkins Blue Ocean
52 0
|
5月前
【gloomyfish】Box zoom on Category Plot in JFreeChart
【gloomyfish】Box zoom on Category Plot in JFreeChart
29 0
190Echarts - 自定义系列(Girths of Black Cherry Trees)
190Echarts - 自定义系列(Girths of Black Cherry Trees)
22 0
|
C++
【PAT甲级 - C++题解】1027 Colors in Mars
【PAT甲级 - C++题解】1027 Colors in Mars
67 0
Figma|Generate color palette
Figma|Generate color palette
112 0
|
数据可视化 搜索推荐 架构师
持续交付-Blue Ocean 应用
Blue Ocean 提供了一套可视化操作界面来帮助创建、编辑 Pipeline 任务。 Blue Ocean 特性: - 流水线编辑器:用于创建贯穿始终的持续交付流水线,是一种直观并可视化的流水线编辑器。 - 流水线的可视化:对流水线的可视化表示,提高了全企业范围内持续交付过程的清晰度。 - 流水线的诊断:即刻定位自动化问题,无需持续扫描日志或关注多个屏幕。 - 个性化仪表盘:用户可以自定
|
机器学习/深度学习 异构计算 Python
Py之face_alignment:face_alignment库的简介、安装、使用方法之详细攻略
Py之face_alignment:face_alignment库的简介、安装、使用方法之详细攻略
Py之face_alignment:face_alignment库的简介、安装、使用方法之详细攻略
|
数据可视化 搜索推荐 jenkins
持续交付-Blue Ocean 应用
持续交付-Blue Ocean 应用
|
数据可视化 搜索推荐 jenkins
Jenkins换肤:Blue Ocean的安装和使用
Jenkins换肤:Blue Ocean的安装和使用
666 0
Jenkins换肤:Blue Ocean的安装和使用
【1027】Colors in Mars (20 分)
【1027】Colors in Mars (20 分) 【1027】Colors in Mars (20 分)
139 0