NYOJ714-Card Trick

简介:

Card Trick
时间限制:1000 ms  |  内存限制:65535 KB
难度:3
描述
The magician shuffles a small pack of cards, holds it face down and performs the following procedure:

The top card is moved to the bottom of the pack. The new top card is dealt face up onto the table. It is the Ace of Spades.
Two cards are moved one at a time from the top to the bottom. The next card is dealt face up onto the table. It is the Two of Spades.
Three cards are moved one at a time…
This goes on until the nth and last card turns out to be the n of Spades.
This impressive trick works if the magician knows how to arrange the cards beforehand (and knows how to give a false shuffle). Your program has to determine the initial order of the cards for a given number of cards, 1 ≤ n ≤ 13.

输入
On the first line of the input is a single positive integer k, telling the number of test cases to follow. 1 ≤ k ≤ 10 Each case consists of one line containing the integer n. 1 ≤ n ≤ 13
输出
For each test case, output a line with the correct permutation of the values 1 to n, space separated. The first number showing the top card of the pack, etc…

样例输入
245

样例输出
2 1 4 33 1 4 5 2


来源
第六届河南省程序设计大赛

 

 

题目大意是:有n张牌,找到一个顺序,使得第一次把上面一张取出放到最下面,

然后取出最上面一张是一,第i次把上面i张取出放到最下面,然后取出一张是i;

//模拟即可

#include<stdio.h>
#include<string.h>
int a[20],b[20];
void MoveBack(int n,int m)//将第一张牌移到牌堆最后
{
    int i;
 for(i=1;i<m;i++)
 {
  a[i]=a[i+1];
 }
 a[m]=n;
}
void DelTop(int m)//删除第一张牌
{
 int i;
 for(i=1;i<=m;i++)
 {
  a[i]=a[i+1];
 }
}
int main()
{
 int i,j,n,m,k,v,x,flag;
 scanf("%d",&n);
 while(n--)
 {
  scanf("%d",&m);
  for(i=1;i<=m;i++)
     a[i]=i;
  x=1;k=1;flag=m;
  while(m)
  {
     v=x;
     while(v--)
     MoveBack(a[1],m);
     b[a[1]]=k++;
     DelTop(m--);
     x++;
  }
  printf("%d",b[1]);
  for(i=2;i<=flag;i++)
   printf(" %d",b[i]);
  puts("");
  memset(a,0,sizeof(a));
  memset(b,0,sizeof(b));
 }
 return 0;
}
相关文章
|
6月前
|
C++
HDU2319— Card Trick
HDU2319— Card Trick
|
6月前
|
人工智能 算法 BI
D - Silver Cow Party——POJ3268(连续用两次Dijkstra算法)
D - Silver Cow Party——POJ3268(连续用两次Dijkstra算法)
Codeforces Round #192 (Div. 2) (330B) B.Road Construction
要将N个城市全部相连,刚开始以为是最小生成树的问题,其实就是一道简单的题目。 要求两个城市之间不超过两条道路,那么所有的城市应该是连在一个点上的,至于这个点就很好找了,只要找到一个没有和其他点有道路限制的即可。
40 0
|
机器学习/深度学习 人工智能 BI
Educational Codeforces Round 115 (Rated for Div. 2) D. Training Session(组合数学 思维)
Educational Codeforces Round 115 (Rated for Div. 2) D. Training Session(组合数学 思维)
105 0
|
人工智能 Windows
Educational Codeforces Round 113 (Rated for Div. 2) C - Jury Meeting (思维 组合数)
Educational Codeforces Round 113 (Rated for Div. 2) C - Jury Meeting (思维 组合数)
97 0
POJ-Silver Cow Party (最短路)
POJ-Silver Cow Party (最短路)
95 0
|
人工智能
Educational Codeforces Round 113 (Rated for Div. 2) B. Chess Tournament(思维 构造)
Educational Codeforces Round 113 (Rated for Div. 2) B. Chess Tournament(思维 构造)
88 0