NYOJ714-Card Trick

简介:

Card Trick
时间限制:1000 ms  |  内存限制:65535 KB
难度:3
描述
The magician shuffles a small pack of cards, holds it face down and performs the following procedure:

The top card is moved to the bottom of the pack. The new top card is dealt face up onto the table. It is the Ace of Spades.
Two cards are moved one at a time from the top to the bottom. The next card is dealt face up onto the table. It is the Two of Spades.
Three cards are moved one at a time…
This goes on until the nth and last card turns out to be the n of Spades.
This impressive trick works if the magician knows how to arrange the cards beforehand (and knows how to give a false shuffle). Your program has to determine the initial order of the cards for a given number of cards, 1 ≤ n ≤ 13.

输入
On the first line of the input is a single positive integer k, telling the number of test cases to follow. 1 ≤ k ≤ 10 Each case consists of one line containing the integer n. 1 ≤ n ≤ 13
输出
For each test case, output a line with the correct permutation of the values 1 to n, space separated. The first number showing the top card of the pack, etc…

样例输入
245

样例输出
2 1 4 33 1 4 5 2


来源
第六届河南省程序设计大赛

 

 

题目大意是:有n张牌,找到一个顺序,使得第一次把上面一张取出放到最下面,

然后取出最上面一张是一,第i次把上面i张取出放到最下面,然后取出一张是i;

//模拟即可

#include<stdio.h>
#include<string.h>
int a[20],b[20];
void MoveBack(int n,int m)//将第一张牌移到牌堆最后
{
    int i;
 for(i=1;i<m;i++)
 {
  a[i]=a[i+1];
 }
 a[m]=n;
}
void DelTop(int m)//删除第一张牌
{
 int i;
 for(i=1;i<=m;i++)
 {
  a[i]=a[i+1];
 }
}
int main()
{
 int i,j,n,m,k,v,x,flag;
 scanf("%d",&n);
 while(n--)
 {
  scanf("%d",&m);
  for(i=1;i<=m;i++)
     a[i]=i;
  x=1;k=1;flag=m;
  while(m)
  {
     v=x;
     while(v--)
     MoveBack(a[1],m);
     b[a[1]]=k++;
     DelTop(m--);
     x++;
  }
  printf("%d",b[1]);
  for(i=2;i<=flag;i++)
   printf(" %d",b[i]);
  puts("");
  memset(a,0,sizeof(a));
  memset(b,0,sizeof(b));
 }
 return 0;
}
相关文章
|
2月前
|
C++
HDU2319— Card Trick
HDU2319— Card Trick
|
2月前
|
人工智能 算法 BI
D - Silver Cow Party——POJ3268(连续用两次Dijkstra算法)
D - Silver Cow Party——POJ3268(连续用两次Dijkstra算法)
|
10月前
|
机器学习/深度学习 人工智能 BI
The Great Hero(Codeforces Round #700 (Div. 2))模拟+贪心思想和排序
The Great Hero(Codeforces Round #700 (Div. 2))模拟+贪心思想和排序
40 0
|
人工智能
Codeforces1343D - Constant Palindrome Sum + UPC-鸭子游戏 (差分)
Codeforces1343D - Constant Palindrome Sum + UPC-鸭子游戏 (差分)
84 1
|
人工智能
【训练题解】UPC Card Eater (思维)
【训练题解】UPC Card Eater (思维)
36 0
POJ-Silver Cow Party (最短路)
POJ-Silver Cow Party (最短路)
78 0
|
Java C语言
HDOJ/HDU 1029 Ignatius and the Princess IV(简单DP,排序)
HDOJ/HDU 1029 Ignatius and the Princess IV(简单DP,排序)
125 0