John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo -- that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.
Input Specification:
Each input file contains one test case. For each case, the first line gives three positive integers M (<= 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John's post.
Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.
Output Specification:
For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print "Keep going..." instead.
Sample Input 1:9 3 2 Imgonnawin! PickMe PickMeMeMeee LookHere Imgonnawin! TryAgainAgain TryAgainAgain Imgonnawin! TryAgainAgainSample Output 1:
PickMe Imgonnawin! TryAgainAgainSample Input 2:
2 3 5 Imgonnawin! PickMeSample Output 2:
Keep going...
#include <iostream>
#include <map>
#include <vector>
#include <algorithm>
using namespace std;
int main(){
int m, n, s;
string st;
cin >> m >> n >> s;
vector<string> v;
map <string, bool> ma;
for (int i = 0; i < m; i++) {
cin >> st;
v.push_back(st);
}
for (int i = s-1; i < v.size(); i = i + n) {
while(ma[v[i]]){
i++;
}
cout << v[i] << endl;
ma[v[i]] = true;
}
if(m < s) cout << "Keep going...\n";
return 0;
}