【PAT甲级 - C++题解】1076 Forwards on Weibo

简介: 【PAT甲级 - C++题解】1076 Forwards on Weibo

1076 Forwards on Weibo

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.


Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]


where M[i] (≤100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.


Then finally a positive K is given, followed by K UserID’s for query.


Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can trigger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.


Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6


Sample Output:

4
5


题意

当用户在微博上发布帖子时,他/她的所有关注者都可以查看并转发他/她的帖子,然后这些人的关注者可以对内容再次转发…

现在给定一个社交网络,假设只考虑 L 层关注者,请你计算某些用户的帖子的最大可能转发量。


思路

这题数据量稍微比较大,所以我们用邻接表来存每条边,并且用 bfs 来计算思路会更简洁一些,具体思路如下:


1.先输入每个用户的关注者,这里用链式前向星来存储邻接表。

2.对每个要查询的用户进行 bfs 计算。这里需要用到队列,初始化完后进行每一层的计算,因为最大计算 L 层,所以遍历次数不大于 L 。另外需要注意的是,发出帖子的那个人在计算过程中被当做第一层加入答案,而我们遍历次数不大于 L ,所以最终返回答案时要加上下一层的数量并减去 1 即不计算发帖的那个人。

3.最后,输出返回回来的最大转发数。如下图所示,假设发帖的人的编号为 1 ,且最多只计算 2 层:

另外,图中只是显示了理想情况,可能会出现两人之间互相关注的情况,我们在 bfs 的过程中会有个 st 数组来记录哪些人已经被计算过,故不会出现重复计算的情况。


代码

#include<bits/stdc++.h>
using namespace std;
const int N = 1010, M = 100010;
int n, m;
int e[M], h[N], ne[M], idx;
bool st[N];
//链式前向星存储邻接表
void add(int a, int b)
{
    e[idx] = b, ne[idx] = h[a], h[a] = idx++;
}
//深搜求最大转发数
int bfs(int x)
{
    //初始化
    memset(st, 0, sizeof st);
    st[x] = true;
    queue<int> q;
    q.push(x);
    //最多转发m层
    int res = 0;
    for (int i = 0; i < m; i++)
    {
        int sz = q.size();
        res += sz;  //一层一层人数的加
        //再遍历该层每个人的关注者
        while (sz--)
        {
            int u = q.front();
            q.pop();
            for (int j = h[u]; ~j; j = ne[j])
            {
                int k = e[j];
                if (st[k])   continue;
                st[k] = true;
                q.push(k);
            }
        }
    }
    //第一层即发帖子的人是不算进转发数的,故第一层不算
    return res + q.size() - 1;
}
int main()
{
    scanf("%d%d", &n, &m);
    //输入每个用户关注的信息
    memset(h, -1, sizeof h);
    for (int i = 1; i <= n; i++)
    {
        int k;
        scanf("%d", &k);
        while (k--)
        {
            int x;
            scanf("%d", &x);
            add(x, i);
        }
    }
    //进行查询
    int k;
    scanf("%d", &k);
    while (k--)
    {
        int x;
        scanf("%d", &x);
        printf("%d\n", bfs(x));
    }
    return 0;
}


目录
相关文章
|
C++
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
68 0
|
算法 C++
【PAT甲级 - C++题解】1044 Shopping in Mars
【PAT甲级 - C++题解】1044 Shopping in Mars
92 0
|
C++
【PAT甲级 - C++题解】1117 Eddington Number
【PAT甲级 - C++题解】1117 Eddington Number
83 0
|
存储 C++ 容器
【PAT甲级 - C++题解】1057 Stack
【PAT甲级 - C++题解】1057 Stack
79 0
|
存储 C++
【PAT甲级 - C++题解】1055 The World‘s Richest
【PAT甲级 - C++题解】1055 The World‘s Richest
82 0
|
C++
【PAT甲级 - C++题解】1051 Pop Sequence
【PAT甲级 - C++题解】1051 Pop Sequence
86 0
|
2月前
|
存储 编译器 C语言
【c++丨STL】string类的使用
本文介绍了C++中`string`类的基本概念及其主要接口。`string`类在C++标准库中扮演着重要角色,它提供了比C语言中字符串处理函数更丰富、安全和便捷的功能。文章详细讲解了`string`类的构造函数、赋值运算符、容量管理接口、元素访问及遍历方法、字符串修改操作、字符串运算接口、常量成员和非成员函数等内容。通过实例演示了如何使用这些接口进行字符串的创建、修改、查找和比较等操作,帮助读者更好地理解和掌握`string`类的应用。
60 2
|
2月前
|
存储 编译器 C++
【c++】类和对象(下)(取地址运算符重载、深究构造函数、类型转换、static修饰成员、友元、内部类、匿名对象)
本文介绍了C++中类和对象的高级特性,包括取地址运算符重载、构造函数的初始化列表、类型转换、static修饰成员、友元、内部类及匿名对象等内容。文章详细解释了每个概念的使用方法和注意事项,帮助读者深入了解C++面向对象编程的核心机制。
111 5
|
2月前
|
存储 编译器 C++
【c++】类和对象(中)(构造函数、析构函数、拷贝构造、赋值重载)
本文深入探讨了C++类的默认成员函数,包括构造函数、析构函数、拷贝构造函数和赋值重载。构造函数用于对象的初始化,析构函数用于对象销毁时的资源清理,拷贝构造函数用于对象的拷贝,赋值重载用于已存在对象的赋值。文章详细介绍了每个函数的特点、使用方法及注意事项,并提供了代码示例。这些默认成员函数确保了资源的正确管理和对象状态的维护。
111 4
|
2月前
|
存储 编译器 Linux
【c++】类和对象(上)(类的定义格式、访问限定符、类域、类的实例化、对象的内存大小、this指针)
本文介绍了C++中的类和对象,包括类的概念、定义格式、访问限定符、类域、对象的创建及内存大小、以及this指针。通过示例代码详细解释了类的定义、成员函数和成员变量的作用,以及如何使用访问限定符控制成员的访问权限。此外,还讨论了对象的内存分配规则和this指针的使用场景,帮助读者深入理解面向对象编程的核心概念。
142 4