1137. Final Grading (25)

简介: For a student taking the online course "Data Structures" on China University MOOC (http://www.

For a student taking the online course "Data Structures" on China University MOOC (http://www.icourse163.org/), to be qualified for a certificate, he/she must first obtain no less than 200 points from the online programming assignments, and then receive a final grade no less than 60 out of 100. The final grade is calculated by G = (Gmid-termx 40% + Gfinalx 60%) if Gmid-term > Gfinal, or Gfinal will be taken as the final grade G. Here Gmid-term and Gfinal are the student's scores of the mid-term and the final exams, respectively.

The problem is that different exams have different grading sheets. Your job is to write a program to merge all the grading sheets into one.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers: P , the number of students having done the online programming assignments; M, the number of students on the mid-term list; and N, the number of students on the final exam list. All the numbers are no more than 10,000.

Then three blocks follow. The first block contains P online programming scores Gp's; the second one contains M mid-term scores Gmid-term's; and the last one contains N final exam scores Gfinal's. Each score occupies a line with the format: StudentID Score, where StudentID is a string of no more than 20 English letters and digits, and Score is a nonnegative integer (the maximum score of the online programming is 900, and that of the mid-term and final exams is 100).

Output Specification:

For each case, print the list of students who are qualified for certificates. Each student occupies a line with the format:

StudentID Gp Gmid-term Gfinal G

If some score does not exist, output "-1" instead. The output must be sorted in descending order of their final grades (G must be rounded up to an integer). If there is a tie, output in ascending order of their StudentID's. It is guaranteed that the StudentID's are all distinct, and there is at least one qualified student.

Sample Input:
6 6 7
01234 880
a1903 199
ydjh2 200
wehu8 300
dx86w 220
missing 400
ydhfu77 99
wehu8 55
ydjh2 98
dx86w 88
a1903 86
01234 39
ydhfu77 88
a1903 66
01234 58
wehu8 84
ydjh2 82
missing 99
dx86w 81
Sample Output:
missing 400 -1 99 99
ydjh2 200 98 82 88
dx86w 220 88 81 84
wehu8 300 55 84 84
#include <iostream>
#include <vector>
#include <map>
#include <algorithm>
using namespace std;

struct node{
    string id;
    int p, gm, gf, g;
};
vector<node> stu;
bool cmp(struct node a, struct node b){
    if(a.g == b.g) return a.id < b.id;
    return a.g > b.g;
}

int main(){
    int p, m, n, t, cnt = 1;
    cin >> p >> m >> n;
    string st;
    map<string, int> to;
    
    
    for (int i = 0; i < p; i++) {
        cin >> st >> t;
        if (t >= 200) {
            stu.push_back(node{st, t, -1, 0, 0});
            to[st] = cnt++;
        }
    }
    
    for (int i = 0; i < m; i++) {
        cin >> st >> t;
        if(to[st]) stu[to[st]-1].gm = t;
    }
    
    for (int i = 0; i < n; i++) {
        cin >> st >> t;
        if(to[st]) stu[to[st]-1].gf = t;
    }
    
    for (int i = 0; i < cnt-1; i++) {
        if(stu[i].gm > stu[i].gf){
            stu[i].g = stu[i].gm * 0.4 + stu[i].gf * 0.6 + 0.5;
        }else{
            stu[i].g = stu[i].gf;
        }
    }
    
    sort(stu.begin(), stu.end() , cmp);
    
    for (int i = 0; i < cnt-1; i++) {
        if(stu[i].g >= 60){
            cout << stu[i].id << ' ' << stu[i].p << ' ' << stu[i].gm << ' ' << stu[i].gf << ' ' << stu[i].g << endl;
        }
    }
    
    return 0;
}

目录
相关文章
|
6月前
|
消息中间件 Kubernetes NoSQL
c++11 关键字 override 与 final
c++11 关键字 override 与 final
|
3月前
|
Linux 数据安全/隐私保护
[HZNUCTF 2023 final]ezgo
[HZNUCTF 2023 final]ezgo
42 0
|
6月前
|
PHP
PHP public、protected、private、static、abstract、final、interface、implements 区别对比
PHP public、protected、private、static、abstract、final、interface、implements 区别对比
76 0
|
6月前
|
程序员
final
final
30 0
JAVA中static、final、static final的区别
JAVA中static、final、static final的区别
103 0
|
6月前
|
编译器 C++
C++新特性 override和final
C++新特性 override和final
|
Java
Java 权限修饰符(private、protected、public、默认、final、static)
Java 权限修饰符(private、protected、public、默认、final、static)
176 0
1. Final 有什么用?
Final(最终)一词可以在不同的语境中有不同的用途和含义。以下是对于"Final"的一般解释,以及一些常见的用途
110 0
private static final long serialVersionUID = 5461344781588144485L;是什么意思,后面的号码是如何生成的
serialVersionUID 用来表明类的不同版本间的兼容性。 序列化的时候,被序列化的类要有一个唯一标记。客户端和服务端必须需要同一个对象,serialVersionUID的唯一值判定其为同一个对象。 后面的号码是自动生成的,只要是唯一的就行,通常为1,此行语句去掉在练习的时候也没有什么影响,只不过此实例类会报一个警告。将鼠标放到警告上,选择第一个解决方案,就会重新加上此行语句,后面的数字和原先的可能会不一样。
199 0
private static final long serialVersionUID = 5461344781588144485L;是什么意思,后面的号码是如何生成的