1139. First Contact (30)

简介: Unlike in nowadays, the way that boys and girls expressing their feelings of love was quite subtle in the early years.

Unlike in nowadays, the way that boys and girls expressing their feelings of love was quite subtle in the early years. When a boy A had a crush on a girl B, he would usually not contact her directly in the first place. Instead, he might ask another boy C, one of his close friends, to ask another girl D, who was a friend of both B and C, to send a message to B -- quite a long shot, isn't it? Girls would do analogously.

Here given a network of friendship relations, you are supposed to help a boy or a girl to list all their friends who can possibly help them making the first contact.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (1 < N <= 300) and M, being the total number of people and the number of friendship relations, respectively. Then M lines follow, each gives a pair of friends. Here a person is represented by a 4-digit ID. To tell their genders, we use a negative sign to represent girls.

After the relations, a positive integer K (<= 100) is given, which is the number of queries. Then K lines of queries follow, each gives a pair of lovers, separated by a space. It is assumed that the first one is having a crush on the second one.

Output Specification:

For each query, first print in a line the number of different pairs of friends they can find to help them, then in each line print the IDs of a pair of friends.

If the lovers A and B are of opposite genders, you must first print the friend of A who is of the same gender of A, then the friend of B, who is of the same gender of B. If they are of the same gender, then both friends must be in the same gender as theirs. It is guaranteed that each person has only one gender.

The friends must be printed in non-decreasing order of the first IDs, and for the same first ones, in increasing order of the seconds ones.

Sample Input:
10 18
-2001 1001
-2002 -2001
1004 1001
-2004 -2001
-2003 1005
1005 -2001
1001 -2003
1002 1001
1002 -2004
-2004 1001
1003 -2002
-2003 1003
1004 -2002
-2001 -2003
1001 1003
1003 -2001
1002 -2001
-2002 -2003
5
1001 -2001
-2003 1001
1005 -2001
-2002 -2004
1111 -2003
Sample Output:
4
1002 2004
1003 2002
1003 2003
1004 2002
4
2001 1002
2001 1003
2002 1003
2002 1004
0
1
2003 2001
0
#include <iostream>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;

bool isFriend[10000][10000];
vector<int> v[10000];
struct node{
    int a, b;
};
bool cmp(node x, node y) {//用来排序
    if(x.a == y.a) return x.b < y.b;
    return x.a < y.a;
}

int main(){
    int n, m, k;
    cin >> n >> m;
    
    // +0000 与 -0000 如果用int 无法判断性别
    for (int i = 0; i < m; i++) {
        string sa, sb;
        cin >> sa >> sb;
        int a = abs(stoi(sa));
        int b = abs(stoi(sb));
        if(sa.length() == sb.length()){
            v[a].push_back(b);
            v[b].push_back(a);;
        }
         isFriend[a][b] = isFriend[b][a] = true;
    }
   
    cin >> k;
    for (int i = 0; i < k; i++) {
        int c, d;
        cin >> c >> d;
        c = abs(c);
        d = abs(d);
        vector<node> ans;
        
        for (int j = 0; j < v[c].size(); j++) {
            for (int k = 0; k < v[d].size(); k++) {
                if(v[c][j] == d || v[d][k] == c) continue;
                if(isFriend[v[c][j]][v[d][k]] == true){
                    ans.push_back(node{v[c][j], v[d][k]});
                }
            }
        }
        
        sort(ans.begin(), ans.end(), cmp);
        cout << ans.size() << endl;
        for (int i = 0; i < ans.size(); i++) {
            printf("%04d %04d\n", ans[i].a, ans[i].b);
        }
    }
    
    return 0;
}

目录
相关文章
|
1月前
|
XML JSON API
Title: Empowering E-commerce with the Product Details Upload API Interface
Title: Empowering E-commerce with the Product Details Upload API Interface
|
内存技术
Obtain the data code of Taobao JD1688alibaba lazada shop product details page
1、 Data types of e-commerce APIs The types of data provided by e-commerce APIs are diverse and can generally be divided into the following categories: Product data: Product ID, Product Name, Product Price, Inventory, etc. Transaction data: order number, payment time, recipient, etc. Store data
Obtain the data code of Taobao JD1688alibaba lazada shop product details page
|
存储
【PAT甲级】1139 First Contact
【PAT甲级】1139 First Contact
79 0
【1139】First Contact (30分)
【1139】First Contact (30分) 【1139】First Contact (30分)
84 0
UWP DEP0700: 应用程序注册失败。[0x80073CF9] Install failed. Please contact your software vendor. (Exception from HRESULT: 0x80073CF9)
原文:UWP DEP0700: 应用程序注册失败。[0x80073CF9] Install failed. Please contact your software vendor. (Exception from HRESULT: 0x80073CF9) 现在部署的app项目八成是从以前的一个项目复制过来,修改的。
1559 0
|
SQL 数据库 关系型数据库