//a[-1]就跟*(a-1)一样 不影响本程序结果
Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N ( <= 20 ) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:
data left_child right_child
where data is a string of no more than 10 characters, left_child and right_child are the indices of this node’s left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by -1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.
Figure 1
Figure 2
Output Specification:
For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.
Sample Input 1:
8
* 8 7
a -1 -1
* 4 1
+ 2 5
b -1 -1
d -1 -1
- -1 6
c -1 -1
Sample Output 1:
(a+b)(c(-d))
Sample Input 2:
8
2.35 -1 -1
* 6 1
- -1 4
% 7 8
+ 2 3
a -1 -1
str -1 -1
871 -1 -1
Sample Output 2:
(a*2.35)+(-(str%871))
#include <iostream>
#include <vector>
using namespace std;
struct node{
string val;
int left, right;
};
vector<node> v;
int n, root = 1;
//每一棵子树的左右两端都要加括号
string dfs(int index){
if(index == -1) return "";
if(v[index].right != -1){//不存在只有左子树没有右子树的情况
v[index].val = dfs(v[index].left) + v[index].val + dfs(v[index].right);
if (index != root) v[index].val = '(' + v[index].val + ')';
}
return v[index].val;
}
int main(){
cin >> n;
v.resize(n+1);
vector<bool> visit(n + 1, false);//用来标记非根结点
for (int i = 1; i <= n; i++) {
cin >> v[i].val >> v[i].left >> v[i].right;
if(v[i].left != -1) visit[v[i].left] = true;
if(v[i].right != -1) visit[v[i].right] = true;
}
while (visit[root] == true) root++;//找到根结点
cout << dfs(root) << endl;
return 0;
}