[解决办法]windows的非administrator账户无法通过plsql工具登录oracle数据库

简介: 环境:windows2008服务器、使用的非administrator账户,而是新建了一个windows2008账户、安装好了plsql工具。问题:使用administrator账户可以用plsql工具连接成功oracle数据库;但是使用非administrator账户用plsql工具连接oracle数据库失败,如下图:原因:经过反复排查,是因为plsql工具没有获取系统的权限,而且加入了administrators组也是无效,主要原因是windows在vista系统之后新增了一个UAC(用户账户控制)功能(PS:有兴趣的可以百度一下)。

环境:
windows2008服务器、使用的非administrator账户,而是新建了一个windows2008账户、安装好了plsql工具。

问题:
使用administrator账户可以用plsql工具连接成功oracle数据库;
但是使用非administrator账户用plsql工具连接oracle数据库失败,如下图:

wKioL1Z6Y2vhSCYEAAKKmFKp5K4293.png


原因:
经过反复排查,是因为plsql工具没有获取系统的权限,而且加入了administrators组也是无效,主要原因是windows在vista系统之后新增了一个UAC(用户账户控制)功能(PS:有兴趣的可以百度一下)。

解决办法:
(1)先在windows2008服务器中,找到plsql工具的绝对路径,然后右击plsqldev.exe的属性,在“兼容性”中勾选“请以管理员身份允许该程序”。
(2)然后到dwindows2008服务器中,打开[控制面板/用户账户/打开或关闭“用户账户控制”]界面,然后把“使用用户账户控制(UAC)帮助帮助您的计算机”的勾选取消掉。勾选取消掉之后,会提示要求重启,因为重启之后才生效!
    配置如下图:(配置位置可能不一样,以下图仅供参考!)
wKioL1Z48KCDgQdHAAX84OlyiAI182.jpg


相关文章
|
SQL Oracle 关系型数据库
基于YMP工具实现Oracle迁移YashanDB
这篇文章主要介绍了基于 YMP 工具实现 Oracle 迁移 YashanDB 的相关内容,包括 YMP 工具的简介、架构、规格,迁移前的环境准备和工具部署,迁移过程中的创建任务、评估、配置、离线迁移、校验等步骤,以及迁移体验,指出其部署简单、数据类型兼容但存在部分功能不支持等情况。
|
SQL Oracle 关系型数据库
PLSQL还原DMP数据库的详细步骤
PLSQL还原DMP数据库的详细步骤
1782 6
|
Windows
windows端口冲突解决办法
windows端口冲突解决办法
854 1
windows端口冲突解决办法
|
SQL Oracle 关系型数据库
关系型数据库Oracle备份工具
【7月更文挑战第19天】
736 4
|
Oracle 关系型数据库 Java
Oracle数据库导入工具IMP详解与用法
Oracle数据库导入工具IMP详解与用法
|
SQL Oracle 关系型数据库
探索 Linux 命令 `db_archive`:Oracle 数据库归档日志的工具
探索 Linux 中的 `db_archive`,实际与 Oracle 数据库归档日志管理相关。在 Oracle 中,归档日志用于恢复,当在线重做日志满时自动归档。管理员可使用 SQL*Plus 查看归档模式,通过 `RMAN` 进行备份和恢复操作。管理归档日志需谨慎,避免数据丢失。了解归档管理对 Oracle 管理员至关重要,确保故障时能快速恢复数据库。
|
Windows
windows系统vbs脚本 恶搞关不掉的窗口 以及解决办法
windows系统vbs脚本 恶搞关不掉的窗口 以及解决办法
759 2
|
Oracle 网络协议 关系型数据库
异地使用PLSQL远程连接访问Oracle数据库【内网穿透】
异地使用PLSQL远程连接访问Oracle数据库【内网穿透】
411 1
windows11物理机和VM中windows10虚拟机共享文件解决办法问题
windows11物理机和VM中windows10虚拟机共享文件解决办法问题
|
Oracle 关系型数据库 Java
Oracle数据库导入工具IMP详解与用法
Oracle数据库导入工具IMP详解与用法

推荐镜像

更多