C-POJ-1426 Find The Multiple

简介: Description Given a positive integer n, write a program to find out a nonzero multiple m o...

Description
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input
2
6
19
0

Sample Output
10
100100100100100100
111111111111111111

BFS、DFS都可以

  1. BFS
#include<iostream>
#include<cstring>
#include<cstdio>
#include<queue>
using namespace std;
typedef long long LL;
void BFS(int n){
    LL ans=1,b;
    queue <LL> a;
    a.push(ans);
    while(!a.empty()){
    b=a.front();
    a.pop();
    if(b%n==0){
        printf("%lld\n",b);
        return;
    }
    a.push(b*10);
    a.push(b*10+1);
    }
    return;
}
int main(){
    int n;
    while(scanf("%d",&n)!=EOF){
        if(n==0)
            break;
        BFS(n);
    }
    return 0;
}
  1. DFS
#include<stdio.h>
#include<string.h>
#include<stdbool.h>
char ans[1005];
bool flag;
void dfs(int mod,int k,int n){
    if(k>20){
        ans[k]='\0';
        return;
    }
    if(mod==0){
        flag=true;
        return;
    }
    if(!flag){
        ans[k]='0';
        dfs((mod*10)%n,k+1,n);
    }
    if(!flag){
        ans[k]='1';
        dfs((mod*10+1)%n,k+1,n);
    }
    if(!flag){
        ans[k]='\0';
    }
}
int main(){
    int n;
    while(scanf("%d",&n)!=EOF){
        if(n==0)
            break;
        ans[0]='1';
        flag=false;
        dfs(1,1,n);
        printf("%s\n",ans);
        memset(ans,'\0',sizeof(ans));
    }
    return 0;
}

这题很简单,没啥说的。

目录
相关文章
|
1月前
hdu 1019 Least Common Multiple
hdu 1019 Least Common Multiple
18 0
|
7月前
hdu 1019 Least Common Multiple
hdu 1019 Least Common Multiple
20 0
|
8月前
codeforces 344B - Simple Molecules
题意就是给出3个原子的化学价,然后组成一个分子,要保证这个分子是稳定的,如果你还记得高中化学知识的话这个很容易理解,然后让你求出1-2 2-3 1-3 号原子之间有几条键, 这里我分别用ta tb tc 表示, 用数学的方法表示出来的话就是a = tc + tb; b = ta+tc; c = ta + tb;可能有多种情况,只要输出一种即可。
27 0
|
9月前
Find The Multiple(dfs和bfs都可)
Find The Multiple(dfs和bfs都可)
15 0
|
人工智能 BI
CF1169C. Increasing by Modulo(二分)
CF1169C. Increasing by Modulo(二分)
93 0
PAT (Advanced Level) Practice - 1068 Find More Coins(30 分)
PAT (Advanced Level) Practice - 1068 Find More Coins(30 分)
97 0
|
Java C语言
HDOJ(HDU) 2139 Calculate the formula(水题,又一个用JavaAC不了的题目)
HDOJ(HDU) 2139 Calculate the formula(水题,又一个用JavaAC不了的题目)
81 0
HDOJ 1019 Least Common Multiple(最小公倍数问题)
HDOJ 1019 Least Common Multiple(最小公倍数问题)
82 0
HDOJ 2028 Lowest Common Multiple Plus(n个数的最小公倍数)
HDOJ 2028 Lowest Common Multiple Plus(n个数的最小公倍数)
104 0