zoj 3829 Known Notation(2014在牡丹江区域赛k称号)

简介:
Known Notation
Time Limit: 2 Seconds       Memory Limit: 131072 KB

Do you know reverse Polish notation (RPN)? It is a known notation in the area of mathematics and computer science. It is also known as postfix notation since every operator in an expression follows all of its operands. Bob is a student in Marjar University. He is learning RPN recent days.

To clarify the syntax of RPN for those who haven't learnt it before, we will offer some examples here. For instance, to add 3 and 4, one would write "3 4 +" rather than "3 + 4". If there are multiple operations, the operator is given immediately after its second operand. The arithmetic expression written "3 - 4 + 5" in conventional notation would be written "3 4 - 5 +" in RPN: 4 is first subtracted from 3, and then 5 added to it. Another infix expression "5 + ((1 + 2) × 4) - 3" can be written down like this in RPN: "5 1 2 + 4 × + 3 -". An advantage of RPN is that it obviates the need for parentheses that are required by infix.

In this problem, we will use the asterisk "*" as the only operator and digits from "1" to "9" (without "0") as components of operands.

You are given an expression in reverse Polish notation. Unfortunately, all space characters are missing. That means the expression are concatenated into several long numeric sequence which are separated by asterisks. So you cannot distinguish the numbers from the given string.

You task is to check whether the given string can represent a valid RPN expression. If the given string cannot represent any valid RPN, please find out the minimal number of operations to make it valid. There are two types of operation to adjust the given string:

  1. Insert. You can insert a non-zero digit or an asterisk anywhere. For example, if you insert a "1" at the beginning of "2*3*4", the string becomes "12*3*4".
  2. Swap. You can swap any two characters in the string. For example, if you swap the last two characters of "12*3*4", the string becomes "12*34*".

The strings "2*3*4" and "12*3*4" cannot represent any valid RPN, but the string "12*34*" can represent a valid RPN which is "1 2 * 34 *".

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is a non-empty string consists of asterisks and non-zero digits. The length of the string will not exceed 1000.

Output

For each test case, output the minimal number of operations to make the given string able to represent a valid RPN.

Sample Input

3
1*1
11*234**
*

Sample Output

1
0
2
 
先算最少加入的数, 再交换。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const int N = 1111;
int main()
{
    int T;
    scanf("%d", &T);
    while (T--)
    {
        char s[N];
        scanf("%s", s);
        int totNum = 0, totChar = 0;
        int len = (int) strlen(s);
        int flag = 0;
        for (int i = 0; i < len && !flag; ++i)
            if (s[i] == '*') flag = 1;
        if (!flag)
        {
            cout << 0 << endl;
            continue;
        }
        int ans = 0;
        for (int i = 0; i < len; ++i)
            if (s[i] == '*') totChar++;
            else totNum++;
        if (totChar - totNum + 1 > 0) ans = totChar - totNum + 1;
        int a[N * 5];
        int curLen = len + ans;
        memset(a, 0, sizeof(a));
        if (ans > 0)
        {
            for (int i = ans + 1; i <= curLen; ++i)
                if (s[i - 1 - ans] == '*') a[i] = 1;
        }
        else
        {
            for (int i = 1; i <= curLen; ++i)
                if (s[i - 1] == '*') a[i] = 1;
        }
        if (!a[curLen])
        {
            int l = 1;
            while (l <= curLen)
            {
                if (a[l]) break;
                else l++;
            }
            swap(a[l], a[curLen]);
            ++ans;
        }
        int r = curLen, pos = 1, tot = 0;
        while (pos <= curLen)
        {
            if (!a[pos])
            {
                tot++;
                pos++;
            }
            else
            {
                if (tot < 2)
                {
                    int p = -1;
                    for (int i = r; i >= 1 && p != -1; --i)
                        if (!a[i]) p = i;
                    swap(a[p], a[pos]);
                    ans++;
                    pos++;
                    tot++;
                    r = p - 1;
                }
                else
                {
                    tot--;
                    pos++;
                }
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}


版权声明:本文博客原创文章,博客,未经同意,不得转载。





本文转自mfrbuaa博客园博客,原文链接:http://www.cnblogs.com/mfrbuaa/p/4642562.html,如需转载请自行联系原作者


相关文章
|
5月前
(2021 ICPC)亚洲区域赛(昆明)I.Mr. Main and Windmills
(2021 ICPC)亚洲区域赛(昆明)I.Mr. Main and Windmills
29 0
(2021 ICPC)亚洲区域赛(昆明)I.Mr. Main and Windmills
第20届上海市青少年计算机应用操作竞赛 ☆线下赛 T1.阶乘求和
第20届上海市青少年计算机应用操作竞赛 ☆线下赛 T1.阶乘求和
146 0
|
C语言 C++
PTA团体程序设计天梯赛-练习集: L1-050 倒数第N个字符串 ( 15分 )
给定一个完全由小写英文字母组成的字符串等差递增序列,该序列中的每个字符串的长度固定为 L,从 L 个 a 开始,以 1 为步长递增。例如当 L 为 3 时,序列为 { aaa, aab, aac, ..., aaz, aba, abb, ..., abz, ..., zzz }。这个序列的倒数第27个字符串就是 zyz。对于任意给定的 L,本题要求你给出对应序列倒数第 N 个字符串。 输入格式: 输入在一行中给出两个正整数 L(2 ≤ L ≤ 6)和 N(≤105)。 输出格式: 在一行中输出对应序列倒数第 N 个字符串。题目保证这个字符串是存在的。 输入样例:
154 0
|
测试技术 C语言 C++
PTA团体程序设计天梯赛-练习集:L1-003 个位数统计
给定一个 k 位整数 N=dk−110k−1+⋯+d1101+d0 (0≤di≤9, i=0,⋯,k−1, dk−1>0),请编写程序统计每种不同的个位数字出现的次数。例如:给定 N=100311,则有 2 个 0,3 个 1,和 1 个 3。 输入格式: 每个输入包含 1 个测试用例,即一个不超过 1000 位的正整数 N。 输出格式: 对 N 中每一种不同的个位数字,以 D:M 的格式在一行中输出该位数字 D 及其在 N 中出现的次数 M。要求按 D 的升序输出。
178 0
|
机器学习/深度学习 算法 机器人
Xue Bin Peng获SIGGRAPH 2022最佳博士论文,太极胡渊鸣获提名(1)
Xue Bin Peng获SIGGRAPH 2022最佳博士论文,太极胡渊鸣获提名
137 0
|
机器学习/深度学习 人工智能 算法
Xue Bin Peng获SIGGRAPH 2022最佳博士论文,太极胡渊鸣获提名(2)
Xue Bin Peng获SIGGRAPH 2022最佳博士论文,太极胡渊鸣获提名
121 0
PTA 7-2 数字之王 (20 分)
给定两个正整数 N 1 ​ <N 2 ​ 。把从 N 1 ​ 到 N 2 ​ 的每个数的各位数的立方相乘,再将结果的各位数求和,得到一批新的数字,再对这批新的数字重复上述操作,直到所有数字都是 1 位数为止
115 0
|
机器学习/深度学习 人工智能
PTA 7-3 拼题 A 是真爱 (20 分)
如果一个人在一段话里很多次提到 pintia,那对拼题 A 就是真爱啦~ 本题就请你检查一下给定的文字中出现了几次 pintia。
133 0
|
人工智能
【CCCC】PAT : 团体程序设计天梯赛-练习集 L1 答案
【CCCC】PAT : 团体程序设计天梯赛-练习集 L1 答案
355 0
【CCCC】PAT : 团体程序设计天梯赛-练习集 L3 答案(01-23)
【CCCC】PAT : 团体程序设计天梯赛-练习集 L3 答案(01-23)
118 0