zoj 3829 Known Notation(2014在牡丹江区域赛k称号)

简介:
Known Notation
Time Limit: 2 Seconds       Memory Limit: 131072 KB

Do you know reverse Polish notation (RPN)? It is a known notation in the area of mathematics and computer science. It is also known as postfix notation since every operator in an expression follows all of its operands. Bob is a student in Marjar University. He is learning RPN recent days.

To clarify the syntax of RPN for those who haven't learnt it before, we will offer some examples here. For instance, to add 3 and 4, one would write "3 4 +" rather than "3 + 4". If there are multiple operations, the operator is given immediately after its second operand. The arithmetic expression written "3 - 4 + 5" in conventional notation would be written "3 4 - 5 +" in RPN: 4 is first subtracted from 3, and then 5 added to it. Another infix expression "5 + ((1 + 2) × 4) - 3" can be written down like this in RPN: "5 1 2 + 4 × + 3 -". An advantage of RPN is that it obviates the need for parentheses that are required by infix.

In this problem, we will use the asterisk "*" as the only operator and digits from "1" to "9" (without "0") as components of operands.

You are given an expression in reverse Polish notation. Unfortunately, all space characters are missing. That means the expression are concatenated into several long numeric sequence which are separated by asterisks. So you cannot distinguish the numbers from the given string.

You task is to check whether the given string can represent a valid RPN expression. If the given string cannot represent any valid RPN, please find out the minimal number of operations to make it valid. There are two types of operation to adjust the given string:

  1. Insert. You can insert a non-zero digit or an asterisk anywhere. For example, if you insert a "1" at the beginning of "2*3*4", the string becomes "12*3*4".
  2. Swap. You can swap any two characters in the string. For example, if you swap the last two characters of "12*3*4", the string becomes "12*34*".

The strings "2*3*4" and "12*3*4" cannot represent any valid RPN, but the string "12*34*" can represent a valid RPN which is "1 2 * 34 *".

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is a non-empty string consists of asterisks and non-zero digits. The length of the string will not exceed 1000.

Output

For each test case, output the minimal number of operations to make the given string able to represent a valid RPN.

Sample Input

3
1*1
11*234**
*

Sample Output

1
0
2
 
先算最少加入的数, 再交换。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const int N = 1111;
int main()
{
    int T;
    scanf("%d", &T);
    while (T--)
    {
        char s[N];
        scanf("%s", s);
        int totNum = 0, totChar = 0;
        int len = (int) strlen(s);
        int flag = 0;
        for (int i = 0; i < len && !flag; ++i)
            if (s[i] == '*') flag = 1;
        if (!flag)
        {
            cout << 0 << endl;
            continue;
        }
        int ans = 0;
        for (int i = 0; i < len; ++i)
            if (s[i] == '*') totChar++;
            else totNum++;
        if (totChar - totNum + 1 > 0) ans = totChar - totNum + 1;
        int a[N * 5];
        int curLen = len + ans;
        memset(a, 0, sizeof(a));
        if (ans > 0)
        {
            for (int i = ans + 1; i <= curLen; ++i)
                if (s[i - 1 - ans] == '*') a[i] = 1;
        }
        else
        {
            for (int i = 1; i <= curLen; ++i)
                if (s[i - 1] == '*') a[i] = 1;
        }
        if (!a[curLen])
        {
            int l = 1;
            while (l <= curLen)
            {
                if (a[l]) break;
                else l++;
            }
            swap(a[l], a[curLen]);
            ++ans;
        }
        int r = curLen, pos = 1, tot = 0;
        while (pos <= curLen)
        {
            if (!a[pos])
            {
                tot++;
                pos++;
            }
            else
            {
                if (tot < 2)
                {
                    int p = -1;
                    for (int i = r; i >= 1 && p != -1; --i)
                        if (!a[i]) p = i;
                    swap(a[p], a[pos]);
                    ans++;
                    pos++;
                    tot++;
                    r = p - 1;
                }
                else
                {
                    tot--;
                    pos++;
                }
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}


版权声明:本文博客原创文章,博客,未经同意,不得转载。





本文转自mfrbuaa博客园博客,原文链接:http://www.cnblogs.com/mfrbuaa/p/4642562.html,如需转载请自行联系原作者


相关文章
|
8月前
2017ICPC沈阳区域赛 F
2017ICPC沈阳区域赛 F
44 0
|
定位技术 Go
第 45 届国际大学生程序设计竞赛(ICPC)亚洲区域赛(银川),签到题5题
第 45 届国际大学生程序设计竞赛(ICPC)亚洲区域赛(银川),签到题5题
99 0
|
5月前
[SWPUCTF 2022 新生赛]base64
[SWPUCTF 2022 新生赛]base64
78 0
|
8月前
|
人工智能 测试技术
【“红旗杯”第十四届吉林省大学生程序设计竞赛】 之 C - String Game
【“红旗杯”第十四届吉林省大学生程序设计竞赛】 之 C - String Game
|
8月前
(2021 ICPC)亚洲区域赛(昆明)I.Mr. Main and Windmills
(2021 ICPC)亚洲区域赛(昆明)I.Mr. Main and Windmills
42 0
(2021 ICPC)亚洲区域赛(昆明)I.Mr. Main and Windmills
中国天眼FAST再立功,精确测量星际磁场强度,研究登Nature封面
中国天眼FAST再立功,精确测量星际磁场强度,研究登Nature封面
101 0
UPC组队赛第三场——G: The Famous ICPC Team Again (主席树)
UPC组队赛第三场——G: The Famous ICPC Team Again (主席树)
104 0
|
数据格式
UPC新生赛—— 排序(思维)
UPC新生赛—— 排序(思维)
116 0
|
算法
每日一题冲刺大厂第十三天提高组 第46届ICPC 东亚区域赛 A题
大家好,我是泡泡,给大家带来每日一题的目的是为了更好的练习算法,我们的每日一题提高组是为了有余力的同学准备的,让大家练到各种各样的题目,一年以后,蜕变成为一个不一样的自己!
133 0
|
关系型数据库 数据中心 ice
Google Earth Engine——AVHRR探路者5.3版海面温度数据集(PFV53)是由NOAA国家海洋学数据中心和迈阿密大学罗森斯蒂尔海洋与大气科学学院合作制作的全球每日两次的4公里数据
Google Earth Engine——AVHRR探路者5.3版海面温度数据集(PFV53)是由NOAA国家海洋学数据中心和迈阿密大学罗森斯蒂尔海洋与大气科学学院合作制作的全球每日两次的4公里数据
491 0
Google Earth Engine——AVHRR探路者5.3版海面温度数据集(PFV53)是由NOAA国家海洋学数据中心和迈阿密大学罗森斯蒂尔海洋与大气科学学院合作制作的全球每日两次的4公里数据

热门文章

最新文章