【python3.5】安装lxml中没有etree模块的问题解决方法-阿里云开发者社区

开发者社区> 小可同学> 正文

【python3.5】安装lxml中没有etree模块的问题解决方法

简介: 【python3.5】安装lxml中没有etree模块的问题解决方法
+关注继续查看

技术交流群:127591054

楼主,在爬网页抓数据的时候。发现lxml死活装不上,百度了试了这种奇葩做法,最终还是不行,知道看到一个神作!!哈哈。我总结一下这个问题。
我用pip自动装的,lxml发现报错!!!然后手动解决问题!
**问题描述:running build_ext building 'lxml.etree' extension
目测是没有找到lxml.etree这个模块!!**
下面开始解决!!

我需要装的包,大伙如果需要可以装,这个没什么依赖的!

python -m pip install requests

lxml依赖的包,网上说有很多!我最后都没有装,也装上了!
主要一点,首先更新pip 。如果没更新的话,目前版本9.1

python -m pip install --upgrade pip

下载这个版本:lxml-3.7.1-cp35-cp35m-win_amd64.whl
高一点版本提示:running build_ext building 'lxml.etree' extension 没有这个包,所以装3.7版本
点击这个地址下载lxml。

python -m pip install 对应本地路径./lxml-3.7.1-cp35-cp35m-win_amd64.whl

然后就可以啦~~~~

版权声明:本文内容由阿里云实名注册用户自发贡献,版权归原作者所有,阿里云开发者社区不拥有其著作权,亦不承担相应法律责任。具体规则请查看《阿里云开发者社区用户服务协议》和《阿里云开发者社区知识产权保护指引》。如果您发现本社区中有涉嫌抄袭的内容,填写侵权投诉表单进行举报,一经查实,本社区将立刻删除涉嫌侵权内容。

相关文章
windows7 python3.4 安装scrapy
首先升级pip 虽然提示说已经升级,但是查看版本还是发现不对,随即进入C:\Python34\Lib\site-packages 查看已经存在9.0.1的版本,怎么办?将其移除,重新升级 安装lxml lxml是解析网页用的,scrapy依赖于它,它是一个第三方的库,这里推荐一个Python第三方库的网站http://www.lfd.uci.edu/~gohlke/pythonlibs/,里边都是编译好的,windows下python使用者的福利。
771 0
CentOS 6.5安装二进制版本的MongoDB 2.6
CentOS 6.5安装二进制版本的MongoDB 2.6 MongoDB的国外镜像访问非常慢,以至于选择MongoDB官网的在线安装很不靠谱。那么,我们可以选择安装MongoDB 2.6的二进制发布包。
795 0
VS2010无法保存项目文件(.csprj)的问题解决方法
VS2010无法保存项目文件(.csprj)的问题解决方法   【出错提示】保存项目文件“XXX”时出错。类没有注册。正在查找具有CLSID的对象:{D9B3211D-E57F-4426-AAEF-30A806ADD397}。
968 0
解决JDk1.6无法安装得问题
最近得JDK1.6测试版下载回来后总是安装不了, 一双击安装文件来,就会提示“无法应用转换程序“,其实这是 JDK1.6 开发中得一个下BUG,这个BUG将再B94中得到修正。
535 0
安装PageAdmin Cms时候“System.ServiceModel.Activation.HttpModule”错误的解决办法
未能从程序集“System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089”中加载类型“System.ServiceModel.Activation.HttpModule”。
1085 0
+关注
小可同学
喜欢学习的童孩
21
文章
0
问答
文章排行榜
最热
最新
相关电子书
更多
《2021云上架构与运维峰会演讲合集》
立即下载
《零基础CSS入门教程》
立即下载
《零基础HTML入门教程》
立即下载