【UVA272】TEX Quotes

简介:
A - TEX Quotes
Time Limit:3000MS    Memory Limit:0KB    64bit IO Format:%lld & %llu
Appoint description:

Description

TeX is a typesetting language developed by Donald Knuth. It takes source text together with a few typesetting instructions and produces, one hopes, a beautiful document. Beautiful documents use `` and " to delimit quotations, rather than the mundane " which is what is provided by most keyboards. Keyboards typically do not have an oriented double-quote, but they do have a left-single-quote ` and a right-single-quote '. Check your keyboard now to locate the left-single-quote key ` (sometimes called the ``backquote key") and the right-single-quote key ' (sometimes called the ``apostrophe" or just ``quote"). Be careful not to confuse the left-single-quote ` with the ``backslash" key \TeX lets the user type two left-single-quotes `` to create a left-double-quote `` and two right-single-quotes '' to create a right-double-quote ''. Most typists, however, are accustomed to delimiting their quotations with the un-oriented double-quote ".

If the source contained

"To be or not to be," quoth the bard, "that is the question."

then the typeset document produced by TeX would not contain the desired form:

``To be or not to be," quoth the bard, ``that is the question."

In order to produce the desired form, the source file must contain the sequence:

``To be or not to be,'' quoth the bard, ``that is the question.''

You are to write a program which converts text containing double-quote (") characters into text that is identical except that double-quotes have been replaced by the two-character sequences required by TeX for delimiting quotations with oriented double-quotes. The double-quote (") characters should be replaced appropriately by either `` if the " opens a quotation and by '' if the " closes a quotation. Notice that the question of nested quotations does not arise: The first" must be replaced by ``, the next by '', the next by ``, the next by '', the next by ``, the next by '', and so on.

Input

Input will consist of several lines of text containing an even number of double-quote (") characters. Input is ended with an end-of-file character.

Output

The text must be output exactly as it was input except that:

  • the first " in each pair is replaced by two ` characters: `` and
  • the second " in each pair is replaced by two ' characters: ''.

Sample Input

"To be or not to be," quoth the Bard, "that
is the question".
The programming contestant replied: "I must disagree.
To `C' or not to `C', that is The Question!"

Sample Output

``To be or not to be,'' quoth the Bard, ``that
is the question''.
The programming contestant replied: ``I must disagree.
To `C' or not to `C', that is The Question!''
题意:大概就是一段话里面全部的双引號编程TeX里面的左双引號和右双引號的形式

题解:一个一个字符的读入 进行推断 注意TeX区分左右双引號 用一个flag做标记

include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int main(){
    char c;
    bool flag = true;
    while((c = getchar()) != EOF){
        if(c == '"'){
            if(flag){
                printf("``");
                flag = false;
            }
            else{
                printf("''");
                flag = true;
            }
        }
        else{
            printf("%c", c);
        }
    }
    return 0;
}


版权声明:本文博主原创文章。博客,未经同意不得转载。







本文转自mfrbuaa博客园博客,原文链接:http://www.cnblogs.com/mfrbuaa/p/4872516.html,如需转载请自行联系原作者


相关文章
UVa11565 - Simple Equations
UVa11565 - Simple Equations
48 0
UVa1583 - Digit Generator
UVa1583 - Digit Generator
46 0
UVa389 - Basically Speaking
UVa389 - Basically Speaking
35 0
|
安全 数据安全/隐私保护
HDOJ/HDU 1039 Easier Done Than Said?(字符串处理~)
HDOJ/HDU 1039 Easier Done Than Said?(字符串处理~)
101 0
1005. Spell It Right (20)
#include using namespace std; int main(int argc, const char * argv[]) { string s; cin >> s; int sum = 0, len = (int)s.
874 0
|
C++
uva10635Prince and Princess
题意:有两个长度分别为p+1和q+1的序列,每个序列中的各个元素互不相同,且都是1~n2之间的整数,两个序列的第一个元素都是1,问A和B的最长公共子序列的长度 分析:由于在同一个序列中元素互不相同,可以转化LCS问题为LIS问题,使用了“置换的思想”,有点类似于“离散化”,然后用stl的lower...
610 0