【UVA272】TEX Quotes

简介:
A - TEX Quotes
Time Limit:3000MS    Memory Limit:0KB    64bit IO Format:%lld & %llu
Appoint description:

Description

TeX is a typesetting language developed by Donald Knuth. It takes source text together with a few typesetting instructions and produces, one hopes, a beautiful document. Beautiful documents use `` and " to delimit quotations, rather than the mundane " which is what is provided by most keyboards. Keyboards typically do not have an oriented double-quote, but they do have a left-single-quote ` and a right-single-quote '. Check your keyboard now to locate the left-single-quote key ` (sometimes called the ``backquote key") and the right-single-quote key ' (sometimes called the ``apostrophe" or just ``quote"). Be careful not to confuse the left-single-quote ` with the ``backslash" key \TeX lets the user type two left-single-quotes `` to create a left-double-quote `` and two right-single-quotes '' to create a right-double-quote ''. Most typists, however, are accustomed to delimiting their quotations with the un-oriented double-quote ".

If the source contained

"To be or not to be," quoth the bard, "that is the question."

then the typeset document produced by TeX would not contain the desired form:

``To be or not to be," quoth the bard, ``that is the question."

In order to produce the desired form, the source file must contain the sequence:

``To be or not to be,'' quoth the bard, ``that is the question.''

You are to write a program which converts text containing double-quote (") characters into text that is identical except that double-quotes have been replaced by the two-character sequences required by TeX for delimiting quotations with oriented double-quotes. The double-quote (") characters should be replaced appropriately by either `` if the " opens a quotation and by '' if the " closes a quotation. Notice that the question of nested quotations does not arise: The first" must be replaced by ``, the next by '', the next by ``, the next by '', the next by ``, the next by '', and so on.

Input

Input will consist of several lines of text containing an even number of double-quote (") characters. Input is ended with an end-of-file character.

Output

The text must be output exactly as it was input except that:

  • the first " in each pair is replaced by two ` characters: `` and
  • the second " in each pair is replaced by two ' characters: ''.

Sample Input

"To be or not to be," quoth the Bard, "that
is the question".
The programming contestant replied: "I must disagree.
To `C' or not to `C', that is The Question!"

Sample Output

``To be or not to be,'' quoth the Bard, ``that
is the question''.
The programming contestant replied: ``I must disagree.
To `C' or not to `C', that is The Question!''
题意:大概就是一段话里面全部的双引號编程TeX里面的左双引號和右双引號的形式

题解:一个一个字符的读入 进行推断 注意TeX区分左右双引號 用一个flag做标记

include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int main(){
    char c;
    bool flag = true;
    while((c = getchar()) != EOF){
        if(c == '"'){
            if(flag){
                printf("``");
                flag = false;
            }
            else{
                printf("''");
                flag = true;
            }
        }
        else{
            printf("%c", c);
        }
    }
    return 0;
}


版权声明:本文博主原创文章。博客,未经同意不得转载。







本文转自mfrbuaa博客园博客,原文链接:http://www.cnblogs.com/mfrbuaa/p/4872516.html,如需转载请自行联系原作者


相关文章
|
算法
light oj 1258 - Making Huge Palindromes(KMP)
ight oj里这个题目是属于KMP分类的,但乍看好像不是kmp,因为只有一个字符串。要想的到一个回文串,把该字符串翻转接到原串后面必然是一个回文串,但并不一定是最短的。我们必须考虑怎么把两个串尽量融合在一起,这就要看翻转串的前段与原串的后段有多少是匹配的了,这里就用到了KMP算法。
41 1
UVa1583 - Digit Generator
UVa1583 - Digit Generator
54 0
UVa11565 - Simple Equations
UVa11565 - Simple Equations
54 0
1005. Spell It Right (20)
#include using namespace std; int main(int argc, const char * argv[]) { string s; cin >> s; int sum = 0, len = (int)s.
879 0
|
人工智能 BI 算法
uva 1121 - Subsequence
点击打开链接uva 1121 思路:二分查找 分析: 1 题目要求找到一个最短的子序列长度并且这个子序列的和大于等于给定的s 2 如果按照常规的做法枚举起点和终点的话肯定是会超时的。
935 0
uva 11210 Chinese Mahjong
点击打开链接uva 11210 思路:模拟 分析: 1 根据题目我们可以知道总共有34种牌,分别是(9张饼+9张条+9张万+东南西北+中发白) 2 题目明确说明“胡牌”的请况是“将+刻子(>=0)+顺子(>=0)”,那么我们知道最多有34总牌,那么我们只要去枚举每一种是否可以作为将,然后去判断剩下的是否满足刻子和顺子即可 3 注意题目明确说明如果输入的时候是4张一样的牌,那么这个牌是不可能听的。
1114 0

热门文章

最新文章