最长上升子序列 POJ2533

简介:
Longest Ordered Subsequence
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 18853   Accepted: 8147

Description

A numeric sequence of  ai is ordered if  a1 <  a2 < ... <  aN. Let the subsequence of the given numeric sequence ( a1a2, ...,  aN) be any sequence ( ai1ai2, ...,  aiK), where 1 <=  i1 <  i2 < ... <  iK <=  N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

Source

Northeastern Europe 2002, Far-Eastern Subregion
 
题目的大意是:给出一序列,求出该序列的最长上升子序列的最大长度。
思路:用数组a[]存储序列,b[i]表示以a[i]为结尾的序列的最大长度。
因此要求出b[i]的最大值,即求出max{b[0],b[1]....b[i-1]}的最大值,那么b[i]的最大值为max{b[0],b[1]....b[i-1]}+1;
即可写出状态方程:b[i]=max{b[0],b[1].....b[j]}+1;(0<=j<i&&a[j]<a[i]),然后求出数组b[]中的最大值即为所求。
#include<iostream>
using  namespace  std;
 
int  main( void )
{
     int  i,j,n;
     int  a[1001];
     int  b[1001];
     int  max;
     scanf ( "%d" ,&n);
     for (i=0;i<n;i++)
     {
         scanf ( "%d" ,&a[i]);
         b[i]=1;
     }
     for (i=0;i<n;i++)
     {
         max=0;
         for (j=0;j<i;j++)
         {
             if (a[i]>a[j]&&b[j]>max)
             {
                 max=b[j];
             }
         }
         b[i]=max+1;
     }
     max=0;
     for (i=0;i<n;i++)
     {
         if (max<b[i])
             max=b[i];
     }
     printf ( "%d\n" ,max);
     return  0;
}
 
 
本文转载自海 子博客园博客,原文链接:http://www.cnblogs.com/dolphin0520/archive/2011/07/09/2102044.html 如需转载自行联系原作者
相关文章
【动态规划刷题 15】最长定差子序列&& 最长的斐波那契子序列的长度
【动态规划刷题 15】最长定差子序列&& 最长的斐波那契子序列的长度
|
3月前
acwing 895 最长上升子序列1
acwing 895 最长上升子序列1
42 3
|
3月前
acwing 896 最长上升子序列II
acwing 896 最长上升子序列II
35 2
|
3月前
acwing 897 最长公共子序列
acwing 897 最长公共子序列
27 0
acwing 897 最长公共子序列
|
算法 JavaScript Go
【动态规划】最长递增子序列
【动态规划】最长递增子序列
|
算法
【学会动态规划】 最长递增子序列(26)
【学会动态规划】 最长递增子序列(26)
51 0
|
算法 Java C++
动态规划专题 最长上升序列模型 acwing 1016.最大上升子序列和
动态规划专题 最长上升序列模型 acwing 1016.最大上升子序列和
56 0
动态规划专题 最长上升序列模型 acwing 1016.最大上升子序列和
Acwing 3692. 最长连续公共子序列
Acwing 3692. 最长连续公共子序列
68 0
|
算法 Java C++
最长上升序列模型 acwing 1016.最大上升子序列和
最长上升序列模型 acwing 1016.最大上升子序列和
55 0
|
人工智能 测试技术
poj 3061 快慢指针寻找最短区间
翻译过来简而言之就是 第1行 输入测试的案例个数 第 i 行 输入N和S (N代表数组长度,S代表目标和) 寻找最短区间满足区间之和大于或者等于S 第 i+1行 输入数组元素