最长上升子序列 POJ2533

简介:
Longest Ordered Subsequence
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 18853   Accepted: 8147

Description

A numeric sequence of  ai is ordered if  a1 <  a2 < ... <  aN. Let the subsequence of the given numeric sequence ( a1a2, ...,  aN) be any sequence ( ai1ai2, ...,  aiK), where 1 <=  i1 <  i2 < ... <  iK <=  N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

Source

Northeastern Europe 2002, Far-Eastern Subregion
 
题目的大意是:给出一序列,求出该序列的最长上升子序列的最大长度。
思路:用数组a[]存储序列,b[i]表示以a[i]为结尾的序列的最大长度。
因此要求出b[i]的最大值,即求出max{b[0],b[1]....b[i-1]}的最大值,那么b[i]的最大值为max{b[0],b[1]....b[i-1]}+1;
即可写出状态方程:b[i]=max{b[0],b[1].....b[j]}+1;(0<=j<i&&a[j]<a[i]),然后求出数组b[]中的最大值即为所求。
#include<iostream>
using  namespace  std;
 
int  main( void )
{
     int  i,j,n;
     int  a[1001];
     int  b[1001];
     int  max;
     scanf ( "%d" ,&n);
     for (i=0;i<n;i++)
     {
         scanf ( "%d" ,&a[i]);
         b[i]=1;
     }
     for (i=0;i<n;i++)
     {
         max=0;
         for (j=0;j<i;j++)
         {
             if (a[i]>a[j]&&b[j]>max)
             {
                 max=b[j];
             }
         }
         b[i]=max+1;
     }
     max=0;
     for (i=0;i<n;i++)
     {
         if (max<b[i])
             max=b[i];
     }
     printf ( "%d\n" ,max);
     return  0;
}
 
 
本文转载自海 子博客园博客,原文链接:http://www.cnblogs.com/dolphin0520/archive/2011/07/09/2102044.html 如需转载自行联系原作者
相关文章
|
8月前
【动态规划刷题 15】最长定差子序列&& 最长的斐波那契子序列的长度
【动态规划刷题 15】最长定差子序列&& 最长的斐波那契子序列的长度
|
8月前
|
算法 JavaScript Go
【动态规划】最长递增子序列
【动态规划】最长递增子序列
|
4月前
leetcode-300:最长递增子序列
leetcode-300:最长递增子序列
23 0
|
5月前
|
算法 程序员 C#
C++二分查找算法的应用:最长递增子序列
C++二分查找算法的应用:最长递增子序列
|
7月前
|
算法
【学会动态规划】 最长递增子序列(26)
【学会动态规划】 最长递增子序列(26)
17 0
|
11月前
|
算法
Leecode 300. 最长上升子序列
Leecode 300. 最长上升子序列
40 0
leetcode 300 最长递增子序列
leetcode 300 最长递增子序列
62 0
leetcode 300 最长递增子序列
|
算法 Python
LeetCode 300. 最长递增子序列
最长递增子序列 给你一个整数数组 nums ,找到其中最长严格递增子序列的长度。
94 0
|
人工智能 算法
Acwing 896. 最长上升子序列 II
Acwing 896. 最长上升子序列 II
73 0
力扣1143. 最长公共子序列 动态规划之最长公共子序列
力扣1143. 最长公共子序列 动态规划之最长公共子序列
149 0
力扣1143. 最长公共子序列 动态规划之最长公共子序列