HDU 5074 Hatsune Miku(DP)

简介:
Problem Description
Hatsune Miku is a popular virtual singer. It is very popular in both Japan and China. Basically it is a computer software that allows you to compose a song on your own using the vocal package.

Today you want to compose a song, which is just a sequence of notes. There are only m different notes provided in the package. And you want to make a song with n notes.


Also, you know that there is a system to evaluate the beautifulness of a song. For each two consecutive notes a and b, if b comes after a, then the beautifulness for these two notes is evaluated as score(a, b).

So the total beautifulness for a song consisting of notes a 1, a 2, . . . , a n, is simply the sum of score(a i, a i+1) for 1 ≤ i ≤ n - 1.

Now, you find that at some positions, the notes have to be some specific ones, but at other positions you can decide what notes to use. You want to maximize your song’s beautifulness. What is the maximum beautifulness you can achieve?
 

Input
The first line contains an integer T (T ≤ 10), denoting the number of the test cases.

For each test case, the first line contains two integers n(1 ≤ n ≤ 100) and m(1 ≤ m ≤ 50) as mentioned above. Then m lines follow, each of them consisting of m space-separated integers, the j-th integer in the i-th line for score(i, j)( 0 ≤ score(i, j) ≤ 100). The next line contains n integers, a 1, a 2, . . . , a n (-1 ≤ a i ≤ m, a i ≠ 0), where positive integers stand for the notes you cannot change, while negative integers are what you can replace with arbitrary notes. The notes are named from 1 to m.
 

Output
For each test case, output the answer in one line.
 

Sample Input
 
 
2 5 3 83 86 77 15 93 35 86 92 49 3 3 3 1 2 10 5 36 11 68 67 29 82 30 62 23 67 35 29 2 22 58 69 67 93 56 11 42 29 73 21 19 -1 -1 5 -1 4 -1 -1 -1 4 -1
 

Sample Output
 
 
270 625
题意:略。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<limits.h>
typedef long long LL;
using namespace std;
#define REPF( i , a , b ) for ( int i = a ; i <= b ; ++ i )
#define REP( i , n ) for ( int i = 0 ; i < n ; ++ i )
#define CLEAR( a , x ) memset ( a , x , sizeof a )
int dp[110][110];
int t,n,m;
int mp[55][55];
int num[110];
void solve()
{
   memset(dp,-1,sizeof(dp));
   if(num[1]!=-1)
       dp[1][num[1]]=0;
   else
   {
       REPF(i,1,m)
         dp[1][i]=0;
   }
    REPF(i,2,n)
    {
        REPF(j,1,m)
        {
            if(dp[i-1][j]!=-1)
            {
               if(num[i]!=-1)
                     dp[i][num[i]]=max(dp[i][num[i]],dp[i-1][j]+mp[j][num[i]]);
               else
               {
                   REPF(k,1,m)
                     dp[i][k]=max(dp[i][k],dp[i-1][j]+mp[j][k]);
               }
            }
        }
    }
    int ans=0;
    for(int i=1;i<=m;i++)
        ans=max(ans,dp[n][i]);
    printf("%d\n",ans);
}
int main()
{
    scanf("%d",&t);
    while(t--)
    {
       scanf("%d%d",&n,&m);
       for(int i=1;i<=m;i++)
       {
         for(int j=1;j<=m;j++)
            scanf("%d",&mp[i][j]);
       }
       for(int i=1;i<=n;i++)
           scanf("%d",&num[i]);
       solve();
    }
    return 0;
}





本文转自mfrbuaa博客园博客,原文链接:http://www.cnblogs.com/mfrbuaa/p/5347562.html,如需转载请自行联系原作者
相关文章
|
1月前
[leetcode ~dp ]279. 完全平方数
[leetcode ~dp ]279. 完全平方数
|
存储 算法
dp 就 dp ,数位dp是什么意思 ?
dp 就 dp ,数位dp是什么意思 ?
248 0
codeforces118——D. Caesar‘s Legions(DP)
codeforces118——D. Caesar‘s Legions(DP)
69 0
codeforces118——D. Caesar‘s Legions(DP)
|
人工智能