HDOJ 1004题 Let the Balloon Rise strcmp()函数

简介: Problem Description Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem.
Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input
 
 
5 green red blue red red 3 pink orange pink 0
Sample Output
 
 
red pink
代码:
#include <iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
using namespace std;

int main()
{
    int n,i,j,s=1,b[1010],f[1010];
    char a[1010][20];
    while(~scanf("%d",&n)&&n)
    {
        memset(b,0,sizeof(b));
        for(i=0; i<n; i++)
        {
            scanf("%s",a[i]);
        }
        for(i=0; i<n; i++)
        {
            f[i]=1;
            for(j=i+1; j<n; j++)
            {
                if(b[j]==0)
                {

                    if(strcmp(a[i],a[j])==0)//这里我不知道为什么用a[i]==a[j]就不可以,求大神评论解释一下,谢谢了
                    {
                        b[j]=1;
                        f[i]=f[i]+1;
                    }
                }
            }
        }
        int s=0;
        for(i=0; i<n; i++)
        {
            if(f[s]<=f[i])
            {
                s=i;
            }
        }
        printf("%s\n",a[s]);
    }
    return 0;
}


 
 
目录
相关文章
|
6月前
|
Java
HDU-1004—Let the Balloon Rise
HDU-1004—Let the Balloon Rise
30 0
LeetCode 264. Ugly Number II
编写一个程序,找出第 n 个丑数。 丑数就是只包含质因数 2, 3, 5 的正整数。
73 0
LeetCode 264. Ugly Number II
LeetCode 263. Ugly Number
编写一个程序判断给定的数是否为丑数。 丑数就是只包含质因数 2, 3, 5 的正整数。
93 0
LeetCode 263. Ugly Number
HDOJ 1004题 Let the Balloon Rise strcmp()函数
HDOJ 1004题 Let the Balloon Rise strcmp()函数
103 0
HDOJ 1004 Let the Balloon Rise
HDOJ 1004 Let the Balloon Rise
139 0
HDOJ 1008 Elevator
HDOJ 1008 Elevator
94 0
|
Java
HDOJ 1097 A hard puzzle(循环问题)
HDOJ 1097 A hard puzzle(循环问题)
120 0