HDOJ 1004 Let the Balloon Rise

简介: HDOJ 1004 Let the Balloon Rise

Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.


This year, they decide to leave this lovely job to you.


Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.


A test case with N = 0 terminates the input and this test case is not to be processed.


Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.


Sample Input

5

green

red

blue

red

red

3

pink

orange

pink

0


Sample Output

red

pink


题意:找输入的n组字符串出现次数最多的那个字符串,然后输出

import java.util.Scanner;
public class Main {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            int n = sc.nextInt();
            if(n==0){
                return ;
            }
            //System.out.println("n="+n);
            int anumber[][] = new int[n][2];
            //初始化
            for(int i=0;i<n;i++){
                anumber[i][0] =0;
                anumber[i][1] =0;
            }
            String a[] = new String[n];
            for(int i=0;i<n;i++){
                a[i] = sc.next();
                //System.out.println("i="+i+","+a[i]);
            }
            for(int i=0;i<a.length-1;i++){
                for(int j=i+1;j<a.length;j++){
                    if(anumber[j][1]==0&&a[i].equals(a[j])){
                        anumber[j][1]=1;
                        anumber[i][0]++;
                    }
                }
            }
            int max = anumber[0][0];
            int k=0;
            for(int i=0;i<a.length;i++){
                if(anumber[i][0]>max){
                    max = anumber[i][0];
                    k=i;
                }
            }
            System.out.println(a[k]);
        }
    }
}
目录
相关文章
HDOJ 1004题 Let the Balloon Rise strcmp()函数
HDOJ 1004题 Let the Balloon Rise strcmp()函数
108 0
HDOJ 1008 Elevator
HDOJ 1008 Elevator
98 0
HDOJ(HDU) 2103 Family planning(需要注意范围)
HDOJ(HDU) 2103 Family planning(需要注意范围)
116 0
HDOJ(HDU) 1678 Shopaholic
HDOJ(HDU) 1678 Shopaholic
112 0
HDOJ(HDU) 2317 Nasty Hacks(比较、)
HDOJ(HDU) 2317 Nasty Hacks(比较、)
109 0
HDOJ(HDU) 1673 Optimal Parking
HDOJ(HDU) 1673 Optimal Parking
134 0
|
Go
HDOJ/HDU 1087 Super Jumping! Jumping! Jumping!(经典DP~)
HDOJ/HDU 1087 Super Jumping! Jumping! Jumping!(经典DP~)
91 0