POJ 1306 Combinations

简介: DescriptionComputing the exact number of ways that N things can be taken M at a time can be a great challenge when N and/or M become very large.

Description

Computing the exact number of ways that N things can be taken M at a time can be a great challenge when N and/or M become very large. Challenges are the stuff of contests. Therefore, you are to make just such a computation given the following:
GIVEN: 5 <= N <= 100; 5 <= M <= 100; M <= N
Compute the EXACT value of: C = N! / (N-M)!M!
You may assume that the final value of C will fit in a 32-bit Pascal LongInt or a C long. For the record, the exact value of 100! is:
93,326,215,443,944,152,681,699,238,856,266,700,490,715,968,264,381,621, 468,592,963,895,217,599,993,229,915,608,941,463,976,156,518,286,253, 697,920,827,223,758,251,185,210,916,864,000,000,000,000,000,000,000,000
Input

The input to this program will be one or more lines each containing zero or more leading spaces, a value for N, one or more spaces, and a value for M. The last line of the input file will contain a dummy N, M pair with both values equal to zero. Your program should terminate when this line is read.
Output

The output from this program should be in the form:
N things taken M at a time is C exactly.
Sample Input

100 6
20 5
18 6
0 0
Sample Output

100 things taken 6 at a time is 1192052400 exactly.
20 things taken 5 at a time is 15504 exactly.
18 things taken 6 at a time is 18564 exactly.

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
using namespace std;

int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m)&&(n||m)){
        int s[200];
        bool vis[200];
        memset(vis,0,sizeof(vis));
        int x,y;
        if(n-m<m){
            x=n-m;/**x为小的那个数**/
            y=m;
        }
        else{
            x=m;
            y=n-m;
        }
        int sum=1;
        for(int i=y+1;i<=n;i++){
            sum*=i;
            for(int j=1;j<=x;j++){
                if(sum%j==0&&vis[j]==0){
                    vis[j]=1;
                    sum=sum/j;
                }
            }
        }
        printf("%d things taken %d at a time is %d exactly.\n",n,m,sum);
    }
    return 0;
}
目录
相关文章
POJ 1306 Combinations
POJ 1306 Combinations
125 0
poj 3264 Balanced Lineup
点击打开链接poj3264 思路:线段树 分析: 1 要求区间的最大值和最小值的差值 2 建立一棵线段树,节点保存这个区间的最大值和最小值,然后写两个查询函数,一个返回最大值一个返回最小值,然后相减即可。
966 0
|
C语言 知识图谱
|
算法 Go
HDU-1548,A strange lift(Dijkstra)
HDU-1548,A strange lift(Dijkstra)
hdu 3015 Disharmony Trees
点击打开hdu 3015 思路: 树状数组 分析: 1 题目给定n棵树的横坐标和高度,然后给定横坐标排序后的rank_f已及树的高度排序后的rank_s,规定两颗树的FAR为abs(rank_f[i] , rank_f[j]) , SHORT为min(rank_s[i] .
927 0
|
机器学习/深度学习
hdu 2199 Can you solve this equation?
点击打开hdu2199 思路: 二分 分析: 1 求题目给定的等式是否有[0,100]之间的解 2 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6是一个单调递增的函数,那么求解的话我们利用二分的思想 3 注意判断没有解的...
900 0

热门文章

最新文章