POJ 1306 Combinations

简介: POJ 1306 Combinations

Description


Computing the exact number of ways that N things can be taken M at a time can be a great challenge when N and/or M become very large. Challenges are the stuff of contests. Therefore, you are to make just such a computation given the following:

GIVEN: 5 <= N <= 100; 5 <= M <= 100; M <= N

Compute the EXACT value of: C = N! / (N-M)!M!

You may assume that the final value of C will fit in a 32-bit Pascal LongInt or a C long. For the record, the exact value of 100! is:

93,326,215,443,944,152,681,699,238,856,266,700,490,715,968,264,381,621, 468,592,963,895,217,599,993,229,915,608,941,463,976,156,518,286,253, 697,920,827,223,758,251,185,210,916,864,000,000,000,000,000,000,000,000

Input


The input to this program will be one or more lines each containing zero or more leading spaces, a value for N, one or more spaces, and a value for M. The last line of the input file will contain a dummy N, M pair with both values equal to zero. Your program should terminate when this line is read.

Output


The output from this program should be in the form:

N things taken M at a time is C exactly.

Sample Input


100 6

20 5

18 6

0 0

Sample Output


100 things taken 6 at a time is 1192052400 exactly.

20 things taken 5 at a time is 15504 exactly.

18 things taken 6 at a time is 18564 exactly.

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
using namespace std;
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m)&&(n||m)){
        int s[200];
        bool vis[200];
        memset(vis,0,sizeof(vis));
        int x,y;
        if(n-m<m){
            x=n-m;/**x为小的那个数**/
            y=m;
        }
        else{
            x=m;
            y=n-m;
        }
        int sum=1;
        for(int i=y+1;i<=n;i++){
            sum*=i;
            for(int j=1;j<=x;j++){
                if(sum%j==0&&vis[j]==0){
                    vis[j]=1;
                    sum=sum/j;
                }
            }
        }
        printf("%d things taken %d at a time is %d exactly.\n",n,m,sum);
    }
    return 0;
}
目录
相关文章
|
6月前
|
开发框架 .NET
poj 3468 A Simple Problem with Integers线段树区间修改
题目意思很简单,有N个数,Q个操作, Q l r 表示查询从l到r 的和,C l r v 表示将从l到r 的值加上v,明显的线段树,不知道线段树的人肯定暴力,肯定超时,哈哈!!
19 0
|
7月前
|
算法
POJ3061 Subsequence
POJ3061 Subsequence
|
8月前
UVa10484 - Divisibility of Factors(数论)
UVa10484 - Divisibility of Factors(数论)
41 1
|
C++
leetcode 37. Sudoku Solver 36. Valid Sudoku 数独问题
三星机试也考了类似的题目,只不过是要针对给出的数独修改其中三个错误数字,总过10个测试用例只过了3个与世界500强无缘了 36. Valid Sudoku Determine if a Sudoku is valid, according to: Sudoku Puzzles - The Rules.
1182 0
|
数据挖掘
poj-1207 THE 3n+1 problem
Description Problems in Computer Science are often classified as belonging to a certain class of problems (e.
773 0