POJ 1423 Big Number

简介: DescriptionIn many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc.

Description

In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
Input

Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 <= m <= 10^7 on each line.
Output

The output contains the number of digits in the factorial of the integers appearing in the input.
Sample Input

2
10
20
Sample Output

7
19

(部分转载)
补充知识 :若n=a+b^10,(a<1,b∈N),则n的位数为b。
所以要求一个数字num有多少位,可以用(int)log10(num)+1,这样就求出num有多少位.
如果sum=n*(n-1)(n-2)……*1,那么log10(sum)=log10(n)+
log10(n-1)+…..+log10(2)+log10(1)。即sum的位数是
( int )( log10(n)+log10(n-1)+…..+log10(2)+log10(1) )+1。
(从小到大算)

下面这一种方法是程序外打表法,需要消耗时间。
还有一种是程序外打表,就是直接给复制,再导入,则肯定是0ms。

#include <stdio.h>
#include <math.h>

int a[10000010];
int main()
{
    double d;
    int i;
    int t;
    int n;
    for(i=1,d=0;i<10000005;i++){
        d+=log10(i);
        a[i]=(int)d+1;
    }

    scanf("%d",&t);
    while(t-->0){
        scanf("%d",&n);
        printf("%d\n",a[n]);

    }
    return 0;
}

还有一种方法:
利用Stirling公式. n!≈sqrt(2*pi*n)*[(n/e)^n]
n越大,答案越准确。
在n=1的情况下,也最大不过相差0.2.
这里只要计算位数,所以是可以用的。
此处的:
e ≈ 2.7182818284590452354, pi ≈ 3.141592653589793239;

#include<iostream>
#include<cmath>
using namespace std;
const double e = 2.7182818284590452354, pi = 3.141592653589793239;
double strling_digits_num(int n)
{
        return log10(2*pi*n)/2.0+n*(log10(n/e));
}

int main()
{
        int t;
        cin>>t;
        while(t--)
        {
                int n;
                cin>>n;
                double m=0;
                m=strling_digits_num(n);
                int answer=(int)m;
                answer++;
                cout<<answer<<endl;
        }
        return 0;
}
目录
相关文章
|
Java
HDOJ 1018 Big Number(大数位数公式)
HDOJ 1018 Big Number(大数位数公式)
91 0
|
前端开发
HDOJ 1212 Big Number
HDOJ 1212 Big Number
92 0
|
机器学习/深度学习
POJ 1423 Big Number
POJ 1423 Big Number
86 0
|
8月前
|
算法
Leetcode 313. Super Ugly Number
题目翻译成中文是『超级丑数』,啥叫丑数?丑数就是素因子只有2,3,5的数,7 14 21不是丑数,因为他们都有7这个素数。 这里的超级丑数只是对丑数的一个扩展,超级丑数的素因子不再仅限于2 3 5,而是由题目给定一个素数数组。与朴素丑数算法相比,只是将素因子变了而已,解法还是和朴素丑数一致的。
73 1
|
23天前
|
存储 SQL 算法
LeetCode 题目 65:有效数字(Valid Number)【python】
LeetCode 题目 65:有效数字(Valid Number)【python】
|
2月前
|
存储 算法
【LeetCode力扣】单调栈解决Next Greater Number(下一个更大值)问题
【LeetCode力扣】单调栈解决Next Greater Number(下一个更大值)问题
17 0