HDOJ 1014 Uniform Generator(公约数问题)

简介: Problem Description Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the ...

Problem Description
Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

seed(x+1) = [seed(x) + STEP] % MOD

where ‘%’ is the modulus operator.

Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1.

For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations.

If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1.

Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers.

Input
Each line of input will contain a pair of integers for STEP and MOD in that order (1 <= STEP, MOD <= 100000).

Output
For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either “Good Choice” or “Bad Choice” left-justified starting in column 25. The “Good Choice” message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message “Bad Choice”. After each output test set, your program should print exactly one blank line.

Sample Input
3 5
15 20
63923 99999

Sample Output

     3         5    Good Choice

    15        20    Bad Choice

 63923     99999    Good Choice

题目这么长,其实意思就是判断输入的2个数的最大公约数是不是1.
如果是输出:Good Choice
否则输出:Bad Choice
还有注意的是:输出后面跟一个空行。其实我也不知道是输出之间还是输出之后(英语水平有限)。我是输出之后跟一个空行,AC了。

import java.util.Scanner;

public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            int a = sc.nextInt();
            int b = sc.nextInt();
            if(gcd(a,b)==1){
                System.out.printf("%10d%10d",a,b);
                System.out.println("    Good Choice");
            }else{
                System.out.printf("%10d%10d",a,b);
                System.out.println("    Bad Choice");
            }
            System.out.println();
        }
    }

    //递归求最大公约数
    private static int gcd(int a, int b) {
        return b==0?a:gcd(b,a%b);
    }

}
目录
相关文章
|
12月前
|
算法
hdoj 4712 Hamming Distance(靠人品过的)
在信息论中,两个等长字符串之间的汉明距离是两个字符串对应位置的字符不同的个数。换句话说,它就是将 一个字符串变换成另外一个字符串所需要替换的字符个数。
31 0
LeetCode 221. Maximal Square
在一个由 0 和 1 组成的二维矩阵内,找到只包含 1 的最大正方形,并返回其面积。
57 0
LeetCode 221. Maximal Square
Leetcode-Easy 461.Hamming Distance
Leetcode-Easy 461.Hamming Distance
104 0
Leetcode-Easy 461.Hamming Distance
HDOJ 1391 Number Steps(打表DP)
HDOJ 1391 Number Steps(打表DP)
121 0
HDOJ 1391 Number Steps(打表DP)
HDOJ 1014 Uniform Generator(公约数问题)
HDOJ 1014 Uniform Generator(公约数问题)
87 0
|
Go
HDOJ(HDU) 1977 Consecutive sum II(推导、、)
HDOJ(HDU) 1977 Consecutive sum II(推导、、)
104 0
HDOJ(HDU) 2136 Largest prime factor(素数筛选)
HDOJ(HDU) 2136 Largest prime factor(素数筛选)
106 0
HDOJ 2003 求绝对值
HDOJ 2003 求绝对值
100 0
|
Java
HDOJ1518Square 深搜
HDOJ1518Square 深搜
102 0