HDU4730-We Love MOE Girls

简介:

We Love MOE Girls
Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1047    Accepted Submission(s): 636


Problem Description
Chikami Nanako is a girl living in many different parallel worlds. In this problem we talk about one of them.
In this world, Nanako has a special habit. When talking with others, she always ends each sentence with "nanodesu".
There are two situations:
If a sentence ends with "desu", she changes "desu" into "nanodesu", e.g. for "iloveyoudesu", she will say "iloveyounanodesu". Otherwise, she just add "nanodesu" to the end of the original sentence.
Given an original sentence, what will it sound like aften spoken by Nanako?
 

Input
The first line has a number T (T <= 1000) , indicating the number of test cases.
For each test case, the only line contains a string s, which is the original sentence.
The length of sentence s will not exceed 100, and the sentence contains lowercase letters from a to z only.
 

Output
For every case, you should output "Case #t: " at first, without quotes. The t is the case number starting from 1. Then output which Nanako will say.
 

Sample Input
2
ohayougozaimasu
daijyoubudesu
 

Sample Output
Case #1: ohayougozaimasunanodesu
Case #2: daijyoubunanodesu
 

Source
2013 ACM/ICPC Asia Regional Chengdu Online
 

//水题,字符串处理
AC代码:

#include<stdio.h>
#include<string.h>
char word[200];
int main()
{
 int i,j,n,m,k=1;
 scanf("%d",&n);
 while(n--)
 {
  memset(word,0,sizeof(word));
  scanf("%s",word);
  m=strlen(word);
  if(word[m-1]=='u'&&word[m-2]=='s'&&word[m-3]=='e'&&word[m-4]=='d')
  {
   word[m-4]='n';
   word[m-3]='a';
   word[m-2]='n';
   word[m-1]='o';
   word[m]='d';
   word[m+1]='e';
   word[m+2]='s';
   word[m+3]='u';
   m=m+4;
   printf("Case #%d: ",k++);
   for(i=0;i<m;i++)
    printf("%c",word[i]);
   puts("");
  }
  else
  {
            printf("Case #%d: %s",k++,word);
   printf("nanodesu\n");
  }
 }
 return 0;
}
相关文章
|
6月前
|
Java
hdu-4883- (Best Coder) TIANKENG’s restaurant
hdu-4883- (Best Coder) TIANKENG’s restaurant
26 0
|
算法 JavaScript 前端开发
|
测试技术
HDU-1847,Good Luck in CET-4 Everybody!(巴什博弈)
HDU-1847,Good Luck in CET-4 Everybody!(巴什博弈)
HDOJ/HDU 1075 What Are You Talking About(字符串查找翻译~Map)
HDOJ/HDU 1075 What Are You Talking About(字符串查找翻译~Map)
133 0
|
存储
HDOJ/HDU 2140 Michael Scofield's letter(字符转换~)
HDOJ/HDU 2140 Michael Scofield's letter(字符转换~)
81 0
转:肉饼的自白:You&#39;ve got to find what you love
《You've got to find what you love》是乔布斯2005年在斯坦福大学毕业典礼上的演讲,当我第一次看到这个演讲视频的时候,被彻底震住了。回顾自己跌跌撞撞的人生道路,就是一个不断寻找然后坚持自己钟爱事业的过程。
1371 0
|
Java
2017 Multi-University Training Contest - Team 9 1002&&HDU 6162 Ch’s gift【树链部分+线段树】
Ch’s gift Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 1354    Accepted Submission(s): 496 Problem Description Mr.
1297 0
|
存储
HDOJ/HDU 2140 Michael Scofield&#39;s letter(字符转换~)
Problem Description I believe many people are the fans of prison break. How clever Michael is!! In order that the message won’t be found b...
937 0