hdu 1588 Gauss Fibonacci

简介:

点击此处即可传送hdu 1588

                           **Gauss Fibonacci**
Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2849    Accepted Submission(s): 1179



Problem Description

Without expecting, Angel replied quickly.She says: "I'v heard that you'r a very clever boy. So if you wanna me be your GF, you should solve the problem called GF~. "
How good an opportunity that Gardon can not give up! The "Problem GF" told by Angel is actually "Gauss Fibonacci".
As we know ,Gauss is the famous mathematician who worked out the sum from 1 to 100 very quickly, and Fibonacci is the crazy man who invented some numbers.

Arithmetic progression:
g(i)=k*i+b;
We assume k and b are both non-nagetive integers.

Fibonacci Numbers:
f(0)=0
f(1)=1
f(n)=f(n-1)+f(n-2) (n>=2)

The Gauss Fibonacci problem is described as follows:
Given k,b,n ,calculate the sum of every f(g(i)) for 0<=i<n
The answer may be very large, so you should divide this answer by M and just output the remainder instead.




Input

The input contains serveral lines. For each line there are four non-nagetive integers: k,b,n,M
Each of them will not exceed 1,000,000,000.





Output

For each line input, out the value described above.




Sample Input

2 1 4 100
2 0 4 100





Sample Output

21
12

题目大意:给你四个数,k, b, n, m,然后,分别表示题干中的意思,就是求F(g(i)) i从0到n-1的和

解题思路:就是推一下,具体看代码吧,
上代码:

/*
2015 - 8 - 15 下午
Author: ITAK

今天感觉还可以,买了一个机械键盘,又要少吃几顿饭了。。。

今日的我要超越昨日的我,明日的我要胜过今日的我,
以创作出更好的代码为目标,不断地超越自己。
*/

#include <iostream>
#include <cstdio>
using namespace std;
typedef long long LL;
const int max1 = 4;
const int max2 = 2;

int mod;
typedef struct
{
    LL m[max1][max1];
}Matrix1;

typedef struct
{
    LL m[max2][max2];
} Matrix2;
Matrix1 P1 = {0,1,1,0,
              0,0,0,1,
              0,0,1,0,
              0,0,0,1
             };
Matrix1 I1 = {1,0,0,0,
              0,1,0,0,
              0,0,1,0,
              0,0,0,1
             };

Matrix2 P2 = {0,1,
              1,1
             };
Matrix2 I2 = {1,0,
              0,1
             };
Matrix1 matrix1mul(Matrix1 a, Matrix1 b)
{
    Matrix1 c;
    for(int i=0; i<max1; i++)
    {
        for(int j=0; j<max1; j++)
        {
            c.m[i][j] = 0;
            for(int k=0; k<max1; k++)
            {
                c.m[i][j] += (a.m[i][k]%mod)*(b.m[k][j]%mod)%mod;
            }
            c.m[i][j] %= mod;
        }
    }
    return c;
}

Matrix1 quick_mod1(LL n)
{
    Matrix1 ans = I1, m = P1;
    while(n)
    {
        if(n & 1)
            ans = matrix1mul(ans, m);
        n >>= 1;
        m = matrix1mul(m,m);
    }
    return ans;
}

Matrix2 matrix2mul(Matrix2 a, Matrix2 b)
{
    Matrix2 c;
    for(int i=0; i<max2; i++)
    {
        for(int j=0; j<max2; j++)
        {
            c.m[i][j] = 0;
            for(int k=0; k<max2; k++)
            {
                c.m[i][j] += (a.m[i][k]%mod)*(b.m[k][j]%mod)%mod;
            }
            c.m[i][j] %= mod;
        }
    }
    return c;
}

Matrix2 quick_mod2(LL n)
{
    Matrix2 ans = I2, m = P2;
    while(n)
    {
        if(n & 1)
            ans = matrix2mul(ans, m);
        n >>= 1;
        m = matrix2mul(m,m);
    }
    return ans;
}
int main()
{
    LL n, b, k;
    Matrix2 tmp1, tmp2;
    Matrix1 tmp;
    while(cin>>k>>b>>n>>mod)
    {
        tmp1 = quick_mod2(k);
        tmp2 = quick_mod2(b);
     """P1.m[0][0] = tmp1.m[0][0];
        P1.m[0][1] = tmp1.m[0][1];
        P1.m[1][0] = tmp1.m[1][0];
        P1.m[1][1] = tmp1.m[1][1];"""
        tmp = quick_mod1(n);
        LL ans=(tmp2.m[0][0]%mod*tmp.m[0][3]%mod)%mod+
               (tmp2. m[0][1]%mod*tmp.m[1][3]%mod)%mod;
        ans = (ans+mod)%mod;
        cout<<ans<<endl;
    }
    return 0;
}
目录
相关文章
|
机器学习/深度学习
HDU 1568 Fibonacci
求Fibonacci数列的高四位先看对数的性质,loga(b^c)=c*loga(b),loga(b*c)=loga(b)+loga(c);假设给出一个数10234432,那么log10(10234432)=log10(1.
783 0
|
Java
HDU 1021 Fibonacci Again
Fibonacci Again Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 58267    Accepted Submission(...
913 0
|
机器学习/深度学习
hdu 3117 Fibonacci Numbers
点击打开hdu 3117 思路: 矩阵快速幂 分析: 1 题目要求的是求F(n)中如果位数的个数大于8那么要输出前4四位和后四位,没有到8位的时候直接输出 2 根据题目的样例我们可以知道当n = 40的时候就超过8位了,所以我们可以知道n...
847 0
|
机器学习/深度学习 Java

热门文章

最新文章