hdu 1051 Wooden Sticks(贪心)

简介:

Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15215    Accepted Submission(s): 6242


Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 

Output
The output should contain the minimum setup time in minutes, one per line.
 

Sample Input
 
 
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
 

Sample Output
 
 
2 1 3
 
题目大意:
有T组数据,首先给定一个数m,接下来有2*m个数,每两个数表示木头的长和重量,现在有这样一种机器,
每次通过一个木头,如果后面的每个值都 > 前面的数,则不需要调整时间,否则时间 +1
解题思路:

这是一个比较简单的贪心问题,首先我们进行对木头的 长度 从大到小排一下序(当然从小到大也行),
然后观察重量的分类,也就是说,能够找到多少个从大到小的重量,

上代码:
/**
2015 - 09 - 30

Author: ITAK

Motto:

今日的我要超越昨日的我,明日的我要胜过今日的我,
以创作出更好的代码为目标,不断地超越自己。
**/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <algorithm>
#include <set>
using namespace std;

#define MM(a) memset(a,0,sizeof(a))

typedef long long LL;
typedef unsigned long long ULL;
const int maxn = 5000+5;
const int mod = 1000000007;
const double eps = 1e-7;
const double pi = 3.1415926;
const int e =  2.718281828;

struct node
{
    int l, w;
}arr[maxn];

int cmp(node a, node b)
{
    if(a.l != b.l)///按照长度从大到小排序
        return a.l > b.l;
    else///按重量排序
        return a.w > b.w;
}
int flag[maxn];
int main()
{
    int m, T;
    cin>>T;
    while(T--)
    {
        int ret = 0;
        cin>>m;
        for(int i=0; i<m; i++)
            cin>>arr[i].l>>arr[i].w;
        MM(flag);
        sort(arr, arr+m, cmp);
        for(int i=0; i<m; i++)
        {
            if(flag[i])
                continue;
            int Min = arr[i].w;///找到所有的从大到小排序的数。。。
            for(int j=i+1; j<m; j++)
            {
                if(Min>=arr[j].w && !flag[j])
                {
                    Min = arr[j].w;
                    flag[j] = 1;
                }
            }
            ret++;
        }
        cout<<ret<<endl;
    }
    return 0;
}


目录
相关文章
|
3月前
|
C++
题解 Sticks 小木棍
这篇文章提供了一个C++程序的题解,使用深度优先搜索(DFS)和剪枝技术来解决如何将不同长度的小木棍拼接成若干根长度相等的木棍的问题,以求得拼接长度的最小值。
|
12月前
hdu 1052 Tian Ji -- The Horse Racing【田忌赛马】(贪心)
hdu 1052 Tian Ji -- The Horse Racing【田忌赛马】(贪心)
49 0
|
算法
POJ3061 Subsequence
POJ3061 Subsequence
HDU 4632 Palindrome subsequence(动态规划)
HDU 4632 Palindrome subsequence(动态规划)
74 0
HDU 4632 Palindrome subsequence(动态规划)
HDU-1061,Rightmost Digit(快速幂)
HDU-1061,Rightmost Digit(快速幂)
|
数据挖掘
HDU-1032,The 3n + 1 problem(水题)
HDU-1032,The 3n + 1 problem(水题)
HDU-1009,FatMouse' Trade(贪心水题)
HDU-1009,FatMouse' Trade(贪心水题)
|
C语言
HDOJ/HDU Tempter of the Bone(深搜+奇偶性剪枝)
HDOJ/HDU Tempter of the Bone(深搜+奇偶性剪枝)
97 0
|
算法 C++
HDOJ(HDU) 2109 Fighting for HDU(简单排序比较)
HDOJ(HDU) 2109 Fighting for HDU(简单排序比较)
109 0