1002 A+B for Polynomials (25 分)

简介: 1002 A+B for Polynomials (25 分)

1002 A+B for Polynomials (25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1 aN1 N2 aN2 ... NK aNK

where K is the number of nonzero terms(非零项) in the polynomial, Ni and aNi (i=1,2,⋯,K) are the exponents(指数) and coefficients(系数), respectively. It is given that 1≤K≤10,0≤NK<⋯<N2<N1≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5


Sample Output:

3 2 1.5 1 2.9 0 3.2

 


题目要求计算两个多项式之和, 格式为:

多项式项数, 指数 系数 指数 系数

输出结果和输入格式相同,保留一位小数


#include<iostream>
using namespace std;
int main()
{
  float c[1001] = { 0 };
  int m, n, t;
  float num;
  cin >> m; //第一个多项式非零项数量
  for (int i = 0; i < m; i++)
  {
    cin>>t>>num;
    c[t] += num;
  }
  cin>>n; //第二个多项式非零项数量
  for (int i = 0; i < n; i++)
  {
    cin>>t>>num;
    c[t] += num;
  }
  int cnt = 0;
  for (int i = 0; i < 1001; i++)
  {
    if (c[i] != 0)cnt++;
  }
  cout<<cnt; //非零项数量
  for (int i = 1000; i >= 0; i--)
  {
    if (c[i] != 0.0)
      printf(" %d %.1f", i, c[i]);
  }
  return 0;
}
相关文章
|
14天前
|
数据安全/隐私保护
1048 数字加密 (20 分)
1048 数字加密 (20 分)
|
6月前
|
算法
水手分椰子
水手分椰子
70 3
L1-044 稳赢 (15 分)
L1-044 稳赢 (15 分)
120 0
L1-044 稳赢 (15 分)
L1-054 福到了 (15 分)
L1-054 福到了 (15 分)
63 0
L1-054 福到了 (15 分)
1002. A+B for Polynomials(25分)
1002. A+B for Polynomials(25分)
56 0
牛几 (10 分)
牛几 (10 分)
112 0
L3-011 直捣黄龙 (30 分)
L3-011 直捣黄龙 (30 分)
111 0
L1-014 简单题 (5 分)
L1-014 简单题 (5 分)
58 0
L1-018 大笨钟 (10 分)
L1-018 大笨钟 (10 分)
82 0