Strange fuction(HDU--2899)

简介: Strange fuction(HDU--2899)

#题目:

Now, here is a fuction:

F(x) = 6 * x ^ 7+8x^ 6+ 7x ^ 3+5x^2-yx (0 <= x <=100)

Can you find the minimum value when x is between 0 and 100.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)

Output

Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.

Sample Input

2
100
200

Sample Output

-74.4291
-178.8534

解题思路:这个题就是给一个函数式,然后由x在区间0-100之间取值求最小值。

利用函数求导为:42*x^6+48 *x ^5+21 *x^2+10 *x-y==0,利用二分求x的值,使倒数为0,则函数值最小。

程序代码:

#include<stdio.h>
#include<math.h>
double l=0.00000001;
int main()
{
  double x,m,n,k,y,sum;
  int T;
  scanf("%d",&T);
  while(T--)
  {
    scanf("%lf",&y);
    n=0.00;
    m=100.00;//x的区间是0-100
    while(m-n>l)//让n和m无限接近,使得导函数为0
    {
      k=(m+n)/2;
      if(42*pow(k,6)+48*pow(k,5)+21*pow(k,2)+10*k-y>0)
        m=k;
      else
        n=k;
    }
    sum=6*pow(k,7)+8*pow(k,6)+7*pow(k,3)+5*pow(k,2)-y*k;
    printf("%.4f\n",sum);
  }
  return 0;
}
相关文章
|
算法 Go
HDU-1548,A strange lift(Dijkstra)
HDU-1548,A strange lift(Dijkstra)
HDOJ(HDU) 2317 Nasty Hacks(比较、)
HDOJ(HDU) 2317 Nasty Hacks(比较、)
113 0
HDOJ(HDU) 1678 Shopaholic
HDOJ(HDU) 1678 Shopaholic
118 0
HDOJ/HDU 1241 Oil Deposits(经典DFS)
HDOJ/HDU 1241 Oil Deposits(经典DFS)
96 0
HDOJ(HDU) 1898 Sempr == The Best Problem Solver?(水题、、、)
HDOJ(HDU) 1898 Sempr == The Best Problem Solver?(水题、、、)
138 0
|
Java
2017 Multi-University Training Contest - Team 9 1002&&HDU 6162 Ch’s gift【树链部分+线段树】
Ch’s gift Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 1354    Accepted Submission(s): 496 Problem Description Mr.
1312 0