HDOJ(HDU) 2317 Nasty Hacks(比较、)

简介: HDOJ(HDU) 2317 Nasty Hacks(比较、)

Problem Description

You are the CEO of Nasty Hacks Inc., a company that creates small pieces of malicious software which teenagers may use

to fool their friends. The company has just finished their first product and it is time to sell it. You want to make as much money as possible and consider advertising in order to increase sales. You get an analyst to predict the expected revenue, both with and without advertising. You now want to make a decision as to whether you should advertise or not, given the expected revenues.


Input

The input consists of n cases, and the first line consists of one positive integer giving n. The next n lines each contain 3 integers, r, e and c. The first, r, is the expected revenue if you do not advertise, the second, e, is the expected revenue if you do advertise, and the third, c, is the cost of advertising. You can assume that the input will follow these restrictions: -106 ≤ r, e ≤ 106 and 0 ≤ c ≤ 106.


Output

Output one line for each test case: “advertise”, “do not advertise” or “does not matter”, presenting whether it is most profitable to advertise or not, or whether it does not make any difference.


Sample Input

3

0 100 70

100 130 30

-100 -70 40


Sample Output

advertise

does not matter

do not advertise


嗯。。水题。。


题意就是输入的:

第一个数a是:做研发能赚多少钱,负数代表亏多少钱。

第二个数b是:做广告能赚多少钱。

第三个数c是:做广告的成本。

也就是比较a和(b+c)谁大谁小,还是相等。

如果a大:输出:do not advertise

如果a小:输出:advertise

如果一样大:输出:does not matter

import java.util.Scanner;
public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int t =sc.nextInt();
        while(t-->0){
            int a =sc.nextInt();
            int b =sc.nextInt();
            int c =sc.nextInt();
            if(a==(b-c)){
                System.out.println("does not matter");
            }else if(a>(b-c)){
                System.out.println("do not advertise");
            }else{
                System.out.println("advertise");
            }
        }
    }
}
目录
相关文章
hdoj 1907
这是一道博弈的题,准确说是尼姆博弈,只要判断各项的异或值即可。
39 0
HDOJ 2041 超级楼梯
HDOJ 2041 超级楼梯
108 0
HDOJ 1214 圆桌会议
HDOJ 1214 圆桌会议
99 0
HDOJ 2013 蟠桃记
HDOJ 2013 蟠桃记
99 0
HDOJ 1412 {A} + {B}
Problem Description 给你两个集合,要求{A} + {B}. 注:同一个集合中不会有两个相同的元素. Input 每组输入数据分为三行,第一行有两个数字n,m(0 < n,m marr[mid]) { System.
781 0
|
机器学习/深度学习
HDOJ 2074 叠筐
Problem Description 需要的时候,就把一个个大小差一圈的筐叠上去,使得从上往下看时,边筐花色交错。这个工作现在要让计算机来完成,得看你的了。 Input 输入是一个个的三元组,分别是,外筐尺寸n(n为满足0< n< 80的奇整数),中心花色字符,外筐花色字符,后二者都为ASCII可见字符; Output 输出叠在一起的筐图案,中心花色与外筐花色字符从内层起交错相叠,多筐相叠时,最外筐的角总是被打磨掉。
852 0
|
Java 测试技术
HDOJ 1877
又一版 A+B Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 9541    Accepted Submission(s): 3551 ...
636 0