2019ICPCshenyang网络赛(C. Dawn-K's water)

简介: 2019ICPCshenyang网络赛(C. Dawn-K's water)

题目:

Dawn-K recently discovered a very magical phenomenon in the supermarket of Northeastern University: The large package is not necessarily more expensive than the small package.

On this day, Dawn-K came to the supermarket to buy mineral water, he found that there are nntypes of mineral water, and he already knew the price pp and the weight cc (kg) of each type of mineral water. Now Dawn-K wants to know the least money aa he needs to buy no less than mm kilograms of mineral water and the actual weight bb of mineral water he will get. Please help him to calculate them.

Input

The input consists of multiple test cases, each test case starts with a number nn (1 \le n \le 10^31≤n≤103) – the number of types, and mm (1 \le m \le 10^41≤m≤104) – the least kilograms of water he needs to buy. For each set of test cases, the sum of nn does not exceed 5e45e4.

Then followed n lines with each line two integers pp (1 \le p \le 10^91≤p≤109) – the price of this type, and cc (1 \le c \le 10^41≤c≤104) – the weight of water this type contains.

Output

For each test case, you should output one line contains the minimum cost aa and the weight of water Dawn-K will get bb. If this minimum cost corresponds different solution, output the maximum weight he can get.

(The answer aa is between 11 and 10^9109, and the answer bb is between 11 and 10^4104)

样例输入

3 3
2 1
3 1
1 1
3 5
2 3
1 2
3 3

样例输出

3 3
3 6

题意描述:这个题可以看成是一个完全背包的问题,就是要买满足至少m的水需要花费的最少钱是多少,其中n是水的种类,a[i]是水的价格,b[i]是以a[i]的价格买的水的重量。

程序代码:

#include<iostream>
#include<algorithm>
using namespace std;
long long mi=1e14;//表示样例所给的大小是10000
int a[1010],b[1010];
long long dp[50100];//给的样例是10^9,所以用long long
int main()
{
  int i,j,k,m,n,sum;
  long long x,y;
  while(scanf("%d%d",&n,&m)!=EOF)
  {
    sum=20010;
    for(i=0;i<n;i++)
      scanf("%d%d",&a[i],&b[i]);
    for(i=1;i<=sum;i++)
      dp[i]=mi;//定义最初的价格都是无穷大
    dp[0]=0;//买0需要花费0
    for(i=0;i<n;i++)
      for(j=b[i];j<=sum;j++)
      {
        dp[j]=min(dp[j],dp[j-b[i]]+a[i]);
      }
    x=dp[m];
    y=m;
    for(i=m+1;i<=sum;i++)//寻找在sum和m之间是否还有满足的其价格更低
    {
      if(dp[i]<=x)
      {
        x=dp[i];
        y=i;
      }
    } 
    printf("%lld %lld\n",x,y);  
  }
  return 0;
}
相关文章
|
6月前
ZZULIOJ----2618: ACM-ICPC亚洲区域赛ZZUL
ZZULIOJ----2618: ACM-ICPC亚洲区域赛ZZUL
Leetcode 365. Water and Jug Problem
一句话理解题意:有容积为x和y升的俩水壶,能不能量出z升的水。 我刚开始看到这题,立马就想了下暴力搜索的可能性,但考虑了下数据大小,立马放弃这个暴力的想法,于是意识到肯定有比较简单的数学方法,其实我自己没想到,后来看还是看了别人的代码,很多博客都直接给出了解法, 但没介绍为什么能这么解。所以我决定解释下我自己的思路。
46 0
|
C++ 网络架构
【PAT甲级 - C++题解】1013 Battle Over Cities
【PAT甲级 - C++题解】1013 Battle Over Cities
62 1
|
存储 C++
【PAT甲级 - C++题解】1107 Social Clusters
【PAT甲级 - C++题解】1107 Social Clusters
59 0
|
C++
【PAT甲级 - C++题解】1061 Dating
【PAT甲级 - C++题解】1061 Dating
70 0
LeetCode 365. Water and Jug Problem
有两个容量分别为 x升 和 y升 的水壶以及无限多的水。请判断能否通过使用这两个水壶,从而可以得到恰好 z升 的水?
81 0
LeetCode 365. Water and Jug Problem
upc2021秋组队训练赛第一场 ICPC North Central NA Contest 2020
upc2021秋组队训练赛第一场 ICPC North Central NA Contest 2020
89 0
upc2021秋组队训练赛第一场 ICPC North Central NA Contest 2020
|
人工智能
upc 2021秋组队训练赛第三场 2020 Rocky Mountain Regional Contest
upc 2021秋组队训练赛第三场 2020 Rocky Mountain Regional Contest
93 0
Google Earth Engine(GEE)-2020年河南洪水之前/之后
Google Earth Engine(GEE)-2020年河南洪水之前/之后
157 0
Google Earth Engine(GEE)-2020年河南洪水之前/之后
|
人工智能 Java
HDU - 2018杭电ACM集训队单人排位赛 - 2 - Problem C. Team Match
HDU - 2018杭电ACM集训队单人排位赛 - 2 - Problem C. Team Match
144 0