数据结构实验之二叉树二:遍历二叉树

简介: 数据结构实验之二叉树二:遍历二叉树

数据结构实验之二叉树二:遍历二叉树

Time Limit: 1000 ms Memory Limit: 65536 KiB

SubmitStatistic

Problem Description

已知二叉树的一个按先序遍历输入的字符序列,如abc,,de,g,,f,,, (其中,表示空结点)。请建立二叉树并按中序和后序的方式遍历该二叉树。

Input

连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。

Output

每组输入数据对应输出2行:
第1行输出中序遍历序列;
第2行输出后序遍历序列。

 

Sample Input

abc,,de,g,,f,,,

Sample Output

cbegdfa

cgefdba

Hint

 

Source

xam

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
char a[100];
int l1;
struct node //二叉树的定义
{
int data;
struct node *lchild,*rchild;
};
struct node *creat()  //建立二叉树
{
struct node  *root;
char c;
c=a[l1++];
if(c==',')
    return NULL;
else
{
    root=(struct node *)malloc(sizeof(struct node));
root->data=c;
root->lchild=creat();
root->rchild=creat();
}
return root;
}
void mid(struct node *root)//中序遍历
{
if(root)
{
mid(root->lchild);
printf("%c",root->data);
mid(root->rchild);
}
}
void after(struct node *root)  //后序遍历
{
if(root)
{
after(root->lchild);
after(root->rchild);
printf("%c",root->data);
}
}
int main()
{
struct node *root;
while(scanf("%s",a)!=EOF)
{
    l1=0;
    root=(struct node *)malloc(sizeof(struct node));
root=creat();
mid(root);
printf("\n");
after(root);
printf("\n");
}return 0;
}


相关文章
数据结构——二叉树的链式结构
数据结构——二叉树的链式结构
36 0
|
1月前
|
存储
数据结构--二叉树(2)
数据结构--二叉树(2)
|
存储 机器学习/深度学习
数据结构--二叉树-堆(1)
数据结构--二叉树-堆(1)
数据结构--二叉树-堆(1)
|
1月前
【数据结构】二叉树的模拟实现
【数据结构】二叉树的模拟实现
|
1月前
|
存储 算法
【数据结构与算法】二叉树基础OJ--下(巩固提高)
【数据结构与算法】二叉树基础OJ--下(巩固提高)
|
26天前
|
算法
【算法与数据结构】二叉树(前中后)序遍历2
【算法与数据结构】二叉树(前中后)序遍历
|
1月前
|
算法
从0开始回顾数据结构---二叉树
二叉树 1、二叉树的建立 层序遍历重建二叉树 测试样例: 11 3 9 20 -1 -1 15 7 -1 -1 -1 -1 中序遍历结果: 9 3 15 20 7 #include<iostream> #include<cstdio> using namespace std; int n, num; //定义一棵二叉树 struct TreeNode { int val; TreeNode* left; TreeNode* right; TreeNode(int _val) : val(_val), left(nullptr), right(nullp
|
12天前
二叉树和数据结构
二叉树和数据结构
18 0
|
12天前
|
算法 DataX
二叉树(中)+Leetcode每日一题——“数据结构与算法”“剑指Offer55-I. 二叉树的深度”“100.相同的树”“965.单值二叉树”
二叉树(中)+Leetcode每日一题——“数据结构与算法”“剑指Offer55-I. 二叉树的深度”“100.相同的树”“965.单值二叉树”
|
23天前
|
算法 索引
【算法与数据结构】深入二叉树实现超详解(全源码优化)
【算法与数据结构】深入二叉树实现超详解(全源码优化)