hdu 1061 Rightmost Digit

简介: hdu 1061 Rightmost Digit

Problem Description

Given a positive integer N, you should output the most right digit of N^N.

 

 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single positive integer N(1<=N<=1,000,000,000).

 

 

Output

For each test case, you should output the rightmost digit of N^N.

 

 

Sample Input

 

2 3 4

 

 

Sample Output

 

7 6

Hint

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

 

 

输出N^N结果的最右边的一位数

 

思路:

只需找出循环节便可。

 

代码:

#include<stdio.h>
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
    int n,i,k=1,f[10]={0},F[10];
scanf("%d",&n);
int a=n%10,b=n%10;
f[a]=1;
F[k]=a;
for(i=0;i<n;i++)
{
a=(a*b)%10;
if(f[a]==0) {f[a]=1;k++;F[k]=a;}
else break;
}
F[0]=F[k];
printf("%d\n",F[n%k]);
}
return 0;
}
目录
相关文章
HDU-1061,Rightmost Digit(快速幂)
HDU-1061,Rightmost Digit(快速幂)
HDOJ(HDU) 2161 Primes(素数打表)
HDOJ(HDU) 2161 Primes(素数打表)
114 0
HDOJ(HDU) 2136 Largest prime factor(素数筛选)
HDOJ(HDU) 2136 Largest prime factor(素数筛选)
112 0
HDOJ(HDU) 2401 Baskets of Gold Coins(数列、)
HDOJ(HDU) 2401 Baskets of Gold Coins(数列、)
83 0
HDOJ 1197 Specialized Four-Digit Numbers
HDOJ 1197 Specialized Four-Digit Numbers
108 0
|
机器学习/深度学习 网络架构
题解 UVA10212 【The Last Non-zero Digit.】
题目链接 这题在学长讲完之后和看完题解之后才明白函数怎么构造。这题构造一个$f(n)$$f(n)$ $=$ $n$除以 $2^{a}$ $*$ $5^{b}$ ,$a$ , $b$ 分别是 $n$ 质因数分解后$2,5$的个数。
1237 0
|
人工智能
扩展KMP - HDU 4333 Revolving Digits
 Revolving Digits Problem's Link   Mean:  给你一个字符串,你可以将该字符串的任意长度后缀截取下来然后接到最前面,让你统计所有新串中有多少种字典序小于、等于、大于原串。
810 0