【PAT甲级 - C++题解】1056 Mice and Rice

简介: 【PAT甲级 - C++题解】1056 Mice and Rice

1056 Mice and Rice


Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.


First the playing order is randomly decided for NP programmers. Then every NG programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every NG winners are then grouped in the next match until a final winner is determined.


For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.


Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: NP and NG (≤1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than NG mice at the end of the player’s list, then all the mice left will be put into the last group. The second line contains NP distinct non-negative numbers Wi (i=0,⋯,NP−1) where each Wi is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,⋯,NP−1 (assume that the programmers are numbered from 0 to NP−1). All the numbers in a line are separated by a space.


Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.


Sample Input:

11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3


Sample Output:

5 5 5 2 5 5 5 3 1 3 5


题意

给定参赛的老鼠数量 NP ,比赛分组每组 NG 只老鼠。


第二行给定 NP 个老鼠的重量,第三行给定老鼠出场的顺序,拿题目样例举例,第一只出场的老鼠编号为 6 ,第二只出场的老鼠编号为 0 。


现在要将 NP 只老鼠进行分组比赛,每组 NG 只,如果不满 NG 则同样被分为一组,每组中重量最大老鼠晋级下一轮。被淘汰的老鼠排名都相同,按照上述规则继续分组比赛,直至找到第一名,最后输出每只老鼠的最终排名。


思路

具体思路如下:


1.先用数组 w 和数组 cur 存储输入的老鼠体重以及老鼠的出场次序。

按照每组 NG 只老鼠进行划分,并进行比赛,每组中重量最大的那只进入下一轮,最后记得将2.最后一只老鼠赋予第一名。

3.输出最终排名结果,注意行末不能有空格。


代码

#include<bits/stdc++.h>
using namespace std;
const int N = 1010;
int w[N], ans[N];
int n, m;
int main()
{
    cin >> n >> m;
    //输入每只老鼠的体重
    for (int i = 0; i < n; i++)    cin >> w[i];
    //输入每只老鼠的次序
    vector<int> cur(n);
    for (int i = 0; i < n; i++)    cin >> cur[i];
    //开始比赛
    while (cur.size() > 1)
    {
        vector<int> next;
        int remain = (cur.size() + m - 1) / m;  //当前轮后剩余比赛人数
        for (int i = 0; i < cur.size();)
        {
            int j = min((int)cur.size(), i + m);  //该组比赛人数
            //找到该组中体重最大的老鼠
            int t = i;
            for (int k = i; k < j; k++)
                if (w[cur[k]] > w[cur[t]])
                    t = k;
            next.push_back(cur[t]);  //加入下一轮参赛名单
            //给淘汰的老鼠指定排名
            for (int k = i; k < j; k++)
                if (k != t)
                    ans[cur[k]] = remain + 1;
            i = j;    //进入下一组
        }
        cur = next;
    }
    ans[cur[0]] = 1;  //最后一只剩下的老鼠是第一名
    //输出最终排名
    cout << ans[0];
    for (int i = 1; i < n; i++)
        cout << " " << ans[i];
    cout << endl;
    return 0;
}
目录
相关文章
|
11月前
|
C++
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
35 0
|
11月前
|
算法 C++
【PAT甲级 - C++题解】1044 Shopping in Mars
【PAT甲级 - C++题解】1044 Shopping in Mars
56 0
|
11月前
|
C++
【PAT甲级 - C++题解】1117 Eddington Number
【PAT甲级 - C++题解】1117 Eddington Number
51 0
|
11月前
|
存储 C++ 容器
【PAT甲级 - C++题解】1057 Stack
【PAT甲级 - C++题解】1057 Stack
48 0
|
11月前
|
存储 C++
【PAT甲级 - C++题解】1055 The World‘s Richest
【PAT甲级 - C++题解】1055 The World‘s Richest
60 0
|
11月前
|
C++
【PAT甲级 - C++题解】1051 Pop Sequence
【PAT甲级 - C++题解】1051 Pop Sequence
54 0
|
11月前
|
人工智能 BI C++
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
100 0
|
11月前
|
存储 定位技术 C++
【PAT甲级 - C++题解】1091 Acute Stroke
【PAT甲级 - C++题解】1091 Acute Stroke
35 0
|
11月前
|
存储 人工智能 C++
【PAT甲级 - C++题解】1085 Perfect Sequence
【PAT甲级 - C++题解】1085 Perfect Sequence
48 0
|
11月前
|
C++
【PAT甲级 - C++题解】1046 Shortest Distance
【PAT甲级 - C++题解】1046 Shortest Distance
50 0