【PAT甲级 - C++题解】1054 The Dominant Color

简介: 【PAT甲级 - C++题解】1054 The Dominant Color

1054 The Dominant Color

Behind the scenes in the computer’s memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.


Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,224). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.


Output Specification:

For each test case, simply print the dominant color in a line.


Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24


Sample Output:

24


给定一个二维数组,指定屏幕中所有颜色,找出出现次数过半的颜色。


思路

具体思路如下:


  1. 用一个哈希表来存储每个颜色出现的次数。
  2. 找出出现此处过半的颜色并输出。


代码

#include<bits/stdc++.h>
using namespace std;
unordered_map<string, int> cnt;
int n, m;
int main()
{
    //输入屏幕的颜色并记录每个颜色出现的次数
    cin >> n >> m;
    for (int i = 0; i < n * m; i++)
    {
        string x;
        cin >> x;
        //如果已经找到则直接break
        if (++cnt[x] > n * m / 2)
        {
            cout << x << endl;
            break;
        }
    }
    return 0;
}
目录
相关文章
|
C++
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
65 0
|
算法 C++
【PAT甲级 - C++题解】1044 Shopping in Mars
【PAT甲级 - C++题解】1044 Shopping in Mars
82 0
|
C++
【PAT甲级 - C++题解】1117 Eddington Number
【PAT甲级 - C++题解】1117 Eddington Number
76 0
|
存储 C++ 容器
【PAT甲级 - C++题解】1057 Stack
【PAT甲级 - C++题解】1057 Stack
76 0
|
存储 C++
【PAT甲级 - C++题解】1055 The World‘s Richest
【PAT甲级 - C++题解】1055 The World‘s Richest
77 0
|
C++
【PAT甲级 - C++题解】1051 Pop Sequence
【PAT甲级 - C++题解】1051 Pop Sequence
77 0
|
人工智能 BI C++
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
132 0
|
存储 定位技术 C++
【PAT甲级 - C++题解】1091 Acute Stroke
【PAT甲级 - C++题解】1091 Acute Stroke
55 0
|
21天前
|
存储 编译器 对象存储
【C++打怪之路Lv5】-- 类和对象(下)
【C++打怪之路Lv5】-- 类和对象(下)
21 4
|
21天前
|
编译器 C语言 C++
【C++打怪之路Lv4】-- 类和对象(中)
【C++打怪之路Lv4】-- 类和对象(中)
19 4