【PAT甲级 - C++题解】1101 Quick Sort

简介: 【PAT甲级 - C++题解】1101 Quick Sort

1101 Quick Sort

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?


For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:


1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;

3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;

2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;

and for the similar reason, 4 and 5 could also be the pivot.

Hence in total there are 3 pivot candidates.


Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤105). Then the next line contains N distinct positive integers no larger than 109. The numbers in a line are separated by spaces.


Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.


Sample Input:

5
1 3 2 4 5

Sample Output:

3
1 4 5


题意

我们需要计算给定的数组的分界点数量,并输出出来,分界点的定义如下:

  1. 该数左边的所有值都要小于它。
  2. 该数右边的所有值都要大于它。


思路

我们可以先预处理出两个数组 lr ,分别表示每个数在其左半部分中的最大值以及每个数在其右半部分中的最小值。然后再从前往后遍历一遍,找出满足条件的分界点并放入答案数组 res 中,最后输出结果即可。

代码

#include<bits/stdc++.h>
using namespace std;
const int N = 100010, INF = 0x3f3f3f3f;
int a[N], l[N], r[N];
int n;
int main()
{
    //输入数组
    cin >> n;
    for (int i = 1; i <= n; i++)    cin >> a[i];
    //从左到右计算一遍每个数在其左半部分中的最大值
    for (int i = 1; i <= n; i++)   l[i] = max(a[i], l[i - 1]);
    //从右到左计算一遍每个数在其右半部分中的最小值
    r[n + 1] = INF;
    for (int i = n; i >= 1; i--)   r[i] = min(a[i], r[i + 1]);
    //判断分界点
    vector<int> res;
    for (int i = 1; i <= n; i++)
        if (a[i] > l[i - 1] && a[i] < r[i + 1])
            res.push_back(a[i]);
    //输出结果
    cout << res.size() << endl;
    if (res.size())
    {
        cout << res[0];
        for (int i = 1; i < res.size(); i++)   cout << " " << res[i];
    }
    cout << endl;
    return 0;
}



目录
相关文章
|
1天前
|
算法 搜索推荐 C++
【C++】sort()、stable_sort()和partial_sort()排序函数详解
【C++】sort()、stable_sort()和partial_sort()排序函数详解
38 0
|
1天前
|
算法 搜索推荐 C++
浅谈sort函数底层(一道c++面试的天坑题)
浅谈sort函数底层(一道c++面试的天坑题)
|
1天前
|
存储 算法 JavaScript
【C++ 泛型编程 入门篇】 C++ 中的泛型算法 STL(sort,find)(二)
【C++ 泛型编程 入门篇】 C++ 中的泛型算法 STL(sort,find)
35 0
|
1天前
|
算法 搜索推荐 程序员
【C++ 泛型编程 入门篇】 C++ 中的泛型算法 STL(sort,find)(一)
【C++ 泛型编程 入门篇】 C++ 中的泛型算法 STL(sort,find)
41 0
|
1天前
|
机器学习/深度学习 算法 搜索推荐
【C++修行之道】竞赛常用库函数(sort,min和max函数,min_element和max_element、nth_element)
【C++修行之道】竞赛常用库函数(sort,min和max函数,min_element和max_element、nth_element)
|
1天前
|
C++
C++如何进行sort的使用——C++如何进行排序
C++如何进行sort的使用——C++如何进行排序
29 0
|
1天前
|
C++
C++中sort排序
C++中sort排序
|
1天前
|
C++ 容器
【C++】STL容器——探究List与Vector在使用sort函数排序的区别(14)
【C++】STL容器——探究List与Vector在使用sort函数排序的区别(14)
|
10月前
|
搜索推荐 C++
C++利用sort进行排序
C++利用sort进行排序
|
11月前
|
C++
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
36 0