【PAT甲级 - C++题解】1102 Invert a Binary Tree

简介: 【PAT甲级 - C++题解】1102 Invert a Binary Tree

1102 Invert a Binary Tree

The following is from Max Howell @twitter:


Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

1
Now it’s your turn to prove that YOU CAN invert a binary tree!

Input Specification:


Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:


For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

题意

给定一棵二叉树,第一行给定 N NN ,表示有 N NN 个结点,且结点编号为 0 ∼ N − 1 0\sim N-10∼N−1 。


接下来 N NN 行输入 0 ∼ N − 1 0\sim N-10∼N−1 个结点的左右孩子编号,空结点用 - 表示。


需要将这颗二叉树进行反转,然后输出反转后的二叉树的层序遍历和中序遍历结果。

思路


  1. 用哈希表来存储每个结点的左右孩子下标。
  2. 递归交换每个结点的左右孩子,由于是用哈希表存的,所以直接交换哈希表中的值即可。
  3. 利用宽搜得到层序遍历的结果,然后递归打印中序遍历结果。


954b10a3db71486e89d9b119c070221a.png



代码

#include<bits/stdc++.h>
using namespace std;
const int N = 20;
int l[N], r[N], has_father[N];
int q[N];
int n;
//反转二叉树
void dfs_reverse(int u)
{
    if (u == -1)   return;
    dfs_reverse(l[u]);
    dfs_reverse(r[u]);
    swap(l[u], r[u]);
}
//层次遍历
void bfs(int root)
{
    int hh = 0, tt = 0;
    q[0] = root;
    while (hh <= tt)
    {
        int t = q[hh++];  //取出队头元素
        if (l[t] != -1)    q[++tt] = l[t];  //如果左孩子不为空,则加入队列
        if (r[t] != -1)    q[++tt] = r[t];  //如果右孩子不为空,则加入队列
    }
    cout << q[0];
    for (int i = 1; i < n; i++)    cout << " " << q[i];
    cout << endl;
}
//中序遍历
void dfs(int u, int& k)
{
    if (u == -1)   return;
    dfs(l[u], k); //递归左孩子
    cout << u;  //打印该结点
    if (++k != n)    cout << " "; //最后一个结点后不能有空格
    dfs(r[u], k); //递归右孩子
}
int main()
{
    //初始化
    cin >> n;
    memset(l, -1, sizeof l);
    memset(r, -1, sizeof r);
    //输入结点信息
    for (int i = 0; i < n; i++)
    {
        char ln, rn;
        cin >> ln >> rn;
        if (ln != '-') l[i] = ln - '0', has_father[l[i]] = true;
        if (rn != '-') r[i] = rn - '0', has_father[r[i]] = true;
    }
    //找出根结点
    int root = 0;
    while (has_father[root]) root++; //根结点是没有父结点的
    dfs_reverse(root);  //反转二叉树
    bfs(root);  //层次遍历
    int k = 0;
    dfs(root, k);    //中序遍历
    return 0;
}
目录
相关文章
|
6月前
|
JSON 数据格式 C++
C++ JSON库 nlohmann::basic_json::binary 的用法
C++ JSON库 nlohmann::basic_json::binary 的用法
98 0
|
C++
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
66 0
|
算法 C++
【PAT甲级 - C++题解】1044 Shopping in Mars
【PAT甲级 - C++题解】1044 Shopping in Mars
82 0
|
C++
【PAT甲级 - C++题解】1117 Eddington Number
【PAT甲级 - C++题解】1117 Eddington Number
77 0
|
存储 C++ 容器
【PAT甲级 - C++题解】1057 Stack
【PAT甲级 - C++题解】1057 Stack
76 0
|
存储 C++
【PAT甲级 - C++题解】1055 The World‘s Richest
【PAT甲级 - C++题解】1055 The World‘s Richest
79 0
|
5天前
|
存储 编译器 C++
【c++】类和对象(下)(取地址运算符重载、深究构造函数、类型转换、static修饰成员、友元、内部类、匿名对象)
本文介绍了C++中类和对象的高级特性,包括取地址运算符重载、构造函数的初始化列表、类型转换、static修饰成员、友元、内部类及匿名对象等内容。文章详细解释了每个概念的使用方法和注意事项,帮助读者深入了解C++面向对象编程的核心机制。
25 5
|
11天前
|
存储 编译器 C++
【c++】类和对象(中)(构造函数、析构函数、拷贝构造、赋值重载)
本文深入探讨了C++类的默认成员函数,包括构造函数、析构函数、拷贝构造函数和赋值重载。构造函数用于对象的初始化,析构函数用于对象销毁时的资源清理,拷贝构造函数用于对象的拷贝,赋值重载用于已存在对象的赋值。文章详细介绍了每个函数的特点、使用方法及注意事项,并提供了代码示例。这些默认成员函数确保了资源的正确管理和对象状态的维护。
40 4
|
12天前
|
存储 编译器 Linux
【c++】类和对象(上)(类的定义格式、访问限定符、类域、类的实例化、对象的内存大小、this指针)
本文介绍了C++中的类和对象,包括类的概念、定义格式、访问限定符、类域、对象的创建及内存大小、以及this指针。通过示例代码详细解释了类的定义、成员函数和成员变量的作用,以及如何使用访问限定符控制成员的访问权限。此外,还讨论了对象的内存分配规则和this指针的使用场景,帮助读者深入理解面向对象编程的核心概念。
35 4
|
1月前
|
存储 编译器 对象存储
【C++打怪之路Lv5】-- 类和对象(下)
【C++打怪之路Lv5】-- 类和对象(下)
27 4