【PAT甲级 - C++题解】1102 Invert a Binary Tree

简介: 【PAT甲级 - C++题解】1102 Invert a Binary Tree

1102 Invert a Binary Tree

The following is from Max Howell @twitter:


Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

1
Now it’s your turn to prove that YOU CAN invert a binary tree!

Input Specification:


Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:


For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

题意

给定一棵二叉树,第一行给定 N NN ,表示有 N NN 个结点,且结点编号为 0 ∼ N − 1 0\sim N-10∼N−1 。


接下来 N NN 行输入 0 ∼ N − 1 0\sim N-10∼N−1 个结点的左右孩子编号,空结点用 - 表示。


需要将这颗二叉树进行反转,然后输出反转后的二叉树的层序遍历和中序遍历结果。

思路


  1. 用哈希表来存储每个结点的左右孩子下标。
  2. 递归交换每个结点的左右孩子,由于是用哈希表存的,所以直接交换哈希表中的值即可。
  3. 利用宽搜得到层序遍历的结果,然后递归打印中序遍历结果。


954b10a3db71486e89d9b119c070221a.png



代码

#include<bits/stdc++.h>
using namespace std;
const int N = 20;
int l[N], r[N], has_father[N];
int q[N];
int n;
//反转二叉树
void dfs_reverse(int u)
{
    if (u == -1)   return;
    dfs_reverse(l[u]);
    dfs_reverse(r[u]);
    swap(l[u], r[u]);
}
//层次遍历
void bfs(int root)
{
    int hh = 0, tt = 0;
    q[0] = root;
    while (hh <= tt)
    {
        int t = q[hh++];  //取出队头元素
        if (l[t] != -1)    q[++tt] = l[t];  //如果左孩子不为空,则加入队列
        if (r[t] != -1)    q[++tt] = r[t];  //如果右孩子不为空,则加入队列
    }
    cout << q[0];
    for (int i = 1; i < n; i++)    cout << " " << q[i];
    cout << endl;
}
//中序遍历
void dfs(int u, int& k)
{
    if (u == -1)   return;
    dfs(l[u], k); //递归左孩子
    cout << u;  //打印该结点
    if (++k != n)    cout << " "; //最后一个结点后不能有空格
    dfs(r[u], k); //递归右孩子
}
int main()
{
    //初始化
    cin >> n;
    memset(l, -1, sizeof l);
    memset(r, -1, sizeof r);
    //输入结点信息
    for (int i = 0; i < n; i++)
    {
        char ln, rn;
        cin >> ln >> rn;
        if (ln != '-') l[i] = ln - '0', has_father[l[i]] = true;
        if (rn != '-') r[i] = rn - '0', has_father[r[i]] = true;
    }
    //找出根结点
    int root = 0;
    while (has_father[root]) root++; //根结点是没有父结点的
    dfs_reverse(root);  //反转二叉树
    bfs(root);  //层次遍历
    int k = 0;
    dfs(root, k);    //中序遍历
    return 0;
}
目录
相关文章
|
8月前
|
JSON 数据格式 C++
C++ JSON库 nlohmann::basic_json::binary 的用法
C++ JSON库 nlohmann::basic_json::binary 的用法
126 0
|
C++
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
73 0
|
算法 C++
【PAT甲级 - C++题解】1044 Shopping in Mars
【PAT甲级 - C++题解】1044 Shopping in Mars
94 0
|
C++
【PAT甲级 - C++题解】1117 Eddington Number
【PAT甲级 - C++题解】1117 Eddington Number
86 0
|
存储 C++ 容器
【PAT甲级 - C++题解】1057 Stack
【PAT甲级 - C++题解】1057 Stack
82 0
|
存储 C++
【PAT甲级 - C++题解】1055 The World‘s Richest
【PAT甲级 - C++题解】1055 The World‘s Richest
84 0
|
11天前
|
C++ 芯片
【C++面向对象——类与对象】Computer类(头歌实践教学平台习题)【合集】
声明一个简单的Computer类,含有数据成员芯片(cpu)、内存(ram)、光驱(cdrom)等等,以及两个公有成员函数run、stop。只能在类的内部访问。这是一种数据隐藏的机制,用于保护类的数据不被外部随意修改。根据提示,在右侧编辑器补充代码,平台会对你编写的代码进行测试。成员可以在派生类(继承该类的子类)中访问。成员,在类的外部不能直接访问。可以在类的外部直接访问。为了完成本关任务,你需要掌握。
52 18
|
11天前
|
存储 编译器 数据安全/隐私保护
【C++面向对象——类与对象】CPU类(头歌实践教学平台习题)【合集】
声明一个CPU类,包含等级(rank)、频率(frequency)、电压(voltage)等属性,以及两个公有成员函数run、stop。根据提示,在右侧编辑器补充代码,平台会对你编写的代码进行测试。​ 相关知识 类的声明和使用。 类的声明和对象的声明。 构造函数和析构函数的执行。 一、类的声明和使用 1.类的声明基础 在C++中,类是创建对象的蓝图。类的声明定义了类的成员,包括数据成员(变量)和成员函数(方法)。一个简单的类声明示例如下: classMyClass{ public: int
38 13
|
11天前
|
编译器 数据安全/隐私保护 C++
【C++面向对象——继承与派生】派生类的应用(头歌实践教学平台习题)【合集】
本实验旨在学习类的继承关系、不同继承方式下的访问控制及利用虚基类解决二义性问题。主要内容包括: 1. **类的继承关系基础概念**:介绍继承的定义及声明派生类的语法。 2. **不同继承方式下对基类成员的访问控制**:详细说明`public`、`private`和`protected`继承方式对基类成员的访问权限影响。 3. **利用虚基类解决二义性问题**:解释多继承中可能出现的二义性及其解决方案——虚基类。 实验任务要求从`people`类派生出`student`、`teacher`、`graduate`和`TA`类,添加特定属性并测试这些类的功能。最终通过创建教师和助教实例,验证代码
37 5
|
11天前
|
存储 算法 搜索推荐
【C++面向对象——群体类和群体数据的组织】实现含排序功能的数组类(头歌实践教学平台习题)【合集】
1. **相关排序和查找算法的原理**:介绍直接插入排序、直接选择排序、冒泡排序和顺序查找的基本原理及其实现代码。 2. **C++ 类与成员函数的定义**:讲解如何定义`Array`类,包括类的声明和实现,以及成员函数的定义与调用。 3. **数组作为类的成员变量的处理**:探讨内存管理和正确访问数组元素的方法,确保在类中正确使用动态分配的数组。 4. **函数参数传递与返回值处理**:解释排序和查找函数的参数传递方式及返回值处理,确保函数功能正确实现。 通过掌握这些知识,可以顺利地将排序和查找算法封装到`Array`类中,并进行测试验证。编程要求是在右侧编辑器补充代码以实现三种排序算法
28 5