【PAT甲级 - C++题解】1099 Build A Binary Search Tree

简介: 【PAT甲级 - C++题解】1099 Build A Binary Search Tree

1099 Build A Binary Search Tree


A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:


The left subtree of a node contains only nodes with keys less than the node’s key.

The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.

Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

c26761265c3b4f0f9e136d86780d521c.jpg



Input Specification:


Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:


For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

题意


二叉搜索树 (BST) 递归定义为具有以下属性的二叉树:


若它的左子树不空,则左子树上所有结点的值均小于它的根结点的值

若它的右子树不空,则右子树上所有结点的值均大于或等于它的根结点的值

它的左、右子树也分别为二叉搜索树

给定二叉树的具体结构以及一系列不同的整数,只有一种方法可以将这些数填充到树中,以使结果树满足 BST 的定义。


请你输出结果树的层序遍历。


给定一个 N NN ,所有结点范围在 0 ∼ N − 1 0 \sim N-10∼N−1 之间,接下来 N NN 行会输入 0 ∼ N − 1 0 \sim N-10∼N−1 的左右孩子的下标,其中 − 1 -1−1 表示空结点。


最后一行输出 N NN 个结点的值。

思路


  1. 利用二叉搜索树的性质,其中序遍历的结果一定是有序序列,所以我们将所有结点的值进行排序就可以得到该树中序遍历的结果。
  2. 模拟该树中序遍历的过程,然后将每个值放入对应的位置上。
  3. 输出层次遍历的结果。


代码

#include<bits/stdc++.h>
using namespace std;
const int N = 110;
int n;
int l[N], r[N]; //用哈希表来存储每个结点左孩子的下标
int a[N], w[N];
int q[N];
//模拟中序遍历
void dfs(int u, int& k)
{
    if (u == -1)  return;
    dfs(l[u], k);
    w[u] = a[k++];
    dfs(r[u], k);
}
//输出层次遍历的结果
void bfs()
{
    int hh = 0, tt = 0;
    q[0] = 0;
    while (hh <= tt)
    {
        int t = q[hh++];
        if (l[t] != -1)    q[++tt] = l[t];
        if (r[t] != -1)    q[++tt] = r[t];
    }
    cout << w[q[0]];
    for (int i = 1; i < n; i++)    cout << " " << w[q[i]];
    cout << endl;
}
int main()
{
    cin >> n;
    for (int i = 0; i < n; i++)    cin >> l[i] >> r[i];
    for (int i = 0; i < n; i++)    cin >> a[i];
    sort(a, a + n);    //获得中序遍历结果
    int k = 0;
    dfs(0, k);
    bfs();
    return 0;
}


目录
相关文章
|
7月前
|
算法 C++ iOS开发
软件开发入门教程网 Search之C++ 接口(抽象类)
软件开发入门教程网 Search之C++ 接口(抽象类)
|
7月前
|
数据安全/隐私保护 C++ iOS开发
软件开发入门教程网 Search之C++ 继承
软件开发入门教程网 Search之C++ 继承
|
7月前
|
并行计算 程序员 C++
软件开发入门教程网 Search之C++ 简介
软件开发入门教程网 Search之C++ 简介
|
4天前
|
缓存 算法 C语言
【C++ 标准查找算法 】C++标准库查找算法深入解析(In-depth Analysis of C++ Standard Library Search Algorithms)
【C++ 标准查找算法 】C++标准库查找算法深入解析(In-depth Analysis of C++ Standard Library Search Algorithms)
51 0
|
4天前
|
算法 前端开发 大数据
【C/C++ 基础知识 】C++中易混淆的函数和关键字:std::find vs std::search,std::remove vs std::erase,remove vs delete
【C/C++ 基础知识 】C++中易混淆的函数和关键字:std::find vs std::search,std::remove vs std::erase,remove vs delete
36 0
|
4天前
|
JSON 数据格式 C++
C++ JSON库 nlohmann::basic_json::binary 的用法
C++ JSON库 nlohmann::basic_json::binary 的用法
31 0
|
7月前
|
编译器 C语言 C++
软件开发入门教程网 Search之C++ 环境设置
软件开发入门教程网 Search之C++ 环境设置
|
7月前
|
存储 程序员 C语言
软件开发入门教程网 Search之C++ 动态内存
软件开发入门教程网 Search之C++ 动态内存
|
11月前
|
C++
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
36 0
|
4天前
|
设计模式 安全 算法
【C++入门到精通】特殊类的设计 | 单例模式 [ C++入门 ]
【C++入门到精通】特殊类的设计 | 单例模式 [ C++入门 ]
18 0