【PAT甲级 - C++题解】1099 Build A Binary Search Tree

简介: 【PAT甲级 - C++题解】1099 Build A Binary Search Tree

1099 Build A Binary Search Tree


A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:


The left subtree of a node contains only nodes with keys less than the node’s key.

The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.

Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

c26761265c3b4f0f9e136d86780d521c.jpg



Input Specification:


Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:


For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

题意


二叉搜索树 (BST) 递归定义为具有以下属性的二叉树:


若它的左子树不空,则左子树上所有结点的值均小于它的根结点的值

若它的右子树不空,则右子树上所有结点的值均大于或等于它的根结点的值

它的左、右子树也分别为二叉搜索树

给定二叉树的具体结构以及一系列不同的整数,只有一种方法可以将这些数填充到树中,以使结果树满足 BST 的定义。


请你输出结果树的层序遍历。


给定一个 N NN ,所有结点范围在 0 ∼ N − 1 0 \sim N-10∼N−1 之间,接下来 N NN 行会输入 0 ∼ N − 1 0 \sim N-10∼N−1 的左右孩子的下标,其中 − 1 -1−1 表示空结点。


最后一行输出 N NN 个结点的值。

思路


  1. 利用二叉搜索树的性质,其中序遍历的结果一定是有序序列,所以我们将所有结点的值进行排序就可以得到该树中序遍历的结果。
  2. 模拟该树中序遍历的过程,然后将每个值放入对应的位置上。
  3. 输出层次遍历的结果。


代码

#include<bits/stdc++.h>
using namespace std;
const int N = 110;
int n;
int l[N], r[N]; //用哈希表来存储每个结点左孩子的下标
int a[N], w[N];
int q[N];
//模拟中序遍历
void dfs(int u, int& k)
{
    if (u == -1)  return;
    dfs(l[u], k);
    w[u] = a[k++];
    dfs(r[u], k);
}
//输出层次遍历的结果
void bfs()
{
    int hh = 0, tt = 0;
    q[0] = 0;
    while (hh <= tt)
    {
        int t = q[hh++];
        if (l[t] != -1)    q[++tt] = l[t];
        if (r[t] != -1)    q[++tt] = r[t];
    }
    cout << w[q[0]];
    for (int i = 1; i < n; i++)    cout << " " << w[q[i]];
    cout << endl;
}
int main()
{
    cin >> n;
    for (int i = 0; i < n; i++)    cin >> l[i] >> r[i];
    for (int i = 0; i < n; i++)    cin >> a[i];
    sort(a, a + n);    //获得中序遍历结果
    int k = 0;
    dfs(0, k);
    bfs();
    return 0;
}


目录
相关文章
|
6月前
|
编译器 开发工具 C++
【Python】已解决error: Microsoft Visual C++ 14.0 or greater is required. Get it with “Microsoft C++ Build
【Python】已解决error: Microsoft Visual C++ 14.0 or greater is required. Get it with “Microsoft C++ Build
3590 0
|
8月前
|
JSON 数据格式 C++
C++ JSON库 nlohmann::basic_json::binary 的用法
C++ JSON库 nlohmann::basic_json::binary 的用法
116 0
|
C++
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
70 0
|
算法 C++
【PAT甲级 - C++题解】1044 Shopping in Mars
【PAT甲级 - C++题解】1044 Shopping in Mars
93 0
|
C++
【PAT甲级 - C++题解】1117 Eddington Number
【PAT甲级 - C++题解】1117 Eddington Number
84 0
|
2月前
|
存储 编译器 C语言
【c++丨STL】string类的使用
本文介绍了C++中`string`类的基本概念及其主要接口。`string`类在C++标准库中扮演着重要角色,它提供了比C语言中字符串处理函数更丰富、安全和便捷的功能。文章详细讲解了`string`类的构造函数、赋值运算符、容量管理接口、元素访问及遍历方法、字符串修改操作、字符串运算接口、常量成员和非成员函数等内容。通过实例演示了如何使用这些接口进行字符串的创建、修改、查找和比较等操作,帮助读者更好地理解和掌握`string`类的应用。
63 2
|
2月前
|
存储 编译器 C++
【c++】类和对象(下)(取地址运算符重载、深究构造函数、类型转换、static修饰成员、友元、内部类、匿名对象)
本文介绍了C++中类和对象的高级特性,包括取地址运算符重载、构造函数的初始化列表、类型转换、static修饰成员、友元、内部类及匿名对象等内容。文章详细解释了每个概念的使用方法和注意事项,帮助读者深入了解C++面向对象编程的核心机制。
113 5
|
2月前
|
存储 编译器 C++
【c++】类和对象(中)(构造函数、析构函数、拷贝构造、赋值重载)
本文深入探讨了C++类的默认成员函数,包括构造函数、析构函数、拷贝构造函数和赋值重载。构造函数用于对象的初始化,析构函数用于对象销毁时的资源清理,拷贝构造函数用于对象的拷贝,赋值重载用于已存在对象的赋值。文章详细介绍了每个函数的特点、使用方法及注意事项,并提供了代码示例。这些默认成员函数确保了资源的正确管理和对象状态的维护。
112 4
|
2月前
|
存储 编译器 Linux
【c++】类和对象(上)(类的定义格式、访问限定符、类域、类的实例化、对象的内存大小、this指针)
本文介绍了C++中的类和对象,包括类的概念、定义格式、访问限定符、类域、对象的创建及内存大小、以及this指针。通过示例代码详细解释了类的定义、成员函数和成员变量的作用,以及如何使用访问限定符控制成员的访问权限。此外,还讨论了对象的内存分配规则和this指针的使用场景,帮助读者深入理解面向对象编程的核心概念。
152 4
|
3月前
|
存储 编译器 对象存储
【C++打怪之路Lv5】-- 类和对象(下)
【C++打怪之路Lv5】-- 类和对象(下)
35 4