【PAT甲级 - C++题解】1136 A Delayed Palin

简介: 【PAT甲级 - C++题解】1136 A Delayed Palin

1136 A Delayed Palindrome


Consider a positive integer N written in standard notation with k+1 digits a i a_ia

i

 as a k   ⋯   a 1   a 0 a_k\ ⋯\ a_1\ a_0a

k

 ⋯ a

1

 a

0

 with 0 ≤ a i < 10 0≤a_i<100≤a

i

<10 for all i and a k > 0 a_k>0a

k

>0. Then N is palindromic if and only if a i = a k − i a_i=a_k−ia

i

=a

k

−i for all i. Zero is written 0 and is also palindromic by definition.


Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number )


Given any positive integer, you are supposed to find its paired palindromic number.

Input Specification:

Each input file contains one test case which gives a positive integer no more than 1000 digits.:https://blog.csdn.net/Newin2020/article/details/126754745


Output Specification:


For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:

A + B = C

where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number – in this case we print in the last line C is a palindromic number.; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations. instead.

Sample Input 1:

97152
• 1

Sample Output 1:

97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.

Sample Input 2:

196
• 1

Sample Output 2:

196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.

题意

这道题是 PAT 1024 那道题的改编,几乎一样。同样想要去获得一个回文数,例如 1234321 。


如果给定的数字不是回文数则需要将该数字加上它的逆序数,例如 123 不是回文数,则要加上它的逆序数 321 。然后再判断加上逆序数之后的数是否为回文数,如果还不是就重复上述操作直至是回文数为止。


但是题目有个限制,上述的加法操作最多只能进行十次,如果十次后还不是回文数就不管了,并且输出 Not found in 10 iterations. ,否则输出 i is a palindromic number. ,其中 i 是最终得到的回文数。


思路

这道题给定的数字很大,如果正常加法会爆 int ,需要用到高精度操作,所以一开始我们用字符串类型读入数字,然后再将字符串中的每一位都放进数组当中,注意要从字符转化回数字即 n[i] - '0' 。另外,我们数组中下标为 0 的位置存的是数字的最高位,例如 12345 放到数组中,下标从 0 到 4 存的是从 5 到 1 的数,即倒着放进数组,这样有利于我们后续的高精度操作。

先判断该数字是否为回文数,如果不是就进行上述的加法操作。另外,我们将数字反转利用了 c++ 的语法。

这里套用了高精度的加法模板,其中有些地方可以省略,因为这道题加法的两个数长度是相同的,所以可以不用同时判断 i 小于 a 和 b 的长度。另外,因为 t 是可能会有进位,所以需要判断 t 是否为 0 ,如果不为 0 还需要加到答案数组中。

在操作的过程中需要输出操作结果,格式为 A + B = C 。

根据最后一个数是否是回文数,输出对应的结果。

代码

#include<bits/stdc++.h>
using namespace std;
//判断是否为回文数
bool check(vector<int> a)
{
    for (int i = 0, j = a.size() - 1; i < j; i++, j--)
        if (a[i] != a[j])
            return false;
    return true;
}
//高精度加法模板
vector<int> add(vector<int> a, vector<int> b)
{
    vector<int> c;
    for (int i = 0, t = 0; i < a.size() || i < b.size() || t; i++)
    {
        if (i < a.size())  t += a[i];
        if (i < b.size())  t += b[i];
        c.push_back(t % 10);
        t /= 10;
    }
    return c;
}
//打印数字
void print(vector<int> a)
{
    for (int i = a.size() - 1; i >= 0; i--)
        cout << a[i];
}
int main()
{
    string n;
    cin >> n;
    vector<int> a;
    for (int i = n.size() - 1; i >= 0; i--)  a.push_back(n[i] - '0');
    for (int i = 0; i < 10; i++)
    {
        if (check(a))    break; //先判断是否为回文数
        vector<int> b(a.rbegin(), a.rend());  //将数字逆转
        print(a), cout << " + ", print(b), cout << " = ";
        a = add(a, b);  //执行高精度加法操作
        print(a), cout << endl;
    }
    //输出对应结果
    if (!check(a))    puts("Not found in 10 iterations.");
    else    print(a), cout << " is a palindromic number." << endl;
    return 0;
}


目录
相关文章
|
C++
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
73 0
|
算法 C++
【PAT甲级 - C++题解】1044 Shopping in Mars
【PAT甲级 - C++题解】1044 Shopping in Mars
94 0
|
C++
【PAT甲级 - C++题解】1117 Eddington Number
【PAT甲级 - C++题解】1117 Eddington Number
86 0
|
存储 C++ 容器
【PAT甲级 - C++题解】1057 Stack
【PAT甲级 - C++题解】1057 Stack
82 0
|
存储 C++
【PAT甲级 - C++题解】1055 The World‘s Richest
【PAT甲级 - C++题解】1055 The World‘s Richest
84 0
|
C++
【PAT甲级 - C++题解】1051 Pop Sequence
【PAT甲级 - C++题解】1051 Pop Sequence
89 0
|
人工智能 BI C++
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
143 0
|
13天前
|
C++ 芯片
【C++面向对象——类与对象】Computer类(头歌实践教学平台习题)【合集】
声明一个简单的Computer类,含有数据成员芯片(cpu)、内存(ram)、光驱(cdrom)等等,以及两个公有成员函数run、stop。只能在类的内部访问。这是一种数据隐藏的机制,用于保护类的数据不被外部随意修改。根据提示,在右侧编辑器补充代码,平台会对你编写的代码进行测试。成员可以在派生类(继承该类的子类)中访问。成员,在类的外部不能直接访问。可以在类的外部直接访问。为了完成本关任务,你需要掌握。
54 18
|
13天前
|
存储 编译器 数据安全/隐私保护
【C++面向对象——类与对象】CPU类(头歌实践教学平台习题)【合集】
声明一个CPU类,包含等级(rank)、频率(frequency)、电压(voltage)等属性,以及两个公有成员函数run、stop。根据提示,在右侧编辑器补充代码,平台会对你编写的代码进行测试。​ 相关知识 类的声明和使用。 类的声明和对象的声明。 构造函数和析构函数的执行。 一、类的声明和使用 1.类的声明基础 在C++中,类是创建对象的蓝图。类的声明定义了类的成员,包括数据成员(变量)和成员函数(方法)。一个简单的类声明示例如下: classMyClass{ public: int
38 13
|
13天前
|
编译器 数据安全/隐私保护 C++
【C++面向对象——继承与派生】派生类的应用(头歌实践教学平台习题)【合集】
本实验旨在学习类的继承关系、不同继承方式下的访问控制及利用虚基类解决二义性问题。主要内容包括: 1. **类的继承关系基础概念**:介绍继承的定义及声明派生类的语法。 2. **不同继承方式下对基类成员的访问控制**:详细说明`public`、`private`和`protected`继承方式对基类成员的访问权限影响。 3. **利用虚基类解决二义性问题**:解释多继承中可能出现的二义性及其解决方案——虚基类。 实验任务要求从`people`类派生出`student`、`teacher`、`graduate`和`TA`类,添加特定属性并测试这些类的功能。最终通过创建教师和助教实例,验证代码
37 5