【PAT甲级 - C++题解】1108 Finding Average

简介: 【PAT甲级 - C++题解】1108 Finding Average

1108 Finding Average


The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:


Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.

Output Specification:


For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
• 1
• 2

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38


Sample Input 2:

2
aaa -9999


Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined


思路



可以利用异常处理的语法来判断数字是否合法,因为在调用 stof 函数(将字符串转换成浮点数类型)时,如果转换的是不合法数字,就会报异常。但是如果该字符串前面是数字后面不是数字,例如 12.2a ,stof 就只会转换到第一个非法数字停止即将 12.2a 转换成 12.2 ,所以并不会报异常,这里还需要我们额外去判断,如果转换时没有用到字符串的所有元素也要标记为非法数字。

数字需要在 [-1000,1000] 的范围内,否则要标记为非法数字。

数字的精度不能超过 2 位,否则要标记为非法数字。

如果是合法数字则更新合法数字数量 cnt 以及合法数字总和 sum ,否则输出对应答案。

最终根据 cnt 的数量输出对应的答案。

代码

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n;
    cin >> n;
    int cnt = 0;  //统计合法数字的个数
    double sum = 0;   //统计合法数字的总和
    for (int i = 0; i < n; i++)
    {
        string str;
        cin >> str;
        double x;
        bool success = true;  //判断是否为合法数字
        try
        {
            size_t idx; //用来取stof转换到第几个位置
            x = stof(str, &idx);
            //例如12.2a也是能够转换成12.2,但却是不合法的需额外判断
            if (idx < str.size())  success = false;
        }
        catch (...)  //...表示接受任何异常
        {
            success = false;
        }
        //数字需要在[-1000,1000]范围内
        if (x < -1000 || x>1000)   success = false;
        //小数点后面最多只能有2位
        int k = str.find('.');
        if (k != -1 && str.size() - k > 3)  success = false;
        if (success) cnt++, sum += x;
        else printf("ERROR: %s is not a legal number\n", str.c_str());
    }
    if (cnt == 0) puts("The average of 0 numbers is Undefined");
    else if (cnt == 1) printf("The average of 1 number is %.2f", sum);
    else    printf("The average of %d numbers is %.2f", cnt, sum / cnt);
    return 0;
}
目录
相关文章
|
C++
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
66 0
|
算法 C++
【PAT甲级 - C++题解】1044 Shopping in Mars
【PAT甲级 - C++题解】1044 Shopping in Mars
82 0
|
C++
【PAT甲级 - C++题解】1117 Eddington Number
【PAT甲级 - C++题解】1117 Eddington Number
76 0
|
存储 C++ 容器
【PAT甲级 - C++题解】1057 Stack
【PAT甲级 - C++题解】1057 Stack
76 0
|
存储 C++
【PAT甲级 - C++题解】1055 The World‘s Richest
【PAT甲级 - C++题解】1055 The World‘s Richest
78 0
|
C++
【PAT甲级 - C++题解】1051 Pop Sequence
【PAT甲级 - C++题解】1051 Pop Sequence
79 0
|
7天前
|
存储 编译器 C++
【c++】类和对象(中)(构造函数、析构函数、拷贝构造、赋值重载)
本文深入探讨了C++类的默认成员函数,包括构造函数、析构函数、拷贝构造函数和赋值重载。构造函数用于对象的初始化,析构函数用于对象销毁时的资源清理,拷贝构造函数用于对象的拷贝,赋值重载用于已存在对象的赋值。文章详细介绍了每个函数的特点、使用方法及注意事项,并提供了代码示例。这些默认成员函数确保了资源的正确管理和对象状态的维护。
33 4
|
8天前
|
存储 编译器 Linux
【c++】类和对象(上)(类的定义格式、访问限定符、类域、类的实例化、对象的内存大小、this指针)
本文介绍了C++中的类和对象,包括类的概念、定义格式、访问限定符、类域、对象的创建及内存大小、以及this指针。通过示例代码详细解释了类的定义、成员函数和成员变量的作用,以及如何使用访问限定符控制成员的访问权限。此外,还讨论了对象的内存分配规则和this指针的使用场景,帮助读者深入理解面向对象编程的核心概念。
27 4
|
1月前
|
存储 编译器 对象存储
【C++打怪之路Lv5】-- 类和对象(下)
【C++打怪之路Lv5】-- 类和对象(下)
27 4
|
1月前
|
编译器 C语言 C++
【C++打怪之路Lv4】-- 类和对象(中)
【C++打怪之路Lv4】-- 类和对象(中)
23 4