【PAT甲级 - C++题解】1108 Finding Average

简介: 【PAT甲级 - C++题解】1108 Finding Average

1108 Finding Average


The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:


Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.

Output Specification:


For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
• 1
• 2

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38


Sample Input 2:

2
aaa -9999


Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined


思路



可以利用异常处理的语法来判断数字是否合法,因为在调用 stof 函数(将字符串转换成浮点数类型)时,如果转换的是不合法数字,就会报异常。但是如果该字符串前面是数字后面不是数字,例如 12.2a ,stof 就只会转换到第一个非法数字停止即将 12.2a 转换成 12.2 ,所以并不会报异常,这里还需要我们额外去判断,如果转换时没有用到字符串的所有元素也要标记为非法数字。

数字需要在 [-1000,1000] 的范围内,否则要标记为非法数字。

数字的精度不能超过 2 位,否则要标记为非法数字。

如果是合法数字则更新合法数字数量 cnt 以及合法数字总和 sum ,否则输出对应答案。

最终根据 cnt 的数量输出对应的答案。

代码

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n;
    cin >> n;
    int cnt = 0;  //统计合法数字的个数
    double sum = 0;   //统计合法数字的总和
    for (int i = 0; i < n; i++)
    {
        string str;
        cin >> str;
        double x;
        bool success = true;  //判断是否为合法数字
        try
        {
            size_t idx; //用来取stof转换到第几个位置
            x = stof(str, &idx);
            //例如12.2a也是能够转换成12.2,但却是不合法的需额外判断
            if (idx < str.size())  success = false;
        }
        catch (...)  //...表示接受任何异常
        {
            success = false;
        }
        //数字需要在[-1000,1000]范围内
        if (x < -1000 || x>1000)   success = false;
        //小数点后面最多只能有2位
        int k = str.find('.');
        if (k != -1 && str.size() - k > 3)  success = false;
        if (success) cnt++, sum += x;
        else printf("ERROR: %s is not a legal number\n", str.c_str());
    }
    if (cnt == 0) puts("The average of 0 numbers is Undefined");
    else if (cnt == 1) printf("The average of 1 number is %.2f", sum);
    else    printf("The average of %d numbers is %.2f", cnt, sum / cnt);
    return 0;
}
目录
相关文章
|
C++
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
40 0
|
算法 C++
【PAT甲级 - C++题解】1044 Shopping in Mars
【PAT甲级 - C++题解】1044 Shopping in Mars
62 0
|
C++
【PAT甲级 - C++题解】1117 Eddington Number
【PAT甲级 - C++题解】1117 Eddington Number
55 0
|
存储 C++ 容器
【PAT甲级 - C++题解】1057 Stack
【PAT甲级 - C++题解】1057 Stack
54 0
|
存储 C++
【PAT甲级 - C++题解】1055 The World‘s Richest
【PAT甲级 - C++题解】1055 The World‘s Richest
64 0
|
C++
【PAT甲级 - C++题解】1051 Pop Sequence
【PAT甲级 - C++题解】1051 Pop Sequence
59 0
|
人工智能 BI C++
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
109 0
|
2天前
|
C++
【C++】日期类Date(详解)②
- `-=`通过复用`+=`实现,`Date operator-(int day)`则通过创建副本并调用`-=`。 - 前置`++`和后置`++`同样使用重载,类似地,前置`--`和后置`--`也复用了`+=`和`-=1`。 - 比较运算符重载如`&gt;`, `==`, `&lt;`, `&lt;=`, `!=`,通常只需实现两个,其他可通过复合逻辑得出。 - `Date`减`Date`返回天数,通过迭代较小日期直到与较大日期相等,记录步数和符号。 ``` 这是236个字符的摘要,符合240字符以内的要求,涵盖了日期类中运算符重载的主要实现。
|
4天前
|
C++
C++职工管理系统(类继承、文件、指针操作、中文乱码解决)
C++职工管理系统(类继承、文件、指针操作、中文乱码解决)
7 0
C++职工管理系统(类继承、文件、指针操作、中文乱码解决)
|
2天前
|
存储 编译器 C++
【C++】类和对象④(再谈构造函数:初始化列表,隐式类型转换,缺省值
C++中的隐式类型转换在变量赋值和函数调用中常见,如`double`转`int`。取引用时,须用`const`以防修改临时变量,如`const int& b = a;`。类可以有隐式单参构造,使`A aa2 = 1;`合法,但`explicit`关键字可阻止这种转换。C++11起,成员变量可设默认值,如`int _b1 = 1;`。博客探讨构造函数、初始化列表及编译器优化,关注更多C++特性。