【PAT甲级 - C++题解】1108 Finding Average

简介: 【PAT甲级 - C++题解】1108 Finding Average

1108 Finding Average


The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:


Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.

Output Specification:


For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
• 1
• 2

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38


Sample Input 2:

2
aaa -9999


Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined


思路



可以利用异常处理的语法来判断数字是否合法,因为在调用 stof 函数(将字符串转换成浮点数类型)时,如果转换的是不合法数字,就会报异常。但是如果该字符串前面是数字后面不是数字,例如 12.2a ,stof 就只会转换到第一个非法数字停止即将 12.2a 转换成 12.2 ,所以并不会报异常,这里还需要我们额外去判断,如果转换时没有用到字符串的所有元素也要标记为非法数字。

数字需要在 [-1000,1000] 的范围内,否则要标记为非法数字。

数字的精度不能超过 2 位,否则要标记为非法数字。

如果是合法数字则更新合法数字数量 cnt 以及合法数字总和 sum ,否则输出对应答案。

最终根据 cnt 的数量输出对应的答案。

代码

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n;
    cin >> n;
    int cnt = 0;  //统计合法数字的个数
    double sum = 0;   //统计合法数字的总和
    for (int i = 0; i < n; i++)
    {
        string str;
        cin >> str;
        double x;
        bool success = true;  //判断是否为合法数字
        try
        {
            size_t idx; //用来取stof转换到第几个位置
            x = stof(str, &idx);
            //例如12.2a也是能够转换成12.2,但却是不合法的需额外判断
            if (idx < str.size())  success = false;
        }
        catch (...)  //...表示接受任何异常
        {
            success = false;
        }
        //数字需要在[-1000,1000]范围内
        if (x < -1000 || x>1000)   success = false;
        //小数点后面最多只能有2位
        int k = str.find('.');
        if (k != -1 && str.size() - k > 3)  success = false;
        if (success) cnt++, sum += x;
        else printf("ERROR: %s is not a legal number\n", str.c_str());
    }
    if (cnt == 0) puts("The average of 0 numbers is Undefined");
    else if (cnt == 1) printf("The average of 1 number is %.2f", sum);
    else    printf("The average of %d numbers is %.2f", cnt, sum / cnt);
    return 0;
}
目录
打赏
0
0
0
0
37
分享
相关文章
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
109 0
【PAT甲级 - C++题解】1044 Shopping in Mars
【PAT甲级 - C++题解】1044 Shopping in Mars
151 0
【PAT甲级 - C++题解】1117 Eddington Number
【PAT甲级 - C++题解】1117 Eddington Number
141 0
【PAT甲级 - C++题解】1057 Stack
【PAT甲级 - C++题解】1057 Stack
140 0
【PAT甲级 - C++题解】1055 The World‘s Richest
【PAT甲级 - C++题解】1055 The World‘s Richest
95 0
【PAT甲级 - C++题解】1051 Pop Sequence
【PAT甲级 - C++题解】1051 Pop Sequence
99 0
【C++篇】深度解析类与对象(下)
在上一篇博客中,我们学习了C++的基础类与对象概念,包括类的定义、对象的使用和构造函数的作用。在这一篇,我们将深入探讨C++类的一些重要特性,如构造函数的高级用法、类型转换、static成员、友元、内部类、匿名对象,以及对象拷贝优化等。这些内容可以帮助你更好地理解和应用面向对象编程的核心理念,提升代码的健壮性、灵活性和可维护性。
【c++11】c++11新特性(上)(列表初始化、右值引用和移动语义、类的新默认成员函数、lambda表达式)
C++11为C++带来了革命性变化,引入了列表初始化、右值引用、移动语义、类的新默认成员函数和lambda表达式等特性。列表初始化统一了对象初始化方式,initializer_list简化了容器多元素初始化;右值引用和移动语义优化了资源管理,减少拷贝开销;类新增移动构造和移动赋值函数提升性能;lambda表达式提供匿名函数对象,增强代码简洁性和灵活性。这些特性共同推动了现代C++编程的发展,提升了开发效率与程序性能。
44 12
【C++进阶】特殊类设计 && 单例模式
通过对特殊类设计和单例模式的深入探讨,我们可以更好地设计和实现复杂的C++程序。特殊类设计提高了代码的安全性和可维护性,而单例模式则确保类的唯一实例性和全局访问性。理解并掌握这些高级设计技巧,对于提升C++编程水平至关重要。
52 16
类和对象(中 )C++
本文详细讲解了C++中的默认成员函数,包括构造函数、析构函数、拷贝构造函数、赋值运算符重载和取地址运算符重载等内容。重点分析了各函数的特点、使用场景及相互关系,如构造函数的主要任务是初始化对象,而非创建空间;析构函数用于清理资源;拷贝构造与赋值运算符的区别在于前者用于创建新对象,后者用于已存在的对象赋值。同时,文章还探讨了运算符重载的规则及其应用场景,并通过实例加深理解。最后强调,若类中存在资源管理,需显式定义拷贝构造和赋值运算符以避免浅拷贝问题。

热门文章

最新文章