【PAT甲级 - C++题解】1061 Dating

简介: 【PAT甲级 - C++题解】1061 Dating

1061 Dating


Sherlock Holmes received a note with some strange strings: Let's date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm. It took him only a minute to figure out that those strange strings are actually referring to the coded time Thursday 14:04 – since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter D, representing the 4th day in a week; the second common character is the 5th capital letter E, representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A to N, respectively); and the English letter shared by the last two strings is s at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.


Input Specification:


Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.


Output Specification:


For each test case, print the decoded time in one line, in the format DAY HH:MM, where DAY is a 3-character abbreviation for the days in a week – that is, MON for Monday, TUE for Tuesday, WED for Wednesday, THU for Thursday, FRI for Friday, SAT for Saturday, and SUN for Sunday. It is guaranteed that the result is unique for each case.


Sample Input:

3485djDkxh4hhGE 
2984akDfkkkkggEdsb 
s&hgsfdk 
d&Hyscvnm
• 1
• 2
• 3
• 4

Sample Output:

THU 14:04


思路


这题第一个输出的是星期,由第一个字符串和第二个字符串中相同位置的第一个相等的大写字母来判断,该大写字母在字母表中从 A AA 开始排第几,输出的就是星期几。

第二个输出的是小时,由第一个字符串和第二个字符串中相同位置的第二个相等的合法字符来判断,该合法字符的范围在 0 ∽ 9 0\backsim90∽9 ,且 10 1010 以后的数用 A ∽ N A\backsim NA∽N 来代替。

第三个输出的是分钟,由第三个字符串和第四个字符串中相同位置的第一个相等的字母来判断,第几个位置相等就输出多少,注意是从 0 00 开始。


代码

#include<bits/stdc++.h>
using namespace std;
int main()
{
    string wek[7] = { "MON","TUE","WED","THU","FRI","SAT","SUN" };
    string a, b;
    cin >> a >> b;
    //1.判断星期几
    int k = 0;
    while (1)
    {
        if (a[k] == b[k] && a[k] >= 'A' && a[k] <= 'G')    break;
        k++;
    }
    cout << wek[a[k] - 'A'] << " ";
    //2.判断多少小时
    k++;
    while (1)
    {
        if (a[k] == b[k] && (a[k] >= '0' && a[k] <= '9' || a[k] >= 'A' && a[k] <= 'N')) break;
        k++;
    }
    printf("%02d:", a[k] <= '9' ? a[k] - '0' : a[k] - 'A' + 10);
    //3.判断多少分钟
    k = 0;
    string c, d;
    cin >> c >> d;
    while (1)
    {
        if (c[k] == d[k] && (c[k] >= 'A' && c[k] <= 'Z' || c[k] >= 'a' && c[k] <= 'z'))
            break;
        k++;
    }
    printf("%02d\n", k);
    return 0;
}


目录
相关文章
|
10月前
|
C++
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
35 0
|
10月前
|
算法 C++
【PAT甲级 - C++题解】1044 Shopping in Mars
【PAT甲级 - C++题解】1044 Shopping in Mars
54 0
|
10月前
|
C++
【PAT甲级 - C++题解】1117 Eddington Number
【PAT甲级 - C++题解】1117 Eddington Number
49 0
|
10月前
|
存储 C++ 容器
【PAT甲级 - C++题解】1057 Stack
【PAT甲级 - C++题解】1057 Stack
48 0
|
10月前
|
存储 C++
【PAT甲级 - C++题解】1055 The World‘s Richest
【PAT甲级 - C++题解】1055 The World‘s Richest
58 0
|
10月前
|
C++
【PAT甲级 - C++题解】1051 Pop Sequence
【PAT甲级 - C++题解】1051 Pop Sequence
50 0
|
10月前
|
人工智能 BI C++
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
99 0
|
10月前
|
存储 定位技术 C++
【PAT甲级 - C++题解】1091 Acute Stroke
【PAT甲级 - C++题解】1091 Acute Stroke
35 0
|
10月前
|
存储 人工智能 C++
【PAT甲级 - C++题解】1085 Perfect Sequence
【PAT甲级 - C++题解】1085 Perfect Sequence
48 0
|
10月前
|
C++
【PAT甲级 - C++题解】1046 Shortest Distance
【PAT甲级 - C++题解】1046 Shortest Distance
48 0