【PAT甲级 - C++题解】1050 String Subtraction

简介: 【PAT甲级 - C++题解】1050 String Subtraction

1050 String Subtraction


Given two strings S1 and S2, S=S1−S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1−S2 for any given strings. However, it might not be that simple to do it fast.


Input Specification:


Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1−S2 in one line.



Sample Input:

They are students.
aeiou
• 1
• 2

Sample Output:

Thy r stdnts.


思路

用哈希表标记 b bb 串中所有字符。

枚举 a aa 串中所有字符,如果当前字符在哈希表中即在 b bb 串中已经出现过,就跳过,否则就加入 r e s resres 当中。

输出 r e s resres 。


代码

#include<bits/stdc++.h>
using namespace std;
int main()
{
    string a, b;
    getline(cin, a);
    getline(cin, b);
    //将b中所有字符放入哈希表标记
    unordered_map<char, bool> st;
    for (int i = 0; i < b.size(); i++)
        st[b[i]] = true;
    //枚举a中每个字符观察是否在哈希表中出现过
    string res = "";
    for (int i = 0; i < a.size(); i++)
        if (!st.count(a[i]))
            res += a[i];
    cout << res << endl;
    return 0;
}


目录
相关文章
|
2月前
|
C语言 C++ 容器
【c++丨STL】string模拟实现(附源码)
本文详细介绍了如何模拟实现C++ STL中的`string`类,包括其构造函数、拷贝构造、赋值重载、析构函数等基本功能,以及字符串的插入、删除、查找、比较等操作。文章还展示了如何实现输入输出流操作符,使自定义的`string`类能够方便地与`cin`和`cout`配合使用。通过这些实现,读者不仅能加深对`string`类的理解,还能提升对C++编程技巧的掌握。
81 5
|
2月前
|
存储 编译器 C语言
【c++丨STL】string类的使用
本文介绍了C++中`string`类的基本概念及其主要接口。`string`类在C++标准库中扮演着重要角色,它提供了比C语言中字符串处理函数更丰富、安全和便捷的功能。文章详细讲解了`string`类的构造函数、赋值运算符、容量管理接口、元素访问及遍历方法、字符串修改操作、字符串运算接口、常量成员和非成员函数等内容。通过实例演示了如何使用这些接口进行字符串的创建、修改、查找和比较等操作,帮助读者更好地理解和掌握`string`类的应用。
65 2
|
3月前
|
C++ 容器
|
3月前
|
存储 安全 C++
【C++打怪之路Lv8】-- string类
【C++打怪之路Lv8】-- string类
33 1
|
3月前
|
C++ 容器
|
3月前
|
C++ 容器
|
3月前
|
C语言 C++
深度剖析C++string(中)
深度剖析C++string(中)
62 0
|
3月前
|
存储 编译器 程序员
深度剖析C++string(上篇)(2)
深度剖析C++string(上篇)(2)
49 0
|
3月前
|
存储 Linux C语言
深度剖析C++string(上篇)(1)
深度剖析C++string(上篇)(1)
35 0
|
3月前
|
C++