【PAT甲级 - C++题解】1001 A+B Format

简介: 【PAT甲级 - C++题解】1001 A+B Format

1001 A+B Format


Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).



Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.


Output Specification:


For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9


Sample Output:

-999,991


思路


先将 a+b 的结果转换成字符串,方便处理,这里用到的库函数是 to_string(sum) ,它可以将数字 sum 转换成字符串。

在得到的字符串 x 中,从后往前进行遍历,每次遍历都将 x[i] 加入到答案字符串数组 res 中。注意是 res = x[i] + res ,因为是从后往前遍历,所以每次加入的数字要放在 res 左边。

通过对 j 取余来判断当前是否已经遍历了 3 个数字,除此之外还要注意遍历到第一个数字的情况,如果已经遍历到第一个数字,即使已经遍历了 3 个数字也不能加逗号。


代码

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int a, b;
    cin >> a >> b;
    //进行字符串转化
    string x = to_string(a + b);
    //从后往前遍历
    string res = "";
    for (int i = x.size() - 1, j = 0; i >= 0; i--)
    {
        j++;
        res = x[i] + res;
        //每遍历三个数字加一个逗号,但是要排除作为第一个数字的情况
        if (j % 3 == 0 && i && x[i - 1] != '-')  res = "," + res;
    }
    cout << res << endl;
    return 0;
}


目录
相关文章
|
C++
【PAT甲级 - C++题解】1040 Longest Symmetric String
【PAT甲级 - C++题解】1040 Longest Symmetric String
61 0
|
算法 C++
【PAT甲级 - C++题解】1044 Shopping in Mars
【PAT甲级 - C++题解】1044 Shopping in Mars
77 0
|
C++
【PAT甲级 - C++题解】1117 Eddington Number
【PAT甲级 - C++题解】1117 Eddington Number
70 0
|
存储 C++ 容器
【PAT甲级 - C++题解】1057 Stack
【PAT甲级 - C++题解】1057 Stack
69 0
|
存储 C++
【PAT甲级 - C++题解】1055 The World‘s Richest
【PAT甲级 - C++题解】1055 The World‘s Richest
74 0
|
C++
【PAT甲级 - C++题解】1051 Pop Sequence
【PAT甲级 - C++题解】1051 Pop Sequence
73 0
|
人工智能 BI C++
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
【PAT甲级 - C++题解】1148 Werewolf - Simple Version
121 0
|
存储 定位技术 C++
【PAT甲级 - C++题解】1091 Acute Stroke
【PAT甲级 - C++题解】1091 Acute Stroke
51 0
|
存储 人工智能 C++
【PAT甲级 - C++题解】1085 Perfect Sequence
【PAT甲级 - C++题解】1085 Perfect Sequence
66 0
|
C++
【PAT甲级 - C++题解】1046 Shortest Distance
【PAT甲级 - C++题解】1046 Shortest Distance
62 0