题目
本题目给出的射击比赛的规则非常简单,谁打的弹洞距离靶心最近,谁就是冠军;谁差得最远,谁就是菜鸟。本题给出一系列弹洞的平面坐标(x,y),请你编写程序找出冠军和菜鸟。我们假设靶心在原点(0,0)。
输入格式: 输入在第一行中给出一个正整数 N(≤ 10 000)。随后 N 行,每行按下列格式给出:
ID x y 其中 ID 是运动员的编号(由 4 位数字组成);x 和 y 是其打出的弹洞的平面坐标(x,y),均为整数,且 0 ≤ |x|, |y| ≤ 100。题目保证每个运动员的编号不重复,且每人只打 1 枪。
输出格式: 输出冠军和菜鸟的编号,中间空 1 格。题目保证他们是唯一的。
输入样例: 3 0001 5 7 1020 -1 3 0233 0 -1 结尾无空行 输出样例: 0233 0001 结尾无空行
解题思路
inputCount = int(input()) # inputCount = 3 menberNoList = [] menberLengthList = [] for i in range(inputCount): inputList = input().split(" ") # inputList = "0001 5 7".split(" ") menberNoList.append(inputList[0]) x = abs(int(inputList[1])) y = abs(int(inputList[2])) # 可以用平方根,但这样少算一层 length = x*x + y*y menberLengthList.append(length) #获取最长最短距离的index maxIndex = menberLengthList.index(max(menberLengthList)) minIndex = menberLengthList.index(min(menberLengthList)) print(str(menberNoList[minIndex]) + " " + str(menberNoList[maxIndex]))