PAT甲级 1007. Maximum Subsequence Sum(25分) 复杂度优化到O(n)

简介: PAT甲级 1007. Maximum Subsequence Sum(25分) 复杂度优化到O(n)

1007. Maximum Subsequence Sum(25分)


Given a sequence of K integers { N1, N2, …, N**K }. A continuous subsequence is defined to be { N**i, N**i+1, …, N**j } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.


Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.


Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.


Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.


Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21
结尾无空行


Sample Output:

10 1 4
结尾无空行
#include <iostream>
using namespace std;
int main()
{
    int N;
    cin >> N;
    int A[N];
    for (int i = 0; i < N; i++)
    {
        cin >> A[i];
    }
    // 最大子序列和:在线处理,直接累加,如果累加到当前的和为负数,置当前值或0 时间复杂度N
    int sum = 0, maxsum = -1, start = 0, end = N - 1, index = 0;
    for (int i = 0; i < N; i++)
    {
        sum += A[i];
        if (sum < 0)
        {
            index = i + 1;
            sum = 0;
        }
        else if (sum > maxsum)
        {
            maxsum = sum;
            start = index;
            end = i;
        }
    }
    if (maxsum < 0)
    {
        maxsum = 0;
    }
    cout << maxsum << " " << A[start] << " " << A[end];
    return 0;
}


时间复杂度:O ( n ) ,直接一遍遍历,更新最大值,如果 s u m < 0 ,说明前面这段对我的子序列来说,只会产生负反馈,所以直接剔除。


卡壳的主要原因是英文水平不行,又或者说没有仔细阅读题目。together with the first and the last numbers of the maximum subsequence,好好看看它的意思,求的是元素而不是索引。

目录
相关文章
|
6月前
|
算法
poj 2479 Maximum sum(求最大子段和的延伸)
看完最大连续子段和 的 dp算法 这个很容易理解,我用dplift[i]保存第1到第i个之间的最大子段和,dpright[i]保存第i到第n个之间的最大子段和,最终结果就是dplift[i]+dpright[i+1]中最大的一个。
28 0
|
7月前
|
Go
Shortest Path with Obstacle( CodeForces - 1547A )(模拟)
Shortest Path with Obstacle( CodeForces - 1547A )(模拟)
28 0
|
10月前
|
C++
【PAT甲级 - C++题解】1007 Maximum Subsequence Sum
【PAT甲级 - C++题解】1007 Maximum Subsequence Sum
53 0
|
10月前
|
存储 人工智能 C++
【PAT甲级 - C++题解】1104 Sum of Number Segments
【PAT甲级 - C++题解】1104 Sum of Number Segments
52 0
|
10月前
|
C++
【PAT甲级 - C++题解】1145 Hashing - Average Search Time
【PAT甲级 - C++题解】1145 Hashing - Average Search Time
57 0
PTA 1083 是否存在相等的差 (20 分)
给定 N 张卡片,正面分别写上 1、2、……、N,然后全部翻面,洗牌,在背面分别写上 1、2、……、N。
46 0
|
机器学习/深度学习
Codeforces1499——C. Minimum Grid Path(思维+分奇偶+贪心)
Codeforces1499——C. Minimum Grid Path(思维+分奇偶+贪心)
65 0
PAT甲级 1010. Radix (25分)
PAT甲级 1010. Radix (25分)
57 0
|
算法
【PTA】01-复杂度1 最大子列和问题 (20分)
【PTA】01-复杂度1 最大子列和问题 (20分)
688 0