PAT甲级 1007. Maximum Subsequence Sum(25分) 复杂度优化到O(n)

简介: PAT甲级 1007. Maximum Subsequence Sum(25分) 复杂度优化到O(n)

1007. Maximum Subsequence Sum(25分)


Given a sequence of K integers { N1, N2, …, N**K }. A continuous subsequence is defined to be { N**i, N**i+1, …, N**j } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.


Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.


Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.


Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.


Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21
结尾无空行


Sample Output:

10 1 4
结尾无空行
#include <iostream>
using namespace std;
int main()
{
    int N;
    cin >> N;
    int A[N];
    for (int i = 0; i < N; i++)
    {
        cin >> A[i];
    }
    // 最大子序列和:在线处理,直接累加,如果累加到当前的和为负数,置当前值或0 时间复杂度N
    int sum = 0, maxsum = -1, start = 0, end = N - 1, index = 0;
    for (int i = 0; i < N; i++)
    {
        sum += A[i];
        if (sum < 0)
        {
            index = i + 1;
            sum = 0;
        }
        else if (sum > maxsum)
        {
            maxsum = sum;
            start = index;
            end = i;
        }
    }
    if (maxsum < 0)
    {
        maxsum = 0;
    }
    cout << maxsum << " " << A[start] << " " << A[end];
    return 0;
}


时间复杂度:O ( n ) ,直接一遍遍历,更新最大值,如果 s u m < 0 ,说明前面这段对我的子序列来说,只会产生负反馈,所以直接剔除。


卡壳的主要原因是英文水平不行,又或者说没有仔细阅读题目。together with the first and the last numbers of the maximum subsequence,好好看看它的意思,求的是元素而不是索引。

目录
相关文章
|
算法
poj 2479 Maximum sum(求最大子段和的延伸)
看完最大连续子段和 的 dp算法 这个很容易理解,我用dplift[i]保存第1到第i个之间的最大子段和,dpright[i]保存第i到第n个之间的最大子段和,最终结果就是dplift[i]+dpright[i+1]中最大的一个。
50 0
|
存储 人工智能 C++
【PAT甲级 - C++题解】1104 Sum of Number Segments
【PAT甲级 - C++题解】1104 Sum of Number Segments
78 0
|
C++
【PAT甲级 - C++题解】1007 Maximum Subsequence Sum
【PAT甲级 - C++题解】1007 Maximum Subsequence Sum
86 0
|
机器学习/深度学习
Codeforces1499——C. Minimum Grid Path(思维+分奇偶+贪心)
Codeforces1499——C. Minimum Grid Path(思维+分奇偶+贪心)
93 0
CF1181B.Split a Number(贪心+高精度)
CF1181B.Split a Number(贪心+高精度)
94 0
|
算法 Java
Minimum Coins(找到最小数量的硬币)
Minimum Coins(找到最小数量的硬币)
383 0
Minimum Coins(找到最小数量的硬币)
|
算法 Java C语言
LeetCode 200:岛屿数量 Number of Islands
题目: 给定一个由 '1'(陆地)和 '0'(水)组成的的二维网格,计算岛屿的数量。一个岛被水包围,并且它是通过水平方向或垂直方向上相邻的陆地连接而成的。你可以假设网格的四个边均被水包围。 Given a 2d grid map of '1's (land) and '0's (water), count the number of islands.
819 0